3560 error

Unanswered Question
May 19th, 2008

I have a 3560 switch and I am getting the following error.

Base ethernet MAC Address: 00:1f:c9:96:60:80

Xmodem file system is available.

The password-recovery mechanism is enabled.

Initializing Flash...

flashfs[0]: 452 files, 6 directories

flashfs[0]: 0 orphaned files, 0 orphaned directories

flashfs[0]: Total bytes: 15998976

flashfs[0]: Bytes used: 2176512

flashfs[0]: Bytes available: 13822464

flashfs[0]: flashfs fsck took 8 seconds.

...done Initializing Flash.

Boot Sector Filesystem (bs) installed, fsid: 3


Loading "flash:c3560-ipbase-mz.122-35.SE5/c3560-ipbase-mz.122-35.SE5.bin"...flash:c3560-ipbase-mz.12

2-35.SE5/c3560-ipbase-mz.122-35.SE5.bin: no such file or directory

Error loading "flash:c3560-ipbase-mz.122-35.SE5/c3560-ipbase-mz.122-35.SE5.bin"

Interrupt within 5 seconds to abort boot process.

Boot process failed...

The system is unable to boot automatically. The BOOT

environment variable needs to be set to a bootable



Can some one please direct me to a fix?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Wantser1981_2 Mon, 05/19/2008 - 07:00

Have you tried to upgrade this and this has happened since?

Do you end up in ROMMON mode?

Are you sure that that image is available on that path on the directory?

What do you see when you issue "dir"?

Sorry for all the questions but, it looks as though it maybe that the boot image needs to be pointed somewhere else if, like I am sure we have all done, you may have inadvertantly put the image.bin in a different place.


steve-harris Mon, 05/19/2008 - 07:06

Thanks for the swift reply Andy.

One of the guys tried to upgrade the SW, hence the problems. He said that it did not go to rommon mode just the mode switch:

switch: dir

List of filesystems currently registered:

flash[0]: (read-write)

xmodem[1]: (read-only)

null[2]: (read-write)

bs[3]: (read-only)

switch: ?

? -- Present list of available commands

boot -- Load and boot an executable image

cat -- Concatenate (type) file(s)

copy -- Copy a file

delete -- Delete file(s)

dir -- List files in directories

flash_init -- Initialize flash filesystem(s)

format -- Format a filesystem

fsck -- Check filesystem consistency

help -- Present list of available commands

load_helper -- Load and initialize a helper image

memory -- Present memory heap utilization information

mkdir -- Create dir(s)

more -- Concatenate (display) file(s)

rename -- Rename a file

reset -- Reset the system

rmdir -- Delete empty dir(s)

set -- Set or display environment variables

set_bs -- Set attributes on a boot sector filesystem

set_param -- Set system parameters in flash

sleep -- Pause (sleep) for a specified number of seconds

-- MORE --

trap -- Cause a software breakpoint to occur

type -- Concatenate (type) file(s)

unset -- Unset one or more environment variables

version -- Display boot loader version




mahmoodmkl Mon, 05/19/2008 - 07:10


from the switch prompt cau do

dir flash:

and see if u find any files in that.if there is any file try boot flash:filename.

if u didnt find any file in the flash then u need to do xmodem recovery for the IOs.



steve-harris Mon, 05/19/2008 - 07:13

Hi Mahmood.

switch: dir flash:

Directory of flash:/

5 drwx 128 c3560-ipbase-mz.122-35.SE5

13822464 bytes available (2176512 bytes used)


mahmoodmkl Mon, 05/19/2008 - 07:19



switch:boot flash:c3560-ipbase-mz.122-35.SE5\c3560-ipbase-mz.122-35.SE5 .bin

and can u do a

cd c3560-ipbase-mz.122-35.SE5




steve-harris Mon, 05/19/2008 - 07:29


switch: boot flash:c3560-ipbase-mz.122-35.SE5\c3560-ipbase-mz.122-35.SE5.bin

Loading "flash:c3560-ipbase-mz.122-35.SE5\c3560-ipbase-mz.122-35.SE5.bin"...flash:c3560-ipbase-mz.12

2-35.SE5\c3560-ipbase-mz.122-35.SE5.bin: no such file or directory

Error loading "flash:c3560-ipbase-mz.122-35.SE5\c3560-ipbase-mz.122-35.SE5.bin"

Interrupt within 5 seconds to abort boot process.

Boot process failed...

switch: cd c:3560-ipbase-mz.122-35.SE5

Unknown cmd: cd


Wantser1981_2 Mon, 05/19/2008 - 07:13

Try dir flash.

Looks like the file path is wrong to me as that output is basically rommon. It maybe that the new image is directly on flash:image.bin rather than in the folder currently specified. The folder may also not exist, which dir flash will show.


Wantser1981_2 Mon, 05/19/2008 - 07:23

It ok, you already did it.

"dir flash:"

slilght slip of the keyboard!

You need to see what is in the flash:c3560-ipbase-mz.122-35.SE5 folder.

I think,

"dir flash:c3560-ipbase-mz.122-35.SE5\"

should show you what is in there. I am guessing the 122-35 is the old image and the new one will be in there, but under a different name.


steve-harris Mon, 05/19/2008 - 07:54


switch: dir flash:c3560-ipbase-mz.122-35.SE5\

unable to stat flash:c3560-ipbase-mz.122-35.SE5\/: no such file or directory


Wantser1981_2 Mon, 05/19/2008 - 07:57

Sorry. Getting towards the end of the day!

Try the end slash the other way

"switch: dir flash:c3560-ipbase-mz.122-35.SE5/"

steve-harris Mon, 05/19/2008 - 08:03

switch: dir flash:c3560-ipbase-mz.122-35.SE5/

Directory of flash:c3560-ipbase-mz.122-35.SE5//

7 drwx 4160 html

462 -rwx 422 info

13822464 bytes available (2176512 bytes used)


Richard Burts Mon, 05/19/2008 - 08:13


I believe that this information helps understand what is going on. In the c3560-ipbase-mz.122-35.SE5 directory there should be an image file but there is not. I would assume that the prior attempt to upgrade the image of the switch removed the old image (file and directory), built a new directory, but was not successful in copying the new image file into the new directory on flash.

If that is correct then your recovery is to get an image file on a server and to use xmodem to transfer the new image to flash.



Mark Yeates Mon, 05/19/2008 - 08:16

Make sure you mount the flash first.


Then you can dir flash:/


Richard Burts Mon, 05/19/2008 - 07:26


I am confused. In a previous post we got this:

Hi Mahmood.

switch: dir flash:

Directory of flash:/

5 drwx 128 c3560-ipbase-mz.122-35.SE5

13822464 bytes available (2176512 bytes used)


and now it appears that the dir command is not recognized. Has something changed on the switch?

The previous dir command shows that this is a directory: c3560-ipbase-mz.122-35.SE5. If you get the dir command to work again it would be helpful to see the output of

dir flash:c3560-ipbase-mz.122-35.SE5/

that might indicate whether your boot image is really there or not.



ronbuchalski Mon, 06/16/2008 - 11:24


I read through this thread, and I hope that you were able to get the problem resolved.

The problem appears to be that the image file that the switch was trying to load was not located in the directory it was pointed to. Newer Cisco devices (including the C3560) put the image file in a subdirectory with the same name as the image, so it can be confusing.

Note that this is not a requirement for the image file to be in a separate subdirectory, and that the easiest way to remedy this is to re-format the flash media and put the image file in the root directory of the flash media.

In any case, simply following the password recovery procedure for this switch would allow you to specify from rommon which image to load. It's a manual process, but it is the direct process, and does not rely on you putting boot information into the configuration file and relying on the switch to read the configuration file to determine where the boot image is.

Hope this helps (you or someone reading through this archive someday...)

Ron Buchalski

steve-harris Mon, 06/16/2008 - 11:46

Hi Ron,

Yes thanks to all the replies I found a fix in X-MODEM. I am now up and running again.


ronbuchalski Mon, 06/16/2008 - 12:04

So, your co-worker ended up blowing away the IOS imge and not installing any image on the switch?

I did that the first time I tried to upgrade the IOS on the 3560. I had deleted the existing image from flash (via format flash: command), and inadvertently rebooted the switch befor I put another IOS image on it.

And yes, I also had to deal with x-modem.

Glad to hear that you resolved ths issue.

Ron Buchalski

glen.grant Mon, 06/16/2008 - 16:41

Myself I just delete the directory and use the .bin file its easier if you don't need gui function .


This Discussion