HUM - Interface Utilization

Unanswered Question
May 19th, 2008

Hello!

I have my router forwarding packets at that speed:

30 second input rate 982418000 bits/sec, 91133 packets/sec

30 second output rate 982413000 bits/sec, 91130 packets/sec

However, HUM shows only 10% load on the link (I have around 936Mbit/s which should be around 93%)!

Regards,

Vladislav

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
GRAEME DANIELSON Mon, 05/19/2008 - 20:25

I am on an eval of HUM and just noticed today I have the same problem. Did a search before posting and found your question, so I'll get in the queue.

I have two GbE interfaces back to back - one a 6500 Sup32 port, the other a 3750 port. While traffic is maxed out in one direction HUM never show more than about 7% util for both interfaces.

Sample "sh int" from the 3750 below, HUM graphs this as 5% RxUtil and also about 5% TxUtil

GigabitEthernet2/0/52 is up, line protocol is up (connected)

Hardware is Gigabit Ethernet, address is 0021.1bf1.2034 (bia 0021.1bf1.2034)

Description: CWDM-1490 Link to Prod via fibre

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 11/255, rxload 221/255

Encapsulation ARPA, loopback not set

Keepalive not set

Full-duplex, 1000Mb/s, link type is auto, media type is CWDM-1490 SFP

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:33, output 00:00:07, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

30 second input rate 869991000 bits/sec, 99076 packets/sec

30 second output rate 44243000 bits/sec, 62783 packets/sec

5351330258 packets input, 5188871774044 bytes, 0 no buffer

Received 10773626 broadcasts (0 multicasts)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 4391875 multicast, 0 pause input

0 input packets with dribble condition detected

3101535098 packets output, 312164650488 bytes, 0 underruns

0 output errors, 0 collisions, 2 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

Note that I have checked on a 2800 router Ethernet interface and HUM seems accurate for these.

Joe Clarke Mon, 05/19/2008 - 20:55

Both of you are making a potentially erroneous calculation. This output shows a 30 second sample. HUM is most likely running a sample over 5 minutes. The 5 minute sample rate could potentially be much lower.

The easiest way to see what HUM is seeing is to get a sniffer trace filtering on udp/161 traffic to this device for a period of twice the HUM polling interval (e.g. 10 minutes if the polling interval is 5 minutes). This way, the math can be applied using the exact same data HUM is seeing.

It may also reveal the HUM is using the wrong objects to collect interface utilization.

GRAEME DANIELSON Mon, 05/19/2008 - 21:33

I understand what you're saying but the two interfaces I described have been running at 90%+ for 4 hours and HUM still says <10%

Will go back and check the poller though see if I can see anything untoward there. As I said it looks correct for at least two other device's Ethernet interfaces I've bothered to check on.

v.vasilev Mon, 05/19/2008 - 22:25

I've got this problem on SPA-2X1GE (SIP-400) and 7609 router. I am currently running some tests so the router has been forwarding at that rate for more than 24 hours now.

I haven't come across this problem with my other device being monitored by HUM - Catalyst 3750 and a Gigabit Ethernet uplink. Check out the screenshot.

Regards,

Vladislav

Attachment: 
Joe Clarke Mon, 05/19/2008 - 23:04

Again, the thing that's going to help identify the problem is the sniffer trace. This will rule out problems on the device side, and calculation problems on HUM's side.

k.abillama Tue, 04/07/2009 - 09:26

Hi Guys, I have a similar issue, please let me know the results of this conversation, thx

Actions

This Discussion