multicast not flowing...hsrp issue?

Unanswered Question
May 19th, 2008
User Badges:

Please see attached topology, configs and explanation as well.


|------------|--vlan35--|--vlan113--|


****FILLER*******/---SW1----\

R1--R2--R3---L2**FILLER**L2----R4

****FILLER*******\---SW2----/


summary:

All L3 interfaces have pim sparse-mode enabled.

All SVI on SW1/2 (3560s) have pim sparse mode enabled.

L2 switches have igmp snooping disabled (3550s)

SW1 and SW2 are L3 switches doing HSRP on vlan 35 and 113.

Receiver R4 gateway is pointing to the vlan 113 hsrp address.

R3's route to R4's network points to the vlan 35 hsrp address.

unicast routing works great.

R4 can ping all the way through and visa versa.

SW1 is HSRP active router on both vlans

PIM DR on vlan 35 is R3

PIM DR on vlan 113 is SW1


Issue:

R4's f0/0 is configured with ip igmp joing-group 224.10.10.10

R1 sends pings to 224.10.10.10 and gets no reply.


Is there something wrong with the configs?


Debug ip mpacket on R3 shows that it is sending the packets onto vlan 35.


debug ip mpacket show nothing on SW1 or SW 2.


Please see attached configs.


thanks,


Bryan



Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
amritpatek Fri, 05/23/2008 - 06:10
User Badges:
  • Silver, 250 points or more

Using Multicast with HSRP. When using multicast in an HSRP environment, care must be used in configuring multicast with the physical IP address as opposed to the HSRP logical address as the IP Address. If the HSRP address is used, multicast traffic will not be sent.

Follow URL for the HSRP and IP multicasting Troubleshooting :

http://www.cisco.com/en/US/tech/tk648/tk362/technologies_tech_note09186a0080094afd.shtml


http://www.cisco.com/en/US/tech/tk828/technologies_tech_note09186a0080094b55.shtml



Actions

This Discussion