Port keeps err disable because of printers on other floors

Unanswered Question
May 20th, 2008

This morning, I had a switchport go into err disable state. I checked the log and the err-disable was caused by a printer on a different floor. I cleared the mac-address sticky and it went err-disable again. I checked the log again and the mac-address causing the issue was a different printer. This has repeated 3 times more with a different printer everytime. Connected to the port is a 7941 phone with a PC connected to the phone.

Has anyone have any ideas? Weird? I am running c3560-ipbasek9-mz.122-25.SEE2.bin

All closet switches connect to a 4503 switch.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
didyap Mon, 05/26/2008 - 16:22

It seem pretty clear that the issue is been caused by the printer and making the ports it is connected to goes to err-disable, the (show interfaces fastEthernet [port] status err-disabled) will allow us to know what is causing the port to go error disable.

ralphcarter Tue, 05/27/2008 - 04:55

You are probably violating the allowed mac address entries for your port-security quota.

Check to see how many devices are connected through this port and do n+1. It seems like when your printer responds to an arp broadcast, the switch records the mac-address and your port-security shutsdown the port due to the violation.

When you fix the problem you can also setup err-disable recovery, so it re-enables byitself after x amount of time.

m_zabetian Tue, 05/27/2008 - 09:00

please try to add this command at that port

switchport port-security maximum 2 (or 3)

I possible because of cisco phone you reach to your MAC limit


This Discussion