debug status not display

Unanswered Question
May 20th, 2008
User Badges:

Hi


I am trying to debug bgp all and its not display any thing, is there any configuration for the same.

interface Loopback0

ip address 192.168.40.40 255.255.255.255

!

interface FastEthernet0

ip address 10.97.37.211 255.255.255.0

speed auto

!

interface Serial0

ip address 192.168.30.1 255.255.255.0

encapsulation frame-relay

frame-relay interface-dlci 200

frame-relay lmi-type ansi

!

interface Serial1

ip address 172.26.8.1 255.255.255.0

!

router bgp 65003

no synchronization

bgp log-neighbor-changes

redistribute connected

neighbor 192.168.40.30 remote-as 65003

neighbor 192.168.40.30 update-source Loopback0

no auto-summary

!

ip route 192.168.40.0 255.255.255.0 192.168.30.2

ip route 192.168.40.0 255.255.255.255 192.168.30.2

!

!

no ip http server

no ip http secure-server

!


Regards,

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ankbhasi Wed, 05/21/2008 - 01:25
User Badges:
  • Cisco Employee,

Hi Manju,


Have you telnetted into the router/switch and then enabling debug? If yes issue a command "terminal monitor" and then update if you see anything in debugs or not?


Regards,


Ankur


*Pls rate all helpfull post

ntmanjunath Wed, 05/21/2008 - 02:24
User Badges:

Hi Ankur,

Yes am telnetted to router.


Where to configure this command ? "terminal monitor"


Regards,

cisco_lad2004 Wed, 05/21/2008 - 02:23
User Badges:
  • Gold, 750 points or more

in addition to previous reply , u may want to logg to memory. add commmand "logging buffered X" where X is the memory amount you choose ( I have it set to 100,000.


HTH


Sam

ntmanjunath Wed, 05/21/2008 - 02:46
User Badges:

Hi,


I added the command "logging buffered 100,000 "and still its not showing anything.


regards,



Pravin Phadte Wed, 05/21/2008 - 02:55
User Badges:
  • Silver, 250 points or more

did u tried the terminal monitor


router#terminal monitor

router#terminal no monitor

cisco_lad2004 Wed, 05/21/2008 - 03:08
User Badges:
  • Gold, 750 points or more

try "logging monitor debugging "


in ur case Router(config)# logging monitor 7 ( to include debugging).


HTH


Sam

ntmanjunath Wed, 05/21/2008 - 03:35
User Badges:

I added the configuration and still the problem is same.



AIRTEL-PE1(config)#logging monitor ?

<0-7> Logging severity level

alerts Immediate action needed (severity=1)

critical Critical conditions (severity=2)

debugging Debugging messages (severity=7)

discriminator Establish MD-Console association

emergencies System is unusable (severity=0)

errors Error conditions (severity=3)

filtered Enable filtered logging

informational Informational messages (severity=6)

notifications Normal but significant conditions (severity=5)

warnings Warning conditions (severity=4)

xml Enable logging in XML


AIRTEL-PE1(config)#logging monitor 7

AIRTEL-PE1(config)#logging monitor debb

AIRTEL-PE1(config)#logging monitor deb

AIRTEL-PE1(config)#logging monitor debugging

AIRTEL-PE1(config)#logging monitor ?

<0-7> Logging severity level

alerts Immediate action needed (severity=1)

critical Critical conditions (severity=2)

debugging Debugging messages (severity=7)

discriminator Establish MD-Console association

emergencies System is unusable (severity=0)

errors Error conditions (severity=3)

filtered Enable filtered logging

informational Informational messages (severity=6)

notifications Normal but significant conditions (severity=5)

warnings Warning conditions (severity=4)

xml Enable logging in XML


AIRTEL-PE1(config)#logging monitor 7

AIRTEL-PE1(config)#logging monitor debb

AIRTEL-PE1(config)#logging monitor deb

AIRTEL-PE1(config)#logging monitor debugging


AIRTEL-PE1(config)#logging monitor ?

<0-7> Logging severity level

alerts Immediate action needed (severity=1)

critical Critical conditions (severity=2)

debugging Debugging messages (severity=7)

discriminator Establish MD-Console association

emergencies System is unusable (severity=0)

errors Error conditions (severity=3)

filtered Enable filtered logging

informational Informational messages (severity=6)

notifications Normal but significant conditions (severity=5)

warnings Warning conditions (severity=4)

xml Enable logging in XML


AIRTEL-PE1(config)#logging monitor 7

AIRTEL-PE1(config)#logging monitor debb

AIRTEL-PE1(config)#logging monitor deb

AIRTEL-PE1(config)#logging monitor debugging


cisco_lad2004 Wed, 05/21/2008 - 04:18
User Badges:
  • Gold, 750 points or more

pls paste a show logg output, just 1st few lines.


Thanks


Sam

ntmanjunath Wed, 05/21/2008 - 23:48
User Badges:

Please see the output.


AIRTEL-PE1#sh logging

Syslog logging: enabled (1 messages dropped, 0 messages rate-limited,

0 flushes, 0 overruns, xml disabled, filtering disabled)


No Active Message Discriminator.




No Inactive Message Discriminator.



Console logging: level debugging, 3703 messages logged, xml disabled,

filtering disabled

Monitor logging: level debugging, 0 messages logged, xml disabled,

filtering disabled

Buffer logging: level debugging, 17 messages logged, xml disabled,

filtering disabled

Logging Exception size (4096 bytes)

Count and timestamp logging messages: disabled


No active filter modules.


Trap logging: level informational, 3349 message lines logged


Log Buffer (100000 bytes):

cisco_lad2004 Thu, 05/22/2008 - 00:01
User Badges:
  • Gold, 750 points or more

Ur config looks ok, u are getting messages on console logging and buffered but not on monitor mode.


1-are there no BGP log messages when u do show log ?

2-debug while u have terminal monitor on.

3-try to create BGP logs by creating a dummy session where there is no other BGP peer at other end.


HTH


Sam


ntmanjunath Thu, 05/22/2008 - 01:00
User Badges:

Please see the output.


Syslog logging: enabled (1 messages dropped, 0 messages rate-limited,

0 flushes, 0 overruns, xml disabled, filtering disabled)


No Active Message Discriminator.




No Inactive Message Discriminator.



Console logging: level debugging, 3704 messages logged, xml disabled,

filtering disabled

Monitor logging: level debugging, 0 messages logged, xml disabled,

filtering disabled

Buffer logging: level debugging, 18 messages logged, xml disabled,

filtering disabled

Logging Exception size (4096 bytes)

Count and timestamp logging messages: disabled


No active filter modules.


Trap logging: level informational, 3350 message lines logged

cisco_lad2004 Thu, 05/22/2008 - 03:27
User Badges:
  • Gold, 750 points or more

u must have some lines in log, since I see


"Buffer logging: level debugging, 18 messages logged, xml disabled, "



Actions

This Discussion