Newbie - 1242AG basic configuration

Unanswered Question
May 21st, 2008
User Badges:

We have just purchased a 1242AG and I am trying to configure it. In the web interface, when information is entered in the express setup and express security screens, and I "apply" it, nothing is saved. Is there something obvious that I am missing?

Thanks,

Alan

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jeromehenry_2 Thu, 05/22/2008 - 03:35
User Badges:
  • Silver, 250 points or more

If you click Apply in the right place, it SHOULD take it. The Apply buttons are some time a bit confusing, you may have several of them on the same page and you have to click the one that applies to the setting that you are actually changing.

Express setup is an easy place to start from. Try to change the community or AP name for example.

Then if you down on the left menu, try to see if the resulting configuration does take it into consideration...

HSS_cisco Thu, 05/22/2008 - 06:41
User Badges:

That is my impression too, it SHOULD take it. I have tried changing the AP name via the Express Setup, but the change does not take. I have also tried setting an SSID via the Express Security screen, but that does not take either. I am wondering whether I have a defective unit.

HSS_cisco Thu, 05/22/2008 - 11:47
User Badges:

I had avoided the cli because of its complexity. However I have been giving it a try. First Question: one is in exec mode when one first logs in via telnet. So I try to get into privileged exec mode so I can change configuration.

ap>enable

% Error in authentication

How do I avoid that error? (I logged in using the default id/pswd and no the antennae are not turned on yet.)

HSS_cisco Thu, 05/22/2008 - 12:47
User Badges:

Ok,so I tried:


login via telnet

ap>default uid Cisco pwd Cisco

^

%Invalid input detected at "^" marker


So how is that cmd used?

HSS_cisco Fri, 05/23/2008 - 08:19
User Badges:

I tried that:

ap>en

% Error in authentication


What I am trying to do is setup a very basic 2.4GHz access point with WEP 128bit encryption and accepting only a very short list of MAC addresses. I would think this would take a config of only a few lines. If you could do a draft that would be very appreciated.

HSS_cisco Fri, 05/23/2008 - 08:25
User Badges:

The AP will be interacting with hardware devices that unfortunately run only WEP.

HSS_cisco Fri, 05/23/2008 - 08:45
User Badges:

The part number is AIR-AP1242AG-A-K9. And I believe it's the autonomous version but how do I tell for sure? The web interface to the unit shows system software as: c1240-k9w7-tar.124-10b.jA with a version of 12.4(10b)jA

HSS_cisco Tue, 05/27/2008 - 06:38
User Badges:

Ok, I have made headway. Using a combination of the web interface and the CLI, I have the 1242AG partially configured. My question now is in the CLI how does one turn on broadcasting of the SSID so clients can see it?

vunnikri Tue, 05/27/2008 - 06:44
User Badges:
  • Cisco Employee,

you can turn on broadcast ssid from the following config commands


ap#conf t

Enter configuration commands, one per line. End with CNTL/Z.

ap(config)#dot11 ssid test

ap(config-ssid)#guest-mode


guest-mode is the command that gets the ssid to broadcast.

HSS_cisco Tue, 05/27/2008 - 07:14
User Badges:

Ok, I tried:

ap(config)# dot11 ssid test

ap(config-ssid)# guest-mode

ap(config-ssid)# exit

ap(config)# interface dot11radio 0

ap(config-if)# ssid test

ap(config-if)# channel 8

ap(config-if)# encryption key 1 size 128Bit akey

ap(config-if)# no shutdown

ap(config-if)# exit

I still cannot see the ssid, but from the flashing lights on the 1242AG I can see the radio is active. What am I missing?

vunnikri Thu, 05/22/2008 - 12:15
User Badges:
  • Cisco Employee,

Hey alan,


Apply might not seem to work correctly in the GUI if you are using a web browser like, mozilla or opera.


Try IE and i hope it works for you.

HSS_cisco Thu, 05/22/2008 - 12:53
User Badges:

I am using Firefox on linux. Due to circumstances, it would be very awkward getting this onto Windows to use IE. I hope Cisco didn't go only for IE, their documentation says netscape. In my short experience the web interface seems so thoughly broken as to not be worthwhile attempting to use.

vunnikri Thu, 05/22/2008 - 12:57
User Badges:
  • Cisco Employee,

cisco supports both IE and netscape, yes you are correct that web interface does not work expected in other browser..


else i will say CLI is the way to go.


vivek

Actions

This Discussion