Will ACE work with DHCP request and loadbalancing

Unanswered Question
May 21st, 2008

Hi,

We are facing an issue with ACE-DHCP load balancing,we have some x vlan ,which is behind FWSM and CNR server server is in vlan x.The IP is 192.x.x.x which is behind FWSM,and ace VIP is 192.x.x.x.

The real problem is when we bypass the ACE from MSFC..the client DHCP request is going to CNR and picking up the IP,but when we revert back the ACE,and the request is not going to CNR,client are getting limited connectvity.

here is the ACE config

probe udp CNRProbe

port 67

interval 30

faildetect 2

passdetect interval 30

passdetect count 2

rserver host CNR-1

ip address 192.x.x.62

inservice

rserver host CNR-2

ip address 192.x.x.63

inservice

serverfarm host CNR-SF

failaction purge

rserver CNR-1

inservice

rserver CNR-2

inservice

class-map match-all DHCP-VIP

2 match virtual-address 192.x.x.60 udp eq 67

class-map type management match-any REMOTE-ACCESS

2 match protocol icmp any

policy-map type management first-match REMOTE-MGMT

class REMOTE-ACCESS

permit

policy-map type loadbalance first-match DHCP-Server

class class-default

serverfarm CNR-SF

interface vlan xx

description clientside

bridge-group xx

no normalization

no icmp-guard

access-group input OSS

access-group output OSS

service-policy input REMOTE-MGMT

service-policy input Serverfarm-Policy

no shutdown

interface vlan y

description serverside

bridge-group XX

access-group input OSS

access-group output OSS

no shutdown

interface bvi 5

ip address x.x.x.x

alias x.x.x.x

peer ip address x.x.x.x

no shutdown

ip route 0.0.0.0 0.0.0.0 x.x.x.x

Will we able to loadbalance the DHCP server by ACE in real time? coz DHCP using 2 ports,will ace can do ? We used to assign CNR VIP to user vlan..any who had experence on this kind of problem pls share,that will be gratefull.

Saji k.s

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Gilles Dufour Thu, 05/22/2008 - 00:28

you should sniff the traffic from ACE tengig interface using a NAM or a PC.

See what traffic the client sends and what ACE does with it.

From there we can figure it out if there is something we can add to the config to make it work.

Gilles.

prakashj Thu, 05/22/2008 - 09:20

Hi,

I tried to do the same,but I could not able to find the port which your talking about,can you specifie bit more,that will be gratefull.Is this logical port of ACE.

Actions

This Discussion