EIGRP error

Answered Question
May 21st, 2008

I have a 4506 with about 30 SVI's. I have a connection through a metro service provider for a branch with a 3560 in layer 3. It has a few SVI's on it. I am running EIGRP between the 3560 and my 4506. router eigrp 100, network 10.0.0.0, auto sum. The problem is on the 3560 i keep getting a "IP-EIGRP(Default-IP-Routing-Table:100): Neighbor 10.0.34.1 not on common subnet for Vlan1" I have double checked the configs and i have vlan 34 configured correctly. it is configured just like all of my other SVI's on the 4506. why would i be getting this error? The configuration works great, the error just keeps showing up in the log

Correct Answer by Edison Ortiz about 8 years 9 months ago

I'm not questioning your design. When I ask a question is for a reason. I asked before if you were trunking the interface and you said no. About 5 responses later, it comes to light that you are trunking. That was a time wasted for you and for me.

Again, I asked you if you were pruning the Vlans and you said you are only sending Vlan 1 towards the ISP. The portion of the config above clearly indicates that you aren't pruning and all the Vlans are being forwarded to the HP switch. You don't want that as it can create problems. You have no control on the HP side so you want to limit what is sent to the ISP. They told only Vlan 1 is the transport Vlan, then you only send that Vlan and prune the rest.

You should have asked those questions before. I can't tell the level of knowledge from a poster unless the poster ask for more clarification.

The problem indicates there is a Vlan leakage from the HP to the 3750 within the ISP and it's passing Vlan 34 for some odd reason. You can control this behavior by pruning your Vlans per Victor's command.

Let us know how it works out.

__

Edison.

Correct Answer by lamav about 8 years 9 months ago

Alright, man. Sorry for the confusion. It isnt easy to follow the conversations on here sometimes.

Just to summarize my recommendations:

1.) As Edison pointed out, you should be pruning your dot1q trunk on the 4506 -- in other words, only allow traffic from the vlans you want traversing the trunk. In your case, its vlan 1, and everyone else will get blocked. Use the command I gave you.

NOTE: You mentioned bringing up more vlans in the future, so if you are going to span another vlan across the provider link, you must also allow that one, too. You added vlan 50 on the 3560 end, but that vlan is local to that side. Its not traversing the link, so you dont need to allow it across. Im talking about a case in which a vlan exists on BOTH sides and there are hosts sitting on that vlan on both sides. In that case, you would allow it through on the trunk.

I know I beat a dead horse. :-)

2.) On the 3560 end, convert that service provider-facing port to a dot1q and make sure you allow vlan 1 and block everything else.

HTH

Victor

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
cowetacoit Wed, 05/21/2008 - 10:53

4506 routing table

Gateway of last resort is 10.0.0.75 to network 0.0.0.0

5.0.0.0/24 is subnetted, 1 subnets

C 5.5.5.0 is directly connected, Loopback0

C 192.168.250.0/24 is directly connected, Vlan250

10.0.0.0/8 is variably subnetted, 19 subnets, 2 masks

C 10.0.10.0/24 is directly connected, Vlan10

C 10.0.11.0/24 is directly connected, Vlan11

C 10.0.0.0/21 is directly connected, Vlan1

C 10.0.27.0/24 is directly connected, Vlan27

C 10.0.30.0/24 is directly connected, Vlan30

C 10.0.28.0/24 is directly connected, Vlan28

C 10.0.23.0/24 is directly connected, Vlan23

C 10.0.41.0/24 is directly connected, Vlan41

C 10.0.45.0/24 is directly connected, Vlan45

C 10.0.34.0/24 is directly connected, Vlan34

C 10.0.35.0/24 is directly connected, Vlan35

C 10.0.32.0/24 is directly connected, Vlan32

C 10.0.38.0/24 is directly connected, Vlan38

C 10.0.39.0/24 is directly connected, Vlan39

C 10.0.36.0/24 is directly connected, Vlan36

D 10.0.50.0/24 [90/3072] via 10.0.2.76, 15:52:13, Vlan1

C 10.0.103.0/24 is directly connected, Vlan103

C 10.0.100.0/24 is directly connected, Vlan100

C 10.0.101.0/24 is directly connected, Vlan101

C 192.168.252.0/24 is directly connected, Vlan252

S* 0.0.0.0/0 [1/0] via 10.0.0.75

cowetacoit Wed, 05/21/2008 - 10:53

3560 routing table

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 19 subnets, 2 masks

D 10.0.10.0/24 [90/3072] via 10.0.0.1, 00:14:28, Vlan1

D 10.0.11.0/24 [90/3072] via 10.0.0.1, 00:14:28, Vlan1

C 10.0.0.0/21 is directly connected, Vlan1

D 10.0.27.0/24 [90/3072] via 10.0.0.1, 00:14:28, Vlan1

D 10.0.30.0/24 [90/3072] via 10.0.0.1, 00:14:28, Vlan1

D 10.0.28.0/24 [90/3072] via 10.0.0.1, 00:14:28, Vlan1

D 10.0.23.0/24 [90/3072] via 10.0.0.1, 00:14:28, Vlan1

D 10.0.41.0/24 [90/3072] via 10.0.0.1, 00:14:28, Vlan1

D 10.0.45.0/24 [90/3072] via 10.0.0.1, 00:14:28, Vlan1

D 10.0.34.0/24 [90/3072] via 10.0.0.1, 00:14:28, Vlan1

D 10.0.35.0/24 [90/3072] via 10.0.0.1, 00:14:28, Vlan1

D 10.0.32.0/24 [90/3072] via 10.0.0.1, 00:14:28, Vlan1

D 10.0.38.0/24 [90/3072] via 10.0.0.1, 00:14:28, Vlan1

D 10.0.39.0/24 [90/3072] via 10.0.0.1, 00:14:28, Vlan1

D 10.0.36.0/24 [90/3072] via 10.0.0.1, 00:14:28, Vlan1

C 10.0.50.0/24 is directly connected, Vlan50

D 10.0.103.0/24 [90/3072] via 10.0.0.1, 00:14:28, Vlan1

D 10.0.100.0/24 [90/3072] via 10.0.0.1, 00:14:28, Vlan1

D 10.0.101.0/24 [90/3072] via 10.0.0.1, 00:14:28, Vlan

Edison Ortiz Wed, 05/21/2008 - 11:26

Let's see your "router eigrp" portion of the config from both routers.

__

Edison.

cowetacoit Wed, 05/21/2008 - 11:32

!

router eigrp 100

network 10.0.0.0 0.0.255.255

no auto-summary

!

It's the same on both.

Edison Ortiz Wed, 05/21/2008 - 11:40

Are you trunking Vlan34 along with Vlan1 ?

The 3560 is receiving EIGRP Hello packets from Vlan34 on Vlan1. The hello packets are multicast with TTL of 1 so they aren't routed.

Verify your native Vlan and/or trunking is in order between these links.

__

Edison.

cowetacoit Wed, 05/21/2008 - 11:48

I can't trunk vlan 34 to that location. I'm routing over a metro vlan connection between two buildings. it goes through our ISP on a layer 2 vlan to one of our branches. It is all running over vlan 1. 10.0.0.1 is the 4506 and 10.0.2.76 is the 3560. (/21). 4506 and 3560 both advertising 10.0.0.0 /16.

yes, i have a lot of devices on vlan 1. trying to segment.

Edison Ortiz Wed, 05/21/2008 - 11:56

Are you saying Vlan34 is part of the MetroE connection towards another building and Vlan1 is part of the MetroE connection towards the 3560 ?

If so, it seems there is a Vlan leakage in the MetroE and 3560 is seeing Vlan34 on that MetroE cloud.

I've seen that problem in Frame-Relay networks with improper frame-mappings but never on MetroE.

If you issue a show cdp neighbor on both switches, what do you see? Can you post the output ?

__

Edison.

lamav Wed, 05/21/2008 - 11:57

Maybe its a good idea to post the entire configs so we dont have to guess...

Victor

cowetacoit Wed, 05/21/2008 - 12:02

thanks for helping out. But NO. vlan 34 is not a part of the metro connection. On my 4506, I have an ACCESS PORT on vlan 1 connecting to the ISP switch. They have a layer 2 vlan to my branch. I have a 3560 in layer 3. it has 2 SVI's. One for vlan 1 and the other for vlan 50. (i plan to add more). I have....

!

router eigrp 100

network 10.0.0.0 0.0.255.255

no auto-summary

!

.....on both 4506 and 3560. The 3560 is the one that has the error in the log. It is receiving all of the updates from the 4506. the 4506 and 3560 are advertising 10.0.0.0 /16.

Edison Ortiz Wed, 05/21/2008 - 12:16

Please post sanitized configs along with the cdp neighbor output as I requested before. Else, I can't continue troubleshooting this problem.

__

Edison.

cowetacoit Wed, 05/21/2008 - 12:22

----3560----

ip routing

!

vlan 50

name TEST

!

interface GigabitEthernet0/1

description Uplink

switchport mode access

!

interface Vlan1

ip address 10.0.2.76 255.255.248.0

!

interface Vlan50

ip address 10.0.50.1 255.255.255.0

!

router eigrp 100

network 10.0.0.0 0.0.255.255

no auto-summary

cowetacoit Wed, 05/21/2008 - 12:23

ip multicast-routing

!

vlan 3

name SAN

!

vlan 10

name WIFIMGT

!

vlan 11

name WIFIInt

!

vlan 20

name IT

!

vlan 21

name *

!

vlan 22

name *

!

vlan 23

name *

!

vlan 24

name *

!

vlan 25

name *

!

vlan 26

name *

!

vlan 27

name *

!

vlan 28

name *

!

vlan 29

name *

!

vlan 30

name *

!

vlan 31

name *

!

vlan 32

name *

!

vlan 33

name *

!

vlan 34

name *

!

vlan 35

name *

!

vlan 36

name *

!

vlan 37

name *

!

vlan 38

name *

!

vlan 39

name A*

!

vlan 41

name *

!

vlan 45

name *

!

vlan 100

name *_VOIP

!

vlan 101

name *_VOIP

!

vlan 103

name *_VOIP

!

vlan 250

name *

!

vlan 252

name *

!

interface Loopback0

ip address 5.5.5.5 255.255.255.0

ip pim sparse-mode

interface FastEthernet5/48

description ISP P2P

switchport trunk encapsulation dot1q

switchport mode trunk

speed 100

duplex full

interface Vlan1

description Data

ip address 10.0.0.1 255.255.248.0

!

interface Vlan10

description WIFIMGT

ip address 10.0.10.1 255.255.255.0

!

interface Vlan11

description WIFIInt

ip address 10.0.11.1 255.255.255.0

!

interface Vlan20

description IT

ip address 10.0.20.1 255.255.255.0

ip helper-address 10.0.0.30

shutdown

!

interface Vlan22

description *

ip address 10.0.22.1 255.255.255.0

ip helper-address 10.0.0.30

shutdown

!

interface Vlan23

description *

ip address 10.0.23.1 255.255.255.0

ip helper-address 10.0.0.30

!

interface Vlan24

description *

ip address 10.0.24.1 255.255.255.0

ip helper-address 10.0.0.30

shutdown

!

interface Vlan25

description *

ip address 10.0.25.1 255.255.255.0

ip helper-address 10.0.0.30

shutdown

!

interface Vlan26

description *

ip address 10.0.26.1 255.255.255.0

ip helper-address 10.0.0.30

shutdown

!

interface Vlan27

description *

ip address 10.0.27.1 255.255.255.0

ip helper-address 10.0.0.30

!

interface Vlan28

description *

ip address 10.0.28.1 255.255.255.0

ip helper-address 10.0.0.30

!

interface Vlan29

description *

ip address 10.0.29.1 255.255.255.0

ip helper-address 10.0.0.30

shutdown

!

interface Vlan30

description *

ip address 10.0.30.1 255.255.255.0

ip helper-address 10.0.0.30

ip pim dense-mode

!

interface Vlan31

description *

ip address 10.0.31.1 255.255.255.0

ip helper-address 10.0.0.30

shutdown

!

interface Vlan32

description *

ip address 10.0.32.1 255.255.255.0

ip helper-address 10.0.0.30

!

interface Vlan33

description *

ip address 10.0.33.1 255.255.255.0

ip helper-address 10.0.0.30

shutdown

!

interface Vlan34

description *

ip address 10.0.34.1 255.255.255.0

ip helper-address 10.0.0.30

!

interface Vlan35

description *

ip address 10.0.35.1 255.255.255.0

ip helper-address 10.0.0.30

!

interface Vlan36

description *

ip address 10.0.36.1 255.255.255.0

ip helper-address 10.0.0.30

!

interface Vlan37

description *

ip address 10.0.37.1 255.255.255.0

ip helper-address 10.0.0.30

shutdown

!

interface Vlan38

description *

ip address 10.0.38.1 255.255.255.0

ip helper-address 10.0.0.30

!

interface Vlan103

description *_VOIP

ip address 10.0.103.75 255.255.255.0

!

interface Vlan250

description *

ip address 192.168.250.1 255.255.255.0

ip helper-address 10.0.0.30

ip pim dense-mode

ip policy route-map CPLS

!

interface Vlan252

description CPLS

ip address 192.168.252.1 255.255.255.0

ip access-group CPLS-WIRELESS-SECURITY in

ip helper-address 10.0.0.30

ip policy route-map CPLS

!

router eigrp 100

network 10.0.0.0 0.0.255.255

no auto-summary

!

ip route 0.0.0.0 0.0.0.0 10.0.0.75

Edison Ortiz Wed, 05/21/2008 - 12:30

Ok, one more time.....

I need to see the CDP output from both devices

AND

this time, please post the output from "show vlan" as well.

cowetacoit Wed, 05/21/2008 - 12:34

4506

Library_4510 Gig 6/18 126 S I WS-C4510R Gig 1/2

AdultProbation Gig 6/3 136 S I WS-C3560-2Gig 0/2

JusticeCenter_4507

Gig 6/2 165 S I WS-C4507R Gig 3/17

Temp_switch_in_Admin

Gig 2/6 137 S I WS-C3560G-Gig 0/47

WaterAuth_MB Gig 6/1 122 S I WS-C3560G-Gig 0/52

SherriffOffice_4506

Gig 1/2 167 S I WS-C4506 Gig 1/1

WLC01 Gig 2/20 169 H AIR-WLC440Unit - 0 Slot - 0 Port - 1

CC MIS(000883-2caac0)

Fas 5/48 135 S HP 2524 16

BTBrown_3560#sh cdp n

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone

Device ID Local Intrfce Holdtme Capability Platform Port ID

SEP001E13E5FEA3 Fas 0/2 168 H P IP Phone Port 1

SEP001E13E6007C Fas 0/3 164 H P IP Phone Port 1

SEP001E135CF67A Fas 0/6 174 H P IP Phone Port 1

SEP001E13E5EBDD Fas 0/1 162 H P IP Phone Port 1

BT_Brown_2950 Gig 0/1 154 S I WS-C2950- Fas 0/2

2950 is in layer 2 of course

Edison Ortiz Wed, 05/21/2008 - 12:44

Which port is being used for the MetroE on each switch?

Per previous post, I assumed the 3560 was using G0/1 as the MetroE switchport as that's the only switchport you decided to include.

The CDP is showing the 2950 is connected to G0/1.

Is the 2950 part of the MetroE connection?

If so, can we see the config and cdp information from that device ?

Most Layer2 MetroE implementations, you should be able to see your neighboring switch via CDP, is that the case here? Because I don't see the 4506 from the 3560.

cowetacoit Wed, 05/21/2008 - 12:51

sorry, you posted as i was still posting my configs

2950 sh cdp n.

this guy is in layer 2. No config to post, default except for IP address on vlan 1

Patillo is the ISP 3750

BT_Brown_2950#sh cdp n

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone

Device ID Local Intrfce Holdtme Capability Platform Port ID

BTBrown_2811 Fas 0/3 121 R S I Cisco 2811Fas 0/0

BTBrown_3560 Fas 0/2 156 R S I WS-C3560-8Gig 0/1

Patillo(000a57-60Fas 0/1 145 S HP 2524 2

BT_Brown_2950#

cowetacoit Wed, 05/21/2008 - 12:34

Admin_4506#SH VLAN

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Gi1/1, Gi2/2, Gi2/3, Gi2/4, Gi2/5, Gi2/7, Gi2/8, Gi2/9, Gi2/10, Gi2/11, Gi2/12

Gi2/13, Gi2/14, Gi2/15, Gi2/16, Gi2/17, Gi2/18, Gi2/19, Gi2/21, Gi2/22, Gi2/23

Gi2/24, Fa3/1, Fa3/2, Fa3/3, Fa3/4, Fa3/5, Fa3/6, Fa3/7, Fa3/8, Fa3/9, Fa3/10

Fa3/11, Fa3/12, Fa3/13, Fa3/14, Fa3/15, Fa3/16, Fa3/17, Fa3/18, Fa3/19, Fa3/20

Fa3/21, Fa3/22, Fa3/23, Fa3/24, Fa3/25, Fa3/26, Fa3/27, Fa3/28, Fa3/29, Fa3/30

Fa3/31, Fa3/32, Fa3/33, Fa3/34, Fa3/35, Fa3/36, Fa3/37, Fa3/38, Fa3/39, Fa3/40

Fa3/41, Fa3/42, Fa3/43, Fa3/44, Fa3/45, Fa3/46, Fa3/47, Fa3/48, Fa4/1, Fa4/2, Fa4/3

Fa4/4, Fa4/5, Fa4/6, Fa4/7, Fa4/8, Fa4/9, Fa4/10, Fa4/11, Fa4/12, Fa4/13, Fa4/14

Fa4/15, Fa4/16, Fa4/17, Fa4/18, Fa4/19, Fa4/20, Fa4/21, Fa4/22, Fa4/23, Fa4/24

Fa4/25, Fa4/26, Fa4/27, Fa4/28, Fa4/29, Fa4/30, Fa4/31, Fa4/32, Fa4/33, Fa4/34

Fa4/35, Fa4/36, Fa4/37, Fa4/38, Fa4/39, Fa4/40, Fa4/41, Fa4/42, Fa4/43, Fa4/44

Fa4/45, Fa4/46, Fa4/47, Fa4/48, Fa5/1, Fa5/2, Fa5/3, Fa5/4, Fa5/5, Fa5/6, Fa5/7

Fa5/8, Fa5/9, Fa5/10, Fa5/11, Fa5/12, Fa5/13, Fa5/14, Fa5/15, Fa5/16, Fa5/17, Fa5/18

Fa5/19, Fa5/20, Fa5/21, Fa5/22, Fa5/23, Fa5/24, Fa5/25, Fa5/26, Fa5/27, Fa5/28

Fa5/29, Fa5/30, Fa5/31, Fa5/32, Fa5/33, Fa5/34, Fa5/35, Fa5/36, Fa5/37, Fa5/38

Fa5/39, Fa5/40, Fa5/41, Fa5/42, Fa5/43, Fa5/44, Fa5/45, Fa5/46, Fa5/47, Gi6/4, Gi6/5

Gi6/6, Gi6/7, Gi6/8, Gi6/9, Gi6/10, Gi6/11, Gi6/12, Gi6/13, Gi6/14, Gi6/15, Gi6/16

Gi6/17

3 active

10 active

11 active

20 active

21 active

22 active

23 active

24 active

25 active

26 active

27 active

28 active

29 active

30 active

31 active

32 active

33 active

34 active

35 active

36 active

37 active

38 active

39 active

41 active

45 active

100 active

101 active

103 active

250 active

252 active

BTBrown_3560#sh vlan

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4, Fa0/5, Fa0/6, Fa0/8, Gi0/1

50 BTBROWNTEST active

1002 fddi-default act/unsup

1003 token-ring-default act/unsup

1004 fddinet-default act/unsup

1005 trnet-default act/unsup

lamav Wed, 05/21/2008 - 12:45

I agree with Edison, but I do think i understand the topology...

You're spanning vlan 1 across the service provider's ethernet cloud and placing an SVI on both ends in vlan 1 to simulate a routed connection. So, the EIGRP neighbor relationship is established between the SVIs in vlan 1 on both the 4506 and the 3560.

So, youre using vlan1 as a trasport vlan. No dot1q trunking -- both sides are access ports.

Do I have it correctly?

Victor

cowetacoit Wed, 05/21/2008 - 12:48

that is correct. the port on my 4506 that connects to the ISP is DOT1Q Trunk because they have a HP Procurve at that location. The ISP has me connected to a 3750 on my 3560 side of the metro cloud. i'm configured as access port there. Yes vlan 1 as transport vlan.

Edison Ortiz Wed, 05/21/2008 - 12:51

the port on my 4506 that connects to the ISP is DOT1Q Trunk

You said you weren't trunking. Are you pruning all Vlans except Vlan 1 ?

cowetacoit Wed, 05/21/2008 - 12:54

only vlan 1 is being sent out to the ISP. i have that side set as DOT1Q because it connects to a HP Procurve (ISP). ISP said i'd have to set it that way. frame tagging issue

cowetacoit Wed, 05/21/2008 - 12:55

sorry guys. i thought i was talking to one person there for a few. I feel like we are all out of order. I replied to an earlier post about the 2950. I posted the cdp n

lamav Wed, 05/21/2008 - 13:23

Dont be sorry. Its all good. Edison was helping you, but I jumped in because I have seen this nutty set up before....

Why dont you configure the 3560 end as a dot1q trunk port also? It makes more sense to keep things consistent. I have a feeling that this inconsistency may be causing some unexpected results....

[EDIT I also just noticed that the dot1q trunk on the 4500 side is NOT pruning the vlans. You are allowing ALL vlans on that trunk, not just vlan 1, as you say. I would change that, too. Allow only vlan 1, block the others, and then change the 3560 to a dot1q trunk and only allow vlan 1 on that end. Consistency...[EDIT]

Victor

Edison Ortiz Wed, 05/21/2008 - 12:57

Again, I'm not saying NOT to send Vlan 1 in the trunk. What I'm asking is, are you pruning the user Vlans in this trunk.

As I suspected in my first post, you seem to have a Vlan leakage somewhere and by pruning on your egress port, you are ensuring the ISP only sees Vlan 1.

If you configure the 802.1q port without manual pruning, your ISP will get information from all Vlans in the trunk and who knows how their end is configured.

cowetacoit Wed, 05/21/2008 - 13:02

funny thing is i use to work for them. i know their set up.

On my 4506, i have a DOT1Q trunk (sending only vlan 1) connected to my ISP HP. It is layer 2 all the way to the ISP 3750. My 2950 connects to the ISP on layer 2 link, and my 3560 connects to the 2950 on an access port.

cowetacoit Wed, 05/21/2008 - 13:25

could you elaborate a little more on "pruning".

This is the interface on my 4506 connecting to the ISP. Like i said, i have to have it set to DOT1Q because of the way HP does tagging/untagging. Traditionally my company has had everything on vlan 1. I'm trying to change this. So we probably have about 500 hosts on vlan 1.

!

interface FastEthernet5/48

description ISP P2P

switchport trunk encapsulation dot1q

switchport mode trunk

speed 100

duplex full

!

lamav Wed, 05/21/2008 - 13:30

Pruning:

switchport trunk allowed vlan 1

Only allows vlan 1...see my post...scroll up...I also added an EDIT.

Victor

Correct Answer
lamav Wed, 05/21/2008 - 13:54

Alright, man. Sorry for the confusion. It isnt easy to follow the conversations on here sometimes.

Just to summarize my recommendations:

1.) As Edison pointed out, you should be pruning your dot1q trunk on the 4506 -- in other words, only allow traffic from the vlans you want traversing the trunk. In your case, its vlan 1, and everyone else will get blocked. Use the command I gave you.

NOTE: You mentioned bringing up more vlans in the future, so if you are going to span another vlan across the provider link, you must also allow that one, too. You added vlan 50 on the 3560 end, but that vlan is local to that side. Its not traversing the link, so you dont need to allow it across. Im talking about a case in which a vlan exists on BOTH sides and there are hosts sitting on that vlan on both sides. In that case, you would allow it through on the trunk.

I know I beat a dead horse. :-)

2.) On the 3560 end, convert that service provider-facing port to a dot1q and make sure you allow vlan 1 and block everything else.

HTH

Victor

Correct Answer
Edison Ortiz Wed, 05/21/2008 - 15:51

I'm not questioning your design. When I ask a question is for a reason. I asked before if you were trunking the interface and you said no. About 5 responses later, it comes to light that you are trunking. That was a time wasted for you and for me.

Again, I asked you if you were pruning the Vlans and you said you are only sending Vlan 1 towards the ISP. The portion of the config above clearly indicates that you aren't pruning and all the Vlans are being forwarded to the HP switch. You don't want that as it can create problems. You have no control on the HP side so you want to limit what is sent to the ISP. They told only Vlan 1 is the transport Vlan, then you only send that Vlan and prune the rest.

You should have asked those questions before. I can't tell the level of knowledge from a poster unless the poster ask for more clarification.

The problem indicates there is a Vlan leakage from the HP to the 3750 within the ISP and it's passing Vlan 34 for some odd reason. You can control this behavior by pruning your Vlans per Victor's command.

Let us know how it works out.

__

Edison.

cowetacoit Thu, 05/22/2008 - 03:15

i didn't realize that it defaults to sending ALL vlans. i will prune it this morning on both ends. I can only send one vlan over that link to my knowledge. The serivce provider can't support multiple vlans since i am on one of there vlans. If we could use DOT1Q in Q then we wouldn't be having this conversation. I didn't think it was possible for a vlan to "leak" like that. I appreciate both of your help. THANKS!

cowetacoit Thu, 05/22/2008 - 04:19

I only allowed vlan 1 over the link and the error went away. As far as the consistency i'm going to get with the ISP and go over a few frame tagging issues. Thanks for your help.

lamav Thu, 05/22/2008 - 05:10

Great news. Glad I could help.

Thanks for the rating.

Victor

Actions

This Discussion