Can't get 871w to work - traffic doesn't pass from fa0-3 to wan fa4

Unanswered Question
May 21st, 2008

I'm going crazy! I've looked all around the internet using sample configs and I can't get going (I'm new to Cisco).

I can hookup the Wan fa4 to my linksys router, it picks up a dhcp ip and I can ping that. I can't ping the fa0-3 ports (when I assigned an ip for them), Vlan1 (when I assigned an IP to that), or the BVI1. I can ping these from in the router itself. Also, it doesn't hand out IP's from the assigned dhcp pool, it gives out 192.168.1.x address which is from the linksys (these 192.168.1.x can't ping anything) when it should be handing out 10.20.0.x addresses. I hooked up the cable modem directly to the 871w and rebooted the router, but it still handed out 192.168.1.x address.

Please can someone point me in the right direction?

Thanks a million!!!!!

Building configuration...

Current configuration : 3612 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Digital

!

boot-start-marker

boot-end-marker

!

no logging buffered

enable secret xxx

!

no aaa new-model

!

resource policy

!

clock timezone MDT -7

clock summer-time MDT date Apr 6 2003 2:00 Oct 26 2003 2:00

--More-- ip subnet-zero

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 10.20.0.1 10.20.0.50

!

ip dhcp pool Internal-net

import all

network 10.20.0.0 255.255.255.0

default-router 10.20.0.1

domain-name bxxxxx.com

!

!

no ip domain lookup

ip domain name cisco.com

!

!

crypto stuff ----

quit

username xxxxx privilege 15 password 0 xxxxxx

!

!

!

bridge irb

!

!

!

interface FastEthernet0

spanning-tree portfast

!

interface FastEthernet1

spanning-tree portfast

!

interface FastEthernet2

spanning-tree portfast

!

interface FastEthernet3

spanning-tree portfast

!

interface FastEthernet4

ip address dhcp

--More-- ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface Dot11Radio0

no ip address

shutdown

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

!

interface Vlan1

no ip address

ip nat inside

ip virtual-reassembly

bridge-group 1

bridge-group 1 spanning-disabled

!

interface BVI1

description Bridge to Internal Network

ip address 10.20.0.1 255.255.255.0

ip nat inside

--More-- ip virtual-reassembly

!

ip classless

ip route 0.0.0.0 0.0.0.0 dhcp

!

!

ip http server

ip http authentication local

ip http secure-server

ip nat inside source list 1 interface FastEthernet4 overload

!

access-list 1 remark SDM_ACL Category=2

access-list 1 permit 10.20.0.0 0.0.0.255

!

!

control-plane

!

bridge 1 route ip

!

left off the rest

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mbevington Wed, 05/21/2008 - 22:17

I checked SDM and they are all Vlan1.

Should I put this in "by hand"?

mbevington Thu, 05/22/2008 - 05:26

Ok, I put it in by hand - looks like nothing changed.

What else could be wrong?

Thanks!

mbevington Thu, 05/22/2008 - 16:51

Still having the same problem.

Somehting new though - I'm seeing an NVI0 interface popping up: it wasn't before. Is this the problem?

Actions

This Discussion