VPN Client ip address conflict

Unanswered Question
May 22nd, 2008

VPN Client 5.0.03.0530 works fine. Connection is ok. When disconnecting the VPN connection, Windows gives the following message: Windows detected an ip address conflict...

What can this be ? This problem occurs on all Windows Vista laptops. Not yet tried on XP..

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
JORGE RODRIGUEZ Wed, 05/28/2008 - 16:53

Remco,

This issue seems to be tied with CSCsi26106 unity vista: reason 442: failed to enable virtual adapter

http://www.cisco.com/en/US/products/sw/secursw/ps2308/prod_release_note09186a0080884df5.html#wp1555976

I checked coupled of VPN client versions, at least for Vpn revision number 5.0.03.0530 error 442 or more specific CSCsi26106 is in its resolved list. It seems to me anything prior 5.0.03.0530 a workaround this 442 error is provided in above link.

additionally:

I quote from cisco opened caveats database

CSCsk21956 has been superseded by CSCsi26106

unity vista: reason 442: failed to enable virtual adapter

Symptom:

Receiving the following error "Reason 442: failed to enable virtual adapter" appears after Vista reports a duplicate IP address detected. Subsequent connection fail with same message but Vista doesn't report a duplicate IP address detected.

Workaround:

Open "Network and Sharing Center", then select "Manage Network Connections", Enable the Virtual Adapter "VA", then right click on the VA and select "diagnose" from the context menu and after that select, "Reset the network adapter "Local Area Connection X"

This resolves the issue until Vista reports a duplicate IP address again. Follow above step to resolve it again.

If that doesn't work, run the following from cmd, if you have UAC enabled ensure you run cmd as administrator.

reg add HKLM\System\CurrentControlSet\Services\Tcpip\Parameters /v ArpRetryCount /t REG_DWORD /d 0 /f

Vista introduces a new feature called "Receive Window Auto-Tuning". What it does is to adjust the receive windows size continually based upon the changing network conditions.

Some people reported that auto-tuning cause network time-out problems with some applications and routers. You can turn it off if you have experienced such problems.

Open up an elevated command prompt.

Enter the following command to disable auto-tuning netsh interface tcp set global autotuninglevel=disabled If you found that this doesn't fix your problem, you can turn it back on.

Open up an elevated command prompt.

Enter the following command to enable auto-tuning netsh interface tcp set global autotuninglevel=normal You can use this command to view the states of the TCP global paremeters.

netsh interface tcp show global

HTH

-Jorge

Brett Hanson Sun, 03/25/2012 - 23:43

I found this info here: http://www.techrepublic.com/article/fix-10-common-cisco-vpn-problems/5913811

I know it's version 4.6 but the principal may apply...

The user's remote network is using the same IP address range as the VPN server's local network (Client VPN release 4.6 with virtual adapter, Windows 2000/XP)

This is somewhat specific to these particular operating systems, but could be quite frustrating to troubleshoot! Version 4.6 of the Cisco VPN client tries to handle these kinds of IP address conflicts, but isn't always able to do so. In these cases, traffic that is supposed to be traversing the VPN tunnel stays local, due to the conflict.

On the affected client, go to Start | Control Panel | Network and Dialup Connections | local adapter. Right-click the adapter and choose Properties. From the Properties page, choose TCP/IP and click the Properties button. Now, click the Advanced option, find the Interface Metric option and increase the number in the box by 1.This effectively tells your computer to use the local adapter second. The VPN adapter will probably have a metric of 1 (lower than this new metric), making it the first choice as a traffic destination."

We've just encountered this issue on Windows 7 32bit connecting to a PIX firewall - but are going to try the newer version of Cisco VPN client first (before messing with network settings).

Our staff member is running 5.0.01.0600 and we've organised for them to install 5.0.07.0410 and test.

Will post back if the new version helps us....and anything else I discover along the way.

NOTE: We also found this other Cisco Bug that seems identical to the other Bug mentioned - CSCso44260

Actions

This Discussion