Cisco IP Phone XML Push Error = 0

Unanswered Question
May 22nd, 2008

Hi,

I am trying to push an XML message on Cisco IP Phone(SoftPhone) but I am getting CiscoIPPhoneError="0". Just by chance it has happenned that it works on only one softphone, means that the code i am writing is ok. Also I unserstand the concept of associating user to IP phone for allowing Push to work.

Please let me know of any other configuration or authorization settings that need to be done. I have been working on the same problem for quite some time now and i am really looking forward for a solution to this. I am anyways mentioning the code i have used:

-------------------------------------

<body>

<FORM name="Form1" action="http://IPofPhone/CGI/Execute" method="POST">

<P>

<INPUT type="text" name="XML" value="<CiscoIPPhoneExecute><ExecuteItem Priority="0" URL="http://urltobeexecuted&quot; /></CiscoIPPhoneExecute> " />

</P>

<P>

  

<INPUT type="Submit" name="button1" value="Submit" />

</P>

</FORM>

</body>

----------------------------------------

this code is written in a jsp.

It would be really gr8 if someone can help me over this.

Thanks & Regards,

Sid

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
stephan.steiner Fri, 05/23/2008 - 04:26

Using IE?

Try Firefox.

Starting some time ago, I'm completely unable to make any POSTS to any phone in IE but Firefox works just fine (I do get another error in IE though.. it seems like it cannot connect properly).

stephan.steiner Sun, 05/25/2008 - 23:42

I noted that after the url to be executed, you have a ;

I don't think that belongs there.

Here's an example of a html page that I use to push information to my phones when I need to make tests (I've been too lazy to write a proper JTAPI app with a GUI and everything).

http://10.145.7.131/CGI/Execute" Method="POST">


As I said though, some time ago this stopped working using IE but it still works fine using Firefox (I also have trouble downloading screenshots using IE.. another thing that works fine with Firefox).

siddharthsukhija Mon, 05/26/2008 - 02:10

Sorry on my part that I left a semi colon.

I in fact copied whole of your text and tried to run it but still got the same error.

I have been able to push messages on only 1 phone. On all other phones I am getting the same error.

I am also trying it by using firefox but stil getting the same errors.

Any there any configurations that I need to make on Call Manager that allows a web application to have access on the phone??

stephan.steiner Mon, 05/26/2008 - 07:59

Well, if it were a configuration issue (you need to associate phones with a user) then you'd get an authentication error, not one of those errors that do not exist.

I think all you can do now is open a developer case to get to the bottom of this. I'm certainly all out of ideas.

siddharthsukhija Tue, 05/27/2008 - 01:43

Hi,

Thanks a lot for ur support. Please let me know as to how I can open a developer case.

Thanks a Lot,

Sid

Actions

This Discussion