7961 phones not loading new firmware

Answered Question
May 22nd, 2008

I have some phones at our Guam location that are not loading the newest firmware across the WAN from our CCM publisher server.

They should be updating to SCCP41.8-3-4SR1S but they are stuck on either 7.0(3.0S) or TERM61.DEFAULT.

Since these phones are in our Guam location they are far away from our CCM publisher server which is in San Diego, CA.

Everything is withing Cisco specs for a VOIP deployment.

If I jack in a phone to our network here in San Diego it will upgrade properly and then I can ship it to Guam and of course it boots up properly with the current firmware.

Has anybody had a problem like this before?

We have phone in Hawaii and Mexico as well and they upgrade just fine.

I have this problem too.
0 votes
Correct Answer by maharris about 8 years 6 months ago

If your remote router is already providing dhcp to the phones, and you want to serve the files out of the flash out there, you can change the opt 150 address to be the router, and make sure you are serving the file from the router flash with the tftp-server flash:[phoneload], reboot the phone and it should pick up new setting and go look for the load. Or, you can manually change the tftp server address in the phone network settings. You can do tftp debugs on the router to see what is going on if you need to.

Mary Beth

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
rob.huffman Thu, 05/22/2008 - 11:35

Hi Mark,

It sounds like a TFTP issue for sure. Is there a Firewall blocking UDP 69 for TFTP?

Just a thought,

Rob

phretbored Thu, 05/22/2008 - 11:39

Thanks I will look into that.

Our Guam location connecs to San Diego on a P2P link.

There is a Cisco ASA in place as well.

I'll let you know if that works.

phretbored Fri, 05/23/2008 - 11:26

Actually there is no firewall or ASA involved in the P2P link between Guam and San Diego.

I think the problem might be in the local router because only the phones at Guam have this trouble.

Every other location is able to load firware without any issues.

david.macias Fri, 05/23/2008 - 11:32

Might it be a bandwidth issue, how many phones are trying to upgrade at once? Have you tried one at a time during low traffic hours?

david

phretbored Fri, 05/23/2008 - 11:38

It might be a bandwidth issue but I have tried during off hours and also tried one phone at a time.

No luck.

It is only about 10 phones total that need the firmware.

I am able send tftp files from San Diego to the router and switch at Guam.

mightyking Fri, 05/23/2008 - 12:06

Do the phones get the TFTP IP address? If the answer is yes, do the following. The procedure is version dependant but it works with most of the versions.

1)Unplug the cable from the phone

2)Hold the # key and replug the cable back

3)Do not release the # key and hold it for about 10 seconds

4)Wait until the lines start flashing

5)As soon as the lines flash, release the # key and dial the following digits using the phone keypad (1,2,3,4,5,6,7,8,9,*,0,# in the order. You have 10 seconds to dial all digits. If you fail to dial the above digits within 10 seconds, you may need to start over.

6)The phones release the old firmware and download the new one.

The upgrade procedure may take up to 5-7 minutes for each phone.

MK

phretbored Fri, 05/23/2008 - 13:32

Hey thanks for the suggestion.

Yes the phones get ip addresses and register to the CCM.

Everything seems normal.

They work fine when making and receiving calls.

I just can't get them to update the firmware.

I will get someone on site to try what you suggested and let you know what happens.

phretbored Tue, 05/27/2008 - 16:44

Ok I have somebody trying this possible fix now.

I noticed there is a setting on the phone config page in CCM that I am unsure about.

The area called "Product Specific Configuration Layout" has a "Load Server" parameter.

Normally this is blank and the phone upgrade just fine.

Does the ip address for the publisher CCM need to be defined here for this forced firmware reload to work?

mightyking Wed, 05/28/2008 - 05:54

You don't need to use any IP address in order to force the firmware upgrade.

When you go to the Device ->Device Setting-> Device Default page, do you see the new firmware which you want to upgrade to in the "Load information" field? If so, just follow the instructions I sent you in the previous posting.

phretbored Wed, 05/28/2008 - 09:22

Yes the new firmware is there and that is what loads to our phones except for the Guam location.

I did email the instructions to someone at Guam and we are going to try it today.

The 18 hr time difference between San Diego and Guam is slowing this down a bit.

phretbored Wed, 05/28/2008 - 13:21

Well we tried this twice on the same phone and no luck.

The employee in Guam reported back to me that "the phone has Cisco Systems on the screen with one big box and a check in it. Headset and mute are lit up and the top right buttons for the phone lines are flashing from top to bottom in an alternating pattern."

Maybe an access list issue?

I am guilty of not checking that before opening this thread.

mightyking Thu, 05/29/2008 - 11:54

That's exactly the symptom of upgrading. Let it go for while and if there's no problem with the connection, the upgrade page will appear.

maharris Thu, 05/29/2008 - 13:49

We had a discussion about this in a recent class - they said images don't transfer well over links slower than 2M(!) and so in 6.x they have added a checkbox in the phone config indicating 'remote device', they said that might help, or you will have to put the new phone load on a tftp server local to the phone, can even set it up in router flash (set it up to server the file), and temporarily repoint the phone to that, let it upgrade, and then repoint for normal operation.

Mary Beth

phretbored Thu, 05/29/2008 - 14:24

The P2P link to Guam is 768K.

I will try your suggestion and setup the phone load in the local router flash.

Thanks!

There is a TAC case opened for this now as well.

phretbored Thu, 05/29/2008 - 14:21

We let it run overnight...no luck.

Actually I know the CISCO screen will appear during a firmware upgrade and there are the check boxes indicating the progress, etc, but the light should not be continously strobing should they?

Over a 768K link how long would a firmware upgrade take?

Letting it run over night should have been plenty of time I would think.

I can let it run as long as I want to however it looks like installing the firmware from a local router or other source would be the way to go at this point.

mightyking Fri, 05/30/2008 - 06:13

This is the step-by-step approach to manualy upgrade the firmware. Please note that the credit goes to James :-)

•Turn off your Cisco phone.

•Create a directory on your C: drive by the name of \TFTPD-Root.

•Put the new Cisco phone firmware into C:\TFTPD-Root

•Connect your phone to your PC through a hub, or directly with a crossover cable.

•On your Windows box, assign a static IP address to your Windows box. You accomplish this by altering your TCP/IP properties of your network interface card.

To get to these properties(in Windows XP): go to Control Panel > Network Connections > Click once on "Local Area Connection" > Select "Change settings of this connection" from the "Network Tasks" pane on the left side of the window.

Select "Internet Protocol(TCP/IP)" from the list, then click on "Properties".

If you already have settings in there, write them down - you'll need them once you're done. However you're probably set up with "Obtain an IP address automatically".

In the "Use the following IP address" I would suggest an IP address of 192.168.1.10, subnet mask of 255.255.255.0, leave the gateway blank. Click "Ok", then "Ok" again.

•Download the TFTPD32 from http://tftpd32.jounin.net

•Start the TFTPD32 program.

•In the TFTPD32 program, click on the "Settings" button:

•For Base Directory, input into the text input box: C:\TFTPD-Root.

•Ensure that "TFTP Server" and "DHCP Server" checkboxes are selected. (You don't need the "Client" box checked.)

•TFTP Security should be set to "None".

•For "Advanced TFTP Options", ensure that "Translate Unix file names" and "Allow '\' As virtual root" are selected. You'll find these checkboxes by clicking the "Settings" button and looking at the lower third of the configuration screen. You may need to use option 150 or 66 to stablish the connection.

•Click the "OK" to save the settings.

•Exit TFTPD32 and restart it so it will use your new settings.

•Turn on your Cisco Phone (making sure it is connected to your Windows machine running the TFTPD32 program via crossover cable or through the hub). You may need to power th phone using a power supply.

At this stage, your Cisco Phone should start requesting an IP address via DHCP. Your Windows machine running TFTPD32 will answer the request - this is why you can't have any other router in the setup configuration, the phone won't know which one to choose.

Next, it should start to TFTP down the new firmware from your Windows machine running the TFTPD32 program. Your "Tftp Server" window of the TFTPD32 program should start listing all the files the Cisco phone is grabbing.

Correct Answer
maharris Fri, 05/30/2008 - 08:32

If your remote router is already providing dhcp to the phones, and you want to serve the files out of the flash out there, you can change the opt 150 address to be the router, and make sure you are serving the file from the router flash with the tftp-server flash:[phoneload], reboot the phone and it should pick up new setting and go look for the load. Or, you can manually change the tftp server address in the phone network settings. You can do tftp debugs on the router to see what is going on if you need to.

Mary Beth

phretbored Mon, 06/09/2008 - 16:39

Right on.

I have the files loaded into the local router and I set the first opt 150 address in the local router dhcp phone pool as the local router.

The router tftp-server is pointing to the phone load file "SCCP41.8-3-4SR1S.loads"

Anything else to consider?

We are going to test this today and see what happens.

phretbored Tue, 06/10/2008 - 09:29

Well I tried to get this working by serving the firmware off the local router but it has not been successful yet.

Here is the router flash:

GuamHPCRT1#show flash

-#- --length-- -----date/time------ path

1 34634704 Mar 7 2008 17:50:08 +10:00 c2800nm-spservicesk9-mz.124-10c.bin

2 1007616 Feb 7 2006 01:59:50 +10:00 COMMON.TAR

3 812032 Feb 7 2006 01:59:26 +10:00 ES.TAR

4 1038 Feb 7 2006 02:00:10 +10:00 home.shtml

5 113152 Feb 7 2006 02:00:28 +10:00 HOME.TAR

6 4052480 Feb 7 2006 01:59:02 +10:00 SDM.TAR

7 1649 Feb 7 2006 01:58:26 +10:00 sdmconfig-28xx.cfg

8 40112248 Apr 22 2008 22:00:48 +10:00 c2800nm-adventerprisek9-mz.124-18.bin

10 642 Jun 10 2008 07:42:34 +10:00 SCCP41.8-3-4SR1S.loads

11 642 Jun 10 2008 07:43:10 +10:00 term61.default.loads

12 2494499 Jun 10 2008 07:58:10 +10:00 apps41.8-3-3-17.sbn

13 548979 Jun 10 2008 08:14:24 +10:00 cnu41.8-3-3-17.sbn

14 2457374 Jun 10 2008 08:29:48 +10:00 cvm41sccp.8-3-3-17.sbn

15 530785 Jun 10 2008 08:47:42 +10:00 dsp41.8-3-3-17.sbn

16 316973 Jun 10 2008 08:50:02 +10:00 jar41sccp.8-3-3-17.sbn

And here is the router tftp debug after I rebooted one of the phones...

Jun 10 16:45:50.950: TFTP: Server request for port 49300, socket_id 0x48343F60 for process 33

Jun 10 16:45:50.950: TFTP: read request from host 10.176.49.166(49300) via GigabitEthernet0/0.128

Jun 10 16:45:50.950: TFTP: Looking for CTLSEP0017E015335F.tlv

Jun 10 16:45:50.950: TFTP: Sending error 1 No such file

Jun 10 16:45:51.090: TFTP: Server request for port 49301, socket_id 0x48343F60 for process 33

Jun 10 16:45:51.090: TFTP: read request from host 10.176.49.166(49301) via GigabitEthernet0/0.128

Jun 10 16:45:51.090: TFTP: Looking for SEP0017E015335F.cnf.xml

Jun 10 16:45:51.090: TFTP: Sending error 1 No such file

Jun 10 16:45:51.174: TFTP: Server request for port 49302, socket_id 0x450CE3E0 for process 33

Jun 10 16:45:51.174: TFTP: read request from host 10.176.49.166(49302) via GigabitEthernet0/0.128

Jun 10 16:45:51.178: TFTP: Looking for XmlDefault.cnf.xml

Jun 10 16:45:51.178: TFTP: Sending error 1 No such file

Jun 10 16:46:52.143: TFTP: Server request for port 49152, socket_id 0x450CE3E0 for process 33

Jun 10 16:46:52.143: TFTP: read request from host

10.176.49.166(49303) via GigabitEthernet0/0.128

Jun 10 16:47:22.439: TFTP: Looking for CTLSEP0017E015335F.tlv

Jun 10 16:47:22.439: TFTP: Sending error 1 No such file

Jun 10 16:47:22.571: TFTP: Server request for port 49304, socket_id 0x48343F60 for process 33

Jun 10 16:47:22.571: TFTP: read request from host 10.176.49.166(49304) via GigabitEthernet0/0.128

Jun 10 16:47:22.571: TFTP: Looking for SEP0017E015335F.cnf.xml

Jun 10 16:47:22.571: TFTP: Sending error 1 No such file

Jun 10 16:47:22.647: TFTP: Server request for port 49305, socket_id 0x48343F60 for process 33

Jun 10 16:47:22.647: TFTP: read request from host 10.176.49.166(49305) via GigabitEthernet0/0.128

Jun 10 16:47:22.647: TFTP: Looking for XmlDefault.cnf.xml

Jun 10 16:47:22.647: TFTP: Sending error 1 No such file

phretbored Mon, 06/16/2008 - 16:19

Ok I was able to enter multiple tftp-server statements in the local router...one for each firmware file that I loaded into flash.

Now my test phone start loading each file...this is progress!

However there are still 3 files that the phone is looking for but it the tftp debug shows errors because these files are not found on the local router:

CTLSEP00170E988E1C.tlv

SEP00170E988E1C.cnf.xml

XMLDefault.cnf.xml

Thse files should exist on Call Manager right?

The first two files are device specific and I believe the last file is for all phones.

At this point I updated the opt 150 statement by removing the local router address...so the phones should now look for Call Manager.

I reset my test phone to see if it would find the remaining 3 files but no luck.

Any ideas?

phretbored Tue, 06/17/2008 - 08:58

Good news!

It looks like it worked with a combination of pointing the phone to the local router to load the firmware files and then pointing the phone back to Call Manager to load some device specific files.

The firmware loaded pretty fast since it was local and the device specific files took several hours.

Actually I was not sure it would work but with patience the phone is now fully updated and registered with Call Manager.

Thanks to all for your input and especially thanks to maharris as her ideas were extremely helpful.

phretbored Tue, 07/01/2008 - 11:34

Here is the entire process that worked for me.

There may be some variations or other tricks to use depending on your specific situation.

For my specific situation this process was the only way I could get it to work.

The process is:

1) Download the firmware from Cisco and tftp the files to the local router

2) Config the local router so the dhcp phone pool option 150 statement has the local router ip address as the first address

3) Config the local router with a tftp-server statement for each firmware file…so I needed 7 tftp-server statements in total

4) Someone at the local facility has to force the phones to blow out the existing firmware via this process:

- Unplug the cable from the phone

- Hold the # key and plug the cable back in

- Do not release the # key…keep holding it for about 10 seconds

- Wait until the lines start flashing

- As soon as the lines flash, release the # key and dial the following digits using the phone keypad in this exact order: 1,2,3,4,5,6,7,8,9,*,0,#

- You have 10 seconds to dial all digits. If you fail to dial the above digits within 10 seconds, you may need to start over.

- The phones should release the old firmware and download the new one.

5) Monitor the local router via tftp debugs to see that each phone loads the firmware files

6) Remove the local router ip address from the dhcp phone pool option 150 statement so the first address is Call Manager so the phones can pick up any remaining device specific files.

Good Luck!

Actions

This Discussion