Configuration guidelines for Cisco871-K9 Model

Unanswered Question
May 23rd, 2008

I'm a novice having difficulty with configuring my 871 router with the virgin network on a cable modem. If anyone can give me a set of guidelines for this I'd be grateful.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ashley1234 Sat, 05/24/2008 - 01:06

Thanks a lot, Mark, a section of the config file is here, if you need more let me know. As you can see the clock is wrong for a start. I'm not sure whether to configure the router as dns server or use the virgin dns servers 62.253.162.237 and 194.168.4.237. ? also the question of static or dynamic routing? I have previously used a mercury K0B RI00 router which works fine on the dynamic/cable modem setting, I will include these settings in case it's useful.

clock timezone PCTime 0

clock summer-time PCTime date Mar 30 2003 1:00 Oct 26 2003 2:00

ip subnet-zero

ip cef

!

!

no ip dhcp use vrf connected

!

ip dhcp pool sdm-pool1

import all

network 10.10.10.0 255.255.255.0

dns-server 10.10.10.1

default-router 10.10.10.1

!

interface FastEthernet0

no cdp enable

!

interface FastEthernet1

no cdp enable

!

interface FastEthernet2

no cdp enable

!

interface FastEthernet3

no cdp enable

!

interface FastEthernet4

description $ES_WAN$$FW_OUTSIDE$

ip address 192.168.1.10 255.255.255.0

ip access-group 101 in

ip verify unicast reverse-path

ip nat outside

ip inspect DEFAULT100 out

ip virtual-reassembly

ip route-cache flow

duplex auto

speed auto

no cdp enable

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$

ip address 10.10.10.1 255.255.255.0

ip access-group 100 in

ip nat inside

ip virtual-reassembly

ip route-cache flow

ip tcp adjust-mss 1452

!

ip classless

ip route 0.0.0.0 0.0.0.0 FastEthernet4

!

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source list 1 interface FastEthernet4 overload

ip nat inside source static tcp 10.10.10.2 23 interface FastEthernet4 23

!

logging trap debugging

line con 0

login local

no modem enable

transport output telnet

line aux 0

login local

transport output telnet

line vty 0 4

privilege level 15

login local

transport input telnet ssh

!

scheduler max-task-time 5000

scheduler allocate 4000 1000

scheduler interval 500

end

Here are the settings for the Mercury router which works fine -

Connection Type Dynamic IP

WAN IP 82.22.8.84

Subnet Mask 255.255.252.0

Gateway 82.22.8.1

DNS 62.253.162.237

Secondary DNS 194.168.4.237

LAN

IP Address 192.168.1.1

Subnet Mask 255.255.255.0

DHCP Server Enabled

Firewall Enabled

INFORMATION

System Time 2008/05/24 09:03:23

System Boot Up Time 00007 days 22:40:22

Connected Clients 0

Runtime Code Version V2.00.0096

Boot Code Version V2.00.34

LAN MAC Address 00-40-F4-FD-B8-A8

WAN MAC Address 00-40-F4-FD-B8-A9

Paolo Bevilacqua Sat, 05/24/2008 - 05:11

You configure:

ip dhcp pool sdm-pool1

dns-server 62.253.162.237 194.168.4.237

int fa4

ip address dhcp

no ip access-group 101 in

no ip verify unicast reverse-path

no ip inspect DEFAULT100 out

no ip route-cache flow

int vlan1

no ip route-cache flow

no access-group 100 in

no ip tcp adjust-mss 1452

no ip http server

no ip http secure-server

no ip nat inside source static tcp 10.10.10.2 23 interface FastEthernet4 23

ip nat inside source static tcp 10.10.10.2 23 interface FastEthernet4 230

no ip route 0.0.0.0 0.0.0.0 fa4

access-list 1 permit 10.10.10.0 0.0.0.255

That should get you going. To telnet from outside to your .2 device, telnet to the address of the router, port 230. The route can also use Dynamic DNS so you always know which address it got.

Hope this helps, please rate post i it does!

ashley1234 Mon, 05/26/2008 - 02:29

Configured as requested, but must be doing something wrong somewhere as there is still no internet connectivity. The ethernet cable to my pc is on f3 by the way.

Please have a look at the current configuration and advise what to do next.

Thanks!

Building configuration...

Current configuration : 3727 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

!

no aaa new-model

!

resource policy

!

ip subnet-zero

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 10.10.10.249 10.10.10.254

!

ip dhcp pool sdm-pool1

import all

network 10.10.10.0 255.255.255.0

dns-server 62.253.162.237 194.168.4.237

!

!

ip name-server 62.253.162.237

ip name-server 194.168.4.237

!

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

no ip address

duplex auto

speed auto

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$

ip address 10.10.10.1 255.255.255.0

!

ip classless

!

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

no cdp run

!

!

control-plane

!

banner login ^C

^C

!

line con 0

login local

no modem enable

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet ssh

!

scheduler max-task-time 5000

end

Mark Yeates Mon, 05/26/2008 - 03:16

Ashley,

You will need to implement NAT (Network Address Translation) on your router to be able to access the internet on the inside of your network. Please input the following lines into your router.

access-list 1 remark NAT_ACL

access-list 1 permit 10.10.10.0 0.0.0.255

!

ip nat inside source list 1 interface FastEthernet4 overload

!

interface FastEthernet4

ip nat outside

!

interface Vlan1

ip nat inside

This will allow you to utilize all four switchports.

Mark

ashley1234 Mon, 05/26/2008 - 04:52

Done, but still no connection. I note that in SDM

the WAN type is unsupported and has no ip address. Here is the latest configuration:

Building configuration...

Current configuration : 3910 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

!

no aaa new-model

!

resource policy

!

ip subnet-zero

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 10.10.10.249 10.10.10.254

!

ip dhcp pool sdm-pool1

import all

network 10.10.10.0 255.255.255.0

dns-server 62.253.162.237 194.168.4.237

!

!

ip name-server 62.253.162.237

ip name-server 194.168.4.237

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

no ip address

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$

ip address 10.10.10.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

ip classless

!

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source list 1 interface FastEthernet4 overload

!

access-list 1 remark NAT_ACL

access-list 1 permit 10.10.10.0 0.0.0.255

no cdp run

!

!

control-plane

!

banner login ^C

^C

!

line con 0

login local

no modem enable

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet ssh

!

scheduler max-task-time 5000

end

Mark Yeates Sat, 05/24/2008 - 09:19

Do you have an NTP server on your network? I usually recommend the use of a NTP server to synchronize the clock on the router. I use a public server for my home equipment. Feel free to use the below statements to update the time on your router.

ntp server 207.46.130.100 source FastEthernet4 prefer

ntp server 192.43.244.18 source FastEthernet4

and these for your appropriate timezone.

clock timezone Central -6

clock summer-time CDT recurring

If there is anything else you need help with let us know.

Mark

ashley1234 Mon, 05/26/2008 - 03:03

Mark, configured the ntp server, but still no web access or net connectivity. Here is my current configuration, can you tell me what's wrong?

I can post ipconfig /all results from the pc command line if you need it.

Thanks

Building configuration...

Current configuration : 3727 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

!

no aaa new-model

!

resource policy

!

ip subnet-zero

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 10.10.10.249 10.10.10.254

!

ip dhcp pool sdm-pool1

import all

network 10.10.10.0 255.255.255.0

dns-server 62.253.162.237 194.168.4.237

!

!

ip name-server 62.253.162.237

ip name-server 194.168.4.237

!

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

no ip address

duplex auto

speed auto

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$

ip address 10.10.10.1 255.255.255.0

!

ip classless

!

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

no cdp run

!

!

control-plane

!

banner login ^C

^C

!

line con 0

login local

no modem enable

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet ssh

!

scheduler max-task-time 5000

end

Paolo Bevilacqua Mon, 05/26/2008 - 05:03

Please review my configuration above, you're mssing "ip address dhcp" and many other commands.

ashley1234 Mon, 05/26/2008 - 06:15

I've re-entered all the commands in your list, and I see that the WAN interface in SDM is unsupported, there is no ip address. Where do I go from here?

ashley1234 Mon, 05/26/2008 - 06:17

also, should I configure default gateway and gateway of last resort, and if so, how?

Ashley

Paolo Bevilacqua Mon, 05/26/2008 - 06:20

No, that is not needed.

Please use the CLI exclusively to configure the router. With SDM you've no guarantee whatsoever to get it working.

markyeates Mon, 05/26/2008 - 07:25

I noticed two things that are preventing web access from working. Are you using a modem of somesort ie.. cable/DSL? I notice that fastethernet 4 does not have an IP address. If you are using a DHCP address for your outside IP address please add this command to FA4. If not add the static IP address from your ISP.

interface FastEthernet4

ip address dhcp

I also see that you don't have a default route. paste the following command.

ip route 0.0.0.0 0.0.0.0 FastEthernet4

You should also re add your DHCP pool with the addition to the default router command.

ip dhcp pool sdm-pool1

import all

network 10.10.10.0 255.255.255.0

dns-server 62.253.162.237 194.168.4.237

default-router 10.10.10.1

Hope this helps

Mark

Paolo Bevilacqua Mon, 05/26/2008 - 07:38

Hi, this command:

ip route 0.0.0.0 0.0.0.0 FastEthernet4

Is always wrong for two reasons:

First, when router get an address via DHCP, it also install a default static route automatically, so it's not needed.

Second, even if router had a static IP address, a route referencing a LAN interface instead of an IP address, causes router to ARP for any destination.

That is not the inteded behavoir, so for routes going via LAN interface one should always use IP addresses, and not the interface itself.

Mark Yeates Mon, 05/26/2008 - 08:44

Thanks for the clarification. I usually don't configure it that way, As I wasn't sure if she needed a static IP or a DHCP address. I was going to advise her to change it after the router is configured, and passing traffic.

Mark

ashley1234 Mon, 05/26/2008 - 10:34

All done, except for the ip route command which was advised against. Still no connection however.

In case it helps, here is information about my cable modem. Thus far have been unable to update the driver.

Cable Modem Information

Cable Modem : Euro-DOCSIS 1.0/1.1/2.0 Compliant

MAC Address : 00:14:a4:c9:8d:f7

Serial Number : 0014A4C98DF7

Boot Code Version : 3.1.6d

Software Version : 2.94.1014

Hardware Version : 1.19

Modem status

Acquire a Downstream Channel 586750000 Hz Locked

Connectivity State OK Operational

Boot State OK Operational

Cable Modem Downstream

Downstream Lock : Locked

Downstream Channel Id : 2

Downstream Frequency : 586750000 Hz

Downstream Modulation : QAM256

Downstream Symbol Rate : 6952 Ksym/sec

Downstream Interleave Depth : taps12Increment17

Downstream Receive Power Level : 3.5 dBmV

Downstream SNR : 33.4 dB

Cable Modem Upstream

Upstream Lock : Locked

Upstream Channel ID : 3

Upstream Frequency : 42800000 Hz

Upstream Modulation : QAM16

Upstream Symbol Rate : 2560 Ksym/sec

Upstream transmit Power Level : 46.0 dBmV

Upstream Mini-Slot Size : 2

Cable Modem Operation Configuration

Network Access : Allowed

Maximum Downstream Data Rate : 20480000

Maximum Upstream Data Rate : 768000

Maximum Upstream Channel Burst : 1600

Maximum Number of CPEs : 1

Modem Capability : Concatenation Enabled, Fragametation Enabled, PHS Disabled

ashley1234 Mon, 05/26/2008 - 11:59

carefully typed in all your commands again one by one, still no luck?, also configured NAT per Mark's instructions. It seems the WAN interface is not recieving an ip address via dhcp and is unsupported in SDM? what am I missing?

Ashley

Paolo Bevilacqua Mon, 05/26/2008 - 12:07

Again, do not rely on the SDM.

Sometime, the DHCP client in cisco routers is incompatible. Can you send output of "show interface fa4" ?

ashley1234 Mon, 05/26/2008 - 23:21

Output of "show interface f4":

Router#show interface fa4

FastEthernet4 is up, line protocol is up

Hardware is PQUICC_FEC, address is 001e.7a3d.1e80 (bia 001e.7a3d.1e80)

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, 100BaseTX/FX

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:27, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

64 packets input, 21888 bytes

Received 64 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog

0 input packets with dribble condition detected

0 packets output, 0 bytes, 0 underruns

0 output errors, 0 collisions, 3 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

ashley1234 Tue, 05/27/2008 - 02:27

I must add, I noticed the configuration wasn't being saved when the router was switched off so I re-entered all requested commands then ran "copy startup-config running-config". the result for "show interface fa4" is now different, you can see 82.22.11.172/22 has been assigned, still no connectivity however:

Router#sh interface fa4

FastEthernet4 is up, line protocol is up

Hardware is PQUICC_FEC, address is 001e.7a3d.1e80 (bia 001e.7a3d.1e80)

Internet address is 82.22.11.172/22

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, 100BaseTX/FX

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:06, output 00:00:18, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

158 packets input, 44232 bytes

Received 120 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog

0 input packets with dribble condition detected

76 packets output, 7536 bytes, 0 underruns

0 output errors, 0 collisions, 3 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

Also here is the result of the "sh ip route" command:

Router#sh ip route

Gateway of last resort is 82.22.8.1 to network 0.0.0.0

80.0.0.0/32 is subnetted, 1 subnets

S 80.1.224.37 [254/0] via 82.22.8.1, FastEthernet4

82.0.0.0/22 is subnetted, 1 subnets

C 82.22.8.0 is directly connected, FastEthernet4

10.0.0.0/24 is subnetted, 1 subnets

C 10.10.10.0 is directly connected, Vlan1

S* 0.0.0.0/0 [254/0] via 82.22.8.1

Paolo Bevilacqua Tue, 05/27/2008 - 03:04

Ok, after configuring you have to exit config with ctrl-Z, then enter "write" to save config.

Now from the router try to ping to one of your DNS addresses, or 4.2.2.1

For the lack of connectivity I'm afraid some command is still missing so you will have to send configuration again.

Do not despair, you're almost there.

ashley1234 Tue, 05/27/2008 - 06:25

No problem, your help is invaluable.

Here is the latest configuration:

!

clock timezone GMT 0

clock summer-time GMT recurring

ip subnet-zero

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 10.10.10.249 10.10.10.254

!

ip dhcp pool sdm-pool1

import all

network 10.10.10.0 255.255.255.0

dns-server 62.253.162.237 194.168.4.237

default-router 10.10.10.1

!

!

ip name-server 62.253.162.237

ip name-server 194.168.4.237

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

ip address dhcp

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$

ip address 10.10.10.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

ip classless

!

!

no ip http server

ip http authentication local

no ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source list 1 interface FastEthernet4 overload

ip nat inside source static tcp 10.10.10.2 23 interface FastEthernet4 230

!

access-list 1 permit 10.10.10.0 0.0.0.255

access-list 1 remark NAT_ACL

access-list 1 remark NAT_ACL

no cdp run

!

!

control-plane

!

banner login ^C

^C

!

line con 0

login local

no modem enable

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet ssh

!

scheduler max-task-time 5000

ntp clock-period 17179760

ntp server 207.46.130.100 source FastEthernet4 prefer

ntp server 192.43.244.18 source FastEthernet4

end

And here is the output from "show ip route" command:

Router#sh ip route

Gateway of last resort is 82.22.8.1 to network 0.0.0.0

80.0.0.0/32 is subnetted, 1 subnets

S 80.1.224.37 [254/0] via 82.22.8.1, FastEthernet4

82.0.0.0/22 is subnetted, 1 subnets

C 82.22.8.0 is directly connected, FastEthernet4

10.0.0.0/24 is subnetted, 1 subnets

C 10.10.10.0 is directly connected, Vlan1

S* 0.0.0.0/0 [254/0] via 82.22.8.1

Mark Yeates Tue, 05/27/2008 - 07:45

Ashley,

I am not seeing anything in your config that would prevent you from accessing the web. Please make sure that you PC's have a valid IP address in the 10.10.10.X scope. I do recommend applying the "spanning-tree portfast" command to int fa3 that your PC is connected to. Please keep us posted.

Mark

ashley1234 Tue, 05/27/2008 - 09:41

Done as requested. I notice that I can only access the router with CLI and not SDM at the moment, still no web. At least now when I try ipconfig /all in the pc command line, you see the default gateway 10.10.10.1 and 10.10.10.2 is automatically configured by DHCP. Also 'show ip route' seems to indicate that DHCP is working on fa4, so what's missing? Here is the output from 'do show spanning-tree' command:

Chiron(config)#do show spanning-tree

VLAN1 is executing the ieee compatible Spanning Tree protocol

Bridge Identifier has priority 32768, address 001e.7a3d.1e76

Configured hello time 2, max age 20, forward delay 15

We are the root of the spanning tree

Topology change flag not set, detected flag not set

Number of topology changes 1 last change occurred 01:00:34 ago

from FastEthernet3

Times: hold 1, topology change 35, notification 2

hello 2, max age 20, forward delay 15

Timers: hello 1, topology change 0, notification 0, aging 300

Port 4 (FastEthernet3) of VLAN1 is forwarding

Port path cost 19, Port priority 128, Port Identifier 128.4.

Designated root has priority 32768, address 001e.7a3d.1e76

Designated bridge has priority 32768, address 001e.7a3d.1e76

Designated port id is 128.4, designated path cost 0

Timers: message age 0, forward delay 0, hold 0

Number of transitions to forwarding state: 1

BPDU: sent 1832, received 0

The port is in the portfast mode

Mark Yeates Tue, 05/27/2008 - 15:13

On that note make sure that you can ping your DNS servers from both your router, and your PC. Based on your config the IP addresses are:

62.253.162.237

194.168.4.237

I think we are getting close to a resolution.

Mark

ashley1234 Tue, 05/27/2008 - 20:37

Yes, I can ping them successfully from both the PC and the router, and most of the other addresses shown in 'show ip route' output. There were two other dns servers shown in the output I had not seen before. I will ping all the addresses again and give you the results.

Ashley

ashley1234 Tue, 05/27/2008 - 21:43

I must correct myself here. I should have said, I can ping the dns servers successfully from the pc while using my mercury router, but NOT from the cisco router, which I tried to communicate with this morning with no success. In my PC command line I typed ipconfig /all and got a different set of results from yesterday. There was an automatic assignment of ip address 169.254.37.215

subnet mask 255.255.0.0, no gateway. I tried pinging the dns servers from the command line, unsuccessfully.

Yesterday the results from ipconfig /all were ip address 10.10.10.2, gateway 10.10.10.1

assigned automatically. I remember this situation happened before, after configuring the cisco router according to instruction. At first, there was an automatic assignment of 10.10.10.2 and CLI was accessible. The following day, I was assigned a similar address to 169.254.37.215 and lost contact with the router. Is there some issue here with DHCP?

Ashley

Paolo Bevilacqua Wed, 05/28/2008 - 04:57

Please try ping from router accessed via CLI. You can give to a static PC address if any DHCP trouble.

Mark Yeates Wed, 05/28/2008 - 05:49

You will want to ping the IP address (FA4) that was assigned to your router from your ISP.

Mark

ashley1234 Wed, 05/28/2008 - 06:44

Right, I can ping 82.22.8.1 (the adress assigned to fa4) no problem with my mercury router connected, but when I try with the cisco router connected I get destination unreachable on the pc command line and still no way of communicating with the router CLI.

Mark Yeates Wed, 05/28/2008 - 14:21

You are not able to console into the cisco router? I'm not sure if I understand which pings work at this point.

ping from PC to fa4 (DHCP address)

ping from PC to ISP gateway

ping from router to ISP gateway.

From previous posts your fa4 IP was 82.22.11.172

ISP gateway IP 82.22.8.1

Based on your response we will know where we stand at this point.

Mark

ashley1234 Wed, 05/28/2008 - 22:59

I have tried pinging 82.22.11.172 and 82.22.8.1 without success from the command line. When I type ipconfig /all it shows the address 169.254.37.215, subnet 255.255.0.0 has been assigned to my PC, but no gateway. Why did the address change from 10.10.10.2?

Thanks,

Ashley

ashley1234 Thu, 05/29/2008 - 02:04

The latest situation (as of 29th May) is this.

I pressed the reset button on the router and found I was able to access CLI in a telnet putty session on 10.10.10.1 23 Not only that but I could ping all the addresses shown in the 'show ip route' command successfully, both from the router and from the pc. However, the ip address for fa4 had changed to 80.0.59.74. still no web access. Here is the current output from 'Show ip route', 'show ip int brief' and 'sh ip arp' commands:

Router#sh ip route

Gateway of last resort is 80.0.56.1 to network 0.0.0.0

80.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C 80.0.56.0/22 is directly connected, FastEthernet4

S 80.1.224.37/32 [254/0] via 80.0.56.1, FastEthernet4

10.0.0.0/24 is subnetted, 1 subnets

C 10.10.10.0 is directly connected, Vlan1

S* 0.0.0.0/0 [254/0] via 80.0.56.1

Router#sh ip int brief

Interface IP-Address OK? Method Status Protocol

FastEthernet0 unassigned YES unset up down

FastEthernet1 unassigned YES unset up down

FastEthernet2 unassigned YES unset up down

FastEthernet3 unassigned YES unset up up

FastEthernet4 80.0.59.74 YES DHCP up up

Vlan1 10.10.10.1 YES NVRAM up up

NVI0 unassigned YES unset up up

Router#sh ip arp

Protocol Address Age (min) Hardware Addr Type Interface

Internet 10.10.10.2 7 0016.e64f.c4ad ARPA Vlan1

Internet 10.10.10.1 - 001e.7a3d.1e76 ARPA Vlan1

Internet 80.0.59.74 - 001e.7a3d.1e80 ARPA FastEthernet4

Internet 80.0.56.1 32 0005.74f7.3001 ARPA FastEthernet4

Mark Yeates Thu, 05/29/2008 - 06:15

It sounds like we have made some progress. If you are able to ping outside of the network from the router and PC then things are working fine. Are you sure you have the right DNS server IP addresses added to your router? That's the only thing I can think of why web access doesn't work, but pings do.

ashley1234 Thu, 05/29/2008 - 06:52

I was originally given 62.253.162.237 and 194.168.4.237 as name servers, and when I tried 'show hosts' on CLI I got these plus an additional 194.168.4.100 and 194.168.8.100. I successfully pinged them all.

Mark Yeates Thu, 05/29/2008 - 07:04

That's good that you can ping the IP's. I just want to make sure that they are valid DNS servers. You can test using 4.2.2.1 as a test DNS server.

ashley1234 Thu, 05/29/2008 - 07:43

Yes! I now have full web connectivity. The problem was quite simple, I had omitted to configure my domain name, duh...

Thanks so much for your help. I may need to think of a couple of questions to ask about general security configuration, and just at the moment can't bring up SDM, but that's all. I'd like to rate this message to notify the problem has been solved, but there doesn't seem to be a box yet?

Ashley

Mark Yeates Thu, 05/29/2008 - 13:09

Great. You should be able to rate the conversation. Please start another post with your other questions, as this one was quite difficult to keep up with. Im glad we got the issue resolved, and would glad to still help in the future.

Mark

ashley1234 Tue, 05/27/2008 - 21:48

While I was in contact with the cisco router it was possible to ping most of the addresses in the network. However, as I said to Mark:

I can ping the dns servers successfully from the pc while using my mercury router, but NOT from the cisco router, which I tried to communicate with this morning with no success. In my PC command line I typed ipconfig /all and got a different set of results from yesterday. There was an automatic assignment of ip address 169.254.37.215

subnet mask 255.255.0.0, no gateway. I tried pinging the dns servers from the command line, unsuccessfully.

Yesterday the results from ipconfig /all were ip address 10.10.10.2, gateway 10.10.10.1

assigned automatically. I remember this situation happened before, after configuring the cisco router according to instruction. At first, there was an automatic assignment of 10.10.10.2 and CLI was accessible. The following day, I was assigned a similar address to 169.254.37.215 and lost contact with the router. Is there some issue here with DHCP?

Ashley

Mark Yeates Mon, 05/26/2008 - 14:06

Please post the output of the "show ip interface brief" command. I would like to make sure that you are getting an IP address. You also may need to reset the modem for 30-45 seconds. Sometimes that does the trick.

Mark

ashley1234 Mon, 05/26/2008 - 23:20

Here we are, output of "show ip interface brief".

I have tried resetting the modem, still no luck, though it works fine on my Mercury router. The PC connects to fa3.

Router#show ip interface brief (typed in two columns to avoid scrambled output)

Interface FastEthernet0

IP-Address unassigned

OK? YES

Method unset

Status up

Protocol down

Interface FastEthernet1

IP-Adress unassigned

OK? YES

Method unset

Status up

Protocol down

Interface FastEthernet2

IP-Adress unassigned

OK? YES

Method unset

Status up

Protocol down

Interface FastEthernet3

IP-Adress unassigned

OK? YES

Method unset

Status up

Protocol up

Interface FastEthernet4

IP-Adress unassigned

OK? YES

Method NVRAM

Status up

Protocol up

Interface Vlan1

IP-Adress 10.10.10.1

OK? YES

Method NVRAM

Status up

Protocol up

Paolo Bevilacqua Mon, 05/26/2008 - 23:25

Please send output of "show interface fa4". To see at least if DHCP packets travels on it.

ashley1234 Tue, 05/27/2008 - 02:10

I must add: it seems the running configuration wasn't being saved when the cisco router was switched off and on again so I loaded all the commands again one by one and then input "copy startup-config running-config"

Then the output of "show ip interface brief"

was different. Here it is. Question, I can see

fa4 has now been assigned 82.22.11.172 via DHCP, but still no connectivity? also what is interface NVI0? I also ran "sh ip route" and got interesting results shown below this:

Thanks!

Ashley

Router#sh ip interface brief

nterface FastEthernet0

IP-Address unassigned

OK? YES

Method unset

Status up

Protocol down

Interface FastEthernet1

IP-Adress unassigned

OK? YES

Method unset

Status up

Protocol down

Interface FastEthernet2

IP-Adress unassigned

OK? YES

Method unset

Status up

Protocol down

Interface FastEthernet3

IP-Adress unassigned

OK? YES

Method unset

Status up

Protocol up

Interface FastEthernet4

IP-Adress 82.22.11.172

OK? YES

Method DHCP

Status up

Protocol up

Interface Vlan1

IP-Adress 10.10.10.1

OK? YES

Method NVRAM

Status up

Protocol up

Interface NVI0

IP-Adress unassigned

OK? YES

Method unset

Status up

Protocol up

Router#sh ip route

Gateway of last resort is 82.22.8.1 to network 0.0.0.0

80.0.0.0/32 is subnetted, 1 subnets

S 80.1.224.37 [254/0] via 82.22.8.1, FastEthernet4

82.0.0.0/22 is subnetted, 1 subnets

C 82.22.8.0 is directly connected, FastEthernet4

10.0.0.0/24 is subnetted, 1 subnets

C 10.10.10.0 is directly connected, Vlan1

S* 0.0.0.0/0 [254/0] via 82.22.8.1

Actions

This Discussion