cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2095
Views
0
Helpful
50
Replies

Configuration guidelines for Cisco871-K9 Model

ashley1234
Level 1
Level 1

I'm a novice having difficulty with configuring my 871 router with the virgin network on a cable modem. If anyone can give me a set of guidelines for this I'd be grateful.

50 Replies 50

paolo bevilacqua
Hall of Fame
Hall of Fame

Post actual configuration and someone may have it corrected for you.

Mark Yeates
Level 7
Level 7

Ashley,

Here is a configuration guide for the 850/870 series routers. Just like Paolo said that if you post the config we would be glad to help you.

http://www.cisco.com/en/US/docs/routers/access/800/850/software/configuration/guide/857sg_bk.pdf

Mark

Thanks a lot, Mark, a section of the config file is here, if you need more let me know. As you can see the clock is wrong for a start. I'm not sure whether to configure the router as dns server or use the virgin dns servers 62.253.162.237 and 194.168.4.237. ? also the question of static or dynamic routing? I have previously used a mercury K0B RI00 router which works fine on the dynamic/cable modem setting, I will include these settings in case it's useful.

clock timezone PCTime 0

clock summer-time PCTime date Mar 30 2003 1:00 Oct 26 2003 2:00

ip subnet-zero

ip cef

!

!

no ip dhcp use vrf connected

!

ip dhcp pool sdm-pool1

import all

network 10.10.10.0 255.255.255.0

dns-server 10.10.10.1

default-router 10.10.10.1

!

interface FastEthernet0

no cdp enable

!

interface FastEthernet1

no cdp enable

!

interface FastEthernet2

no cdp enable

!

interface FastEthernet3

no cdp enable

!

interface FastEthernet4

description $ES_WAN$$FW_OUTSIDE$

ip address 192.168.1.10 255.255.255.0

ip access-group 101 in

ip verify unicast reverse-path

ip nat outside

ip inspect DEFAULT100 out

ip virtual-reassembly

ip route-cache flow

duplex auto

speed auto

no cdp enable

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$

ip address 10.10.10.1 255.255.255.0

ip access-group 100 in

ip nat inside

ip virtual-reassembly

ip route-cache flow

ip tcp adjust-mss 1452

!

ip classless

ip route 0.0.0.0 0.0.0.0 FastEthernet4

!

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source list 1 interface FastEthernet4 overload

ip nat inside source static tcp 10.10.10.2 23 interface FastEthernet4 23

!

logging trap debugging

line con 0

login local

no modem enable

transport output telnet

line aux 0

login local

transport output telnet

line vty 0 4

privilege level 15

login local

transport input telnet ssh

!

scheduler max-task-time 5000

scheduler allocate 4000 1000

scheduler interval 500

end

Here are the settings for the Mercury router which works fine -

Connection Type Dynamic IP

WAN IP 82.22.8.84

Subnet Mask 255.255.252.0

Gateway 82.22.8.1

DNS 62.253.162.237

Secondary DNS 194.168.4.237

LAN

IP Address 192.168.1.1

Subnet Mask 255.255.255.0

DHCP Server Enabled

Firewall Enabled

INFORMATION

System Time 2008/05/24 09:03:23

System Boot Up Time 00007 days 22:40:22

Connected Clients 0

Runtime Code Version V2.00.0096

Boot Code Version V2.00.34

LAN MAC Address 00-40-F4-FD-B8-A8

WAN MAC Address 00-40-F4-FD-B8-A9

You configure:

ip dhcp pool sdm-pool1

dns-server 62.253.162.237 194.168.4.237

int fa4

ip address dhcp

no ip access-group 101 in

no ip verify unicast reverse-path

no ip inspect DEFAULT100 out

no ip route-cache flow

int vlan1

no ip route-cache flow

no access-group 100 in

no ip tcp adjust-mss 1452

no ip http server

no ip http secure-server

no ip nat inside source static tcp 10.10.10.2 23 interface FastEthernet4 23

ip nat inside source static tcp 10.10.10.2 23 interface FastEthernet4 230

no ip route 0.0.0.0 0.0.0.0 fa4

access-list 1 permit 10.10.10.0 0.0.0.255

That should get you going. To telnet from outside to your .2 device, telnet to the address of the router, port 230. The route can also use Dynamic DNS so you always know which address it got.

Hope this helps, please rate post i it does!

Thanks very much, will get back to you on this...

Configured as requested, but must be doing something wrong somewhere as there is still no internet connectivity. The ethernet cable to my pc is on f3 by the way.

Please have a look at the current configuration and advise what to do next.

Thanks!

Building configuration...

Current configuration : 3727 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

!

no aaa new-model

!

resource policy

!

ip subnet-zero

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 10.10.10.249 10.10.10.254

!

ip dhcp pool sdm-pool1

import all

network 10.10.10.0 255.255.255.0

dns-server 62.253.162.237 194.168.4.237

!

!

ip name-server 62.253.162.237

ip name-server 194.168.4.237

!

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

no ip address

duplex auto

speed auto

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$

ip address 10.10.10.1 255.255.255.0

!

ip classless

!

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

no cdp run

!

!

control-plane

!

banner login ^C

^C

!

line con 0

login local

no modem enable

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet ssh

!

scheduler max-task-time 5000

end

Ashley,

You will need to implement NAT (Network Address Translation) on your router to be able to access the internet on the inside of your network. Please input the following lines into your router.

access-list 1 remark NAT_ACL

access-list 1 permit 10.10.10.0 0.0.0.255

!

ip nat inside source list 1 interface FastEthernet4 overload

!

interface FastEthernet4

ip nat outside

!

interface Vlan1

ip nat inside

This will allow you to utilize all four switchports.

Mark

Done, but still no connection. I note that in SDM

the WAN type is unsupported and has no ip address. Here is the latest configuration:

Building configuration...

Current configuration : 3910 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

!

no aaa new-model

!

resource policy

!

ip subnet-zero

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 10.10.10.249 10.10.10.254

!

ip dhcp pool sdm-pool1

import all

network 10.10.10.0 255.255.255.0

dns-server 62.253.162.237 194.168.4.237

!

!

ip name-server 62.253.162.237

ip name-server 194.168.4.237

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

no ip address

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$

ip address 10.10.10.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

ip classless

!

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source list 1 interface FastEthernet4 overload

!

access-list 1 remark NAT_ACL

access-list 1 permit 10.10.10.0 0.0.0.255

no cdp run

!

!

control-plane

!

banner login ^C

^C

!

line con 0

login local

no modem enable

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet ssh

!

scheduler max-task-time 5000

end

Do you have an NTP server on your network? I usually recommend the use of a NTP server to synchronize the clock on the router. I use a public server for my home equipment. Feel free to use the below statements to update the time on your router.

ntp server 207.46.130.100 source FastEthernet4 prefer

ntp server 192.43.244.18 source FastEthernet4

and these for your appropriate timezone.

clock timezone Central -6

clock summer-time CDT recurring

If there is anything else you need help with let us know.

Mark

Much appreciated, will let you know how everything went.

Mark, configured the ntp server, but still no web access or net connectivity. Here is my current configuration, can you tell me what's wrong?

I can post ipconfig /all results from the pc command line if you need it.

Thanks

Building configuration...

Current configuration : 3727 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

!

no aaa new-model

!

resource policy

!

ip subnet-zero

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 10.10.10.249 10.10.10.254

!

ip dhcp pool sdm-pool1

import all

network 10.10.10.0 255.255.255.0

dns-server 62.253.162.237 194.168.4.237

!

!

ip name-server 62.253.162.237

ip name-server 194.168.4.237

!

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

no ip address

duplex auto

speed auto

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$

ip address 10.10.10.1 255.255.255.0

!

ip classless

!

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

no cdp run

!

!

control-plane

!

banner login ^C

^C

!

line con 0

login local

no modem enable

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet ssh

!

scheduler max-task-time 5000

end

Please review my configuration above, you're mssing "ip address dhcp" and many other commands.

I've re-entered all the commands in your list, and I see that the WAN interface in SDM is unsupported, there is no ip address. Where do I go from here?

also, should I configure default gateway and gateway of last resort, and if so, how?

Ashley

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Innovations in Cisco Full Stack Observability - A new webinar from Cisco