RingList.xml / DistinctiveRingList.xml - why arn't phones using them?

Unanswered Question
May 23rd, 2008

Hi all.

I've copied a load of RAW files into the flash of my ccme 2801:

tftp-server flash:Classic1.raw

tftp-server Analog1.raw

tftp-server Analog2.raw

tftp-server AreYouThere.raw

tftp-server AreYouThereF.raw

tftp-server Bass.raw

tftp-server CallBack.raw

tftp-server Chime.raw

tftp-server Classic2.raw

tftp-server ClockShop.raw

tftp-server DistinctiveRingList.xml

tftp-server Drums1.raw

tftp-server Drums2.raw

tftp-server FilmScore.raw

tftp-server HarpSynth.raw

tftp-server Jamaica.raw

tftp-server KotoEffect.raw

tftp-server MusicBox.raw

tftp-server Piano1.raw

tftp-server Piano2.raw

tftp-server Pop.raw

tftp-server Pulse1.raw

tftp-server Ring1.raw

tftp-server Ring2.raw

tftp-server Ring3.raw

tftp-server Ring4.raw

tftp-server Ring5.raw

tftp-server Ring6.raw

tftp-server Ring7.raw

tftp-server RingList.xml

tftp-server Sax1.raw

tftp-server Sax2.raw

tftp-server Vibe.raw

And shared them out using the above commands.

I've edited ringlist and distinctiveringlist.xml files and put those in the root of flash too.

My CCME Admin guide pretty much says this is all I need to do. Reboot the phones and away I go.

However, on my 7941, I go into Settings, User Preferences, Rings, and only Chirp 1 is available. Where am I going wrong?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
rob.huffman Sat, 05/24/2008 - 06:16

Hey Sankar,

Nice to see you back my friend! +5 for this good tip.

Take care,


davieshuw Tue, 05/27/2008 - 02:30

Hi guys, sorry I forgot to subscribe to this thread doh!

First thing I did was a create cnf files, and I dont get any error message appearing on phone bootup.. still all the same. Odd.. are the 7941's capable of supporting these ringtones?

thisisshanky Wed, 05/28/2008 - 04:10

Hey Rob, Thanks for the comments and the points..its been a while..feels good to be back.

bkvalentine Wed, 05/28/2008 - 17:08


It looks like you've forgotten the "flash:" part of the tftp-server command for every item that you want to serve via tftp.

For instance, say "tftp-server flash:RingList.xml".

Make that change for all of your tftp-server commands and then reboot the phones.

Matheus Lopes Fri, 01/03/2014 - 06:00

Hi guys,

I got the same problem with IP Phone 7940 and i fixed this issue creating cnf-files and reseting the phone.


This Discussion