CCM 4.1(3)SR7 Extension Mobility issue

Unanswered Question
May 23rd, 2008

Hello,

we are running 4.1(3)SR7 on our Dev Enviroment and Extension Mobility no longer works.

We have a publisher and a subscriber and on both Tomcat is running.

I have already deleted and re-added the Cisco IP Phone Service for Extension Mobility and assigned it to the Phones but I still get a HTTP 404 error when I try to Logon.

If I use the following URL in my Browser http://10.143.11.31/emapp/EMAppServlet?device=#DEVICENAME#

I get the HTTP Status 404 - /emapp/EMAppServlet

This is from the stderr.log:

23-May-2008 14:22:23 org.apache.commons.modeler.Registry loadRegistry

INFO: Loading registry information

23-May-2008 14:22:23 org.apache.commons.modeler.Registry getRegistry

INFO: Creating new Registry instance

23-May-2008 14:22:24 org.apache.commons.modeler.Registry getServer

INFO: Creating MBeanServer

23-May-2008 14:22:26 org.apache.commons.digester.Digester error

SEVERE: Parse Error at line 14 column 13: The content of element type "servlet" must match "(icon?,servlet-name,display-name?,description?,(servlet-class|jsp-file),init-param*,load-on-startup?,security-role-ref*)".

(Above is only part of the attached error message)

Has anybody any Ideas ?

Thanks

Steffen

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Steffen.Baier Fri, 05/23/2008 - 07:20

Hello,

thanks for your fast response. I am not in the office anymore but we did manually stop and start the Tomcat Service via the Services as you cannot do this within CallManager.

I also rebooted the box multiple times so I shall have a read of your document.

Thanks

Steffen

Steffen.Baier Tue, 05/27/2008 - 09:47

Hello,

stopping and restarting Tomcat did not di the trick. I also rebooted the CCM again but still no luck.

In the link that you provided there is no mention of the 404 error.

Any other hints ?

THX

Steffen

Jaime Valencia Tue, 05/27/2008 - 09:56

you mention this is a dev environment, any chance someone else installed something new on the boxes?

do you get any errors in the app log?

what happens when you try on the phone?

HTH

javalenc

if this helps, please rate

Steffen.Baier Tue, 05/27/2008 - 10:03

Hello,

I am not aware of any other installations than SR7 and the latest Cisco OS Patches.

Were would I find the logs as I am not 100% familiar with their location.

Both Phone or using the Webbrowser give me the same 404 error.

I have traced via Wireshark and the CCM goves back that error.

THX

Steffen

Jaime Valencia Tue, 05/27/2008 - 10:06

i meant the application or system logs, just start -> run -> eventvwr.msc

HTH

javalenc

if this helps, please rate

Steffen.Baier Wed, 05/28/2008 - 02:33

Hello,

apologize for the silly question about the event viewer. I cannot see any issues in there especially after restarting the Publisher again.

I have now compared settings with our porduction system and have disabled extension mobility on our Dev Pub and only have it running on our Dev Sub. Another colleague of mine tried to troubleshoot a few weeks ago and he might have activated this then.

I have now also enabled the traces for Extension mobility via the Serviceability Page within the Troubleshooting Trace Setting.

On the Dev Publisher I have a C:\Program Files\Cisco\Trace\EM Directory as mentioned here: http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/admin/4_0_1/ccmfeat/fsappb.html

But no files have been written or created since the end of April.

There is no such directory even with the Trace activated on the Dev Subscriber.

Thx

Steffen

Steffen.Baier Wed, 05/28/2008 - 06:04

Dear all,

I have found the problem.

Around the 01.05.2008 something was installed on the Dev CCM Publisher but for whatever reason parts of the Tomcat Directory had whole subdirectories missing or just single files in them.

The affected directories were : C:\Program Files\Cisco\Tomcat\webapps\emapp and C:\Program Files\Cisco\Tomcat\webapps\emservice

I simply copied them over from our Dev CCM Subscriber and restarted the Publisher. Before the restart I started the Extension Mobility Service on the Publisher that I had before stopped.

Thanks everybody for their replies and I hope this post helps somebody in a Simular position.

Just for the Record:

CCM with 4.1(3)SR7 and latest OS 2000.4.5bSR11 installed.

Thanks

Steffen

Jaime Valencia Wed, 05/28/2008 - 06:19

told ya ;-) it's really strange that something just stops working like that, specially EM with that error.

i found several cases and someone always had the great idea of installing something extra and not telling anyone, thanks for letting us know what the issue was.

javalenc

Actions

This Discussion