Cannot write to const_nvram 6509 - Sup720

Unanswered Question
May 23rd, 2008

My IOS: s72033-ipservicesk9-mz.122-18.SXF12.bin


I cannot do a: "copy tftp const_nvram:vlan.dat"

After a successful tftp transfer, the switch immediately responds with an error to the effect of , "cannot write to const_nvram".


This command works with this IOS, "s72033-jk9sv-mz.122-18.SXD7b.bin"


Any help would be greatly appreciated!

thanks,

Jason

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
lamav Fri, 05/23/2008 - 08:26

In order to restore the vlan.dat file, complete these steps:


Copy the vlan.dat file into the device's NVRAM from a TFTP server or an external PCMCIA card.


copy tftp: const_nvram:

notice no vlan.dat file name present...


Reload the switch, as vlan.dat is read only during the booting process.


HTH


Victor



gilbert.jason Fri, 05/23/2008 - 08:58

Tried that and still have the same problem

Here is what I typed.

copy ttp: const_nvram:


I got:

"%Warning: There is a file already existing with this name Do you want to over write? [confirm]

Cannot copy from vlan.dat to vlan.dat"



ita_hsieh Tue, 10/19/2010 - 23:31

Dear Jason:


   Did you happen to solve the problem? I am facing the same issue. Thanks.

FlorianBerthelot Fri, 12/30/2011 - 05:29

Hello,

Did you manage to solve this issue ? I am having the same, i tried with a

erase const_nvram before the reload but with no luck.


Thanks in advance

amikat Sat, 12/31/2011 - 01:33

Hi,


Can you please post the "dir const_nvram:" command output.


Thanks&Regards,

Antonin

FlorianBerthelot Tue, 01/03/2012 - 00:54

Hello Amikat,

Thanks for your reply, dir const_nvram says that vlan.dat


1     -rwx     0          vlan.dat


I also did a

Chassis#erase const_nvram

Erasing the const_nvram filesystem will remove all configuration files! Continue? [confirm]

[OK]

Erase of const_nvram: complete

Chassis#reload

//output....


but no chances, i get :


User Access Verification


Password:

Chassis>en

Chassis#copy bootflash:vlan.dat const_nvram:vlan.dat

Destination filename [vlan.dat]?

%Warning:There is a file already existing with this name

Do you want to over write? [confirm]

Cannot copy from vlan.dat to vlan.dat

Chassis#exit


Thanks you in advance if you have any ideas...


best regards

amikat Tue, 01/03/2012 - 01:49

Hi,


Thanks for the reply.

Can you please try to use the command "delete const_nvram:vlan.dat" instead of "erase ..." and if succeed reload the switch and try again the "copy ..." command and see if there is any progress.


Best regards,

Antonin

FlorianBerthelot Tue, 01/03/2012 - 01:52

Hi again, same issu when I use the delete command... I will make some tests today and let you know, I did follow the Cisco procedure, i do have all expected output (reset of the VLAN & VTP configuration) but still no way to copy the file.

I will keep you informed, regards

amikat Tue, 01/03/2012 - 02:18

Hi,


Thanks for the reply.

What is you vtp status? I would suggest to set it to "client" before deleting the vlan.dat.


Best regards,

Antonin

FlorianBerthelot Fri, 01/06/2012 - 07:42

Hi

I tried to change the vtp status, no chance. I did upgrade the chassis to the same version as the originate vlan.dat, and that worked fine.

According to the TAC, this is not a software version issue, bug this might be bug

CSCsj71192.


VSL : Unable to replace vlan.dat file with Sierra image.

Symptom:

Unable to replace vlan.dat file


Conditions:

When attempting to copy vlan.dat file from disk0: to nvram: the copy is blocked and the console displays the error message "Cannot copy from vlan.dat to vlan.dat"


Workaround:

Downgrade to 12.2(18)SXF7 or upgrade to a release that integrates the fix.

Actions

This Discussion