URGENT - problem with Cisco 876 and ADSL over ISDN

Unanswered Question
May 23rd, 2008

I'm having problems with a Cisco 876 router (ADSL over ISDN Anex B, 1024/256 Kbp/s). I'm try to configure ADSL connection with public IP address from ISP. My configuration is bad, not work's. If you have any good suggestion write to me. I not assured how to configure ATM0, Dialer0, NAT and others interfaces.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
durakovica Fri, 05/23/2008 - 16:12

ISP support LLC, GDMT ADSL (ITU G.992.1/G.992.2) encapsulation, pvc 8/35. ISP have Ericsson DSLAM equipment. If you have same configuration post it!!! I'm so tired and not have solutions for this problems!

Paolo Bevilacqua Sat, 05/24/2008 - 05:16

First of all check "show isdn status" to see if the link goes up.

Then specify if your ISP is using PPPoE, bridged 1483 or what else, and post your configuration.

durakovica Sun, 05/25/2008 - 22:40

This is my config:

Current configuration : 4050 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname xxxx

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

enable secret 5 xxxx

!

no aaa new-model

!

resource policy

!

ip cef

!

!

!

!

no ip domain lookup

ip name-server xxx.xxx.xxx.xxx

ip name-server xxx.xxx.xxx.xxx

!

!

!

!

username xxxx privilege 15 password 7 xxxxxxx

!

!

interface Loopback0

no ip address

!

interface BRI0

no ip address

encapsulation hdlc

shutdown

!

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

description ADSL 1024/256

ip address xxx.xxx.xxx.xxx 255.255.255.0 (Public, static IP from ISP)

ip access-group 100 in

ip nat outside

ip virtual-reassembly

no snmp trap link-status

pvc 8/35

encapsulation aal5snap

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Vlan1

ip address xxx.xxx.xxx.xxx 255.255.255.0 (Private IP)

ip access-group 100 in

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1412

!

ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx (Gateway from ISP)

!

!

no ip http server

ip http authentication local

ip http secure-server

ip nat inside source list 100 interface Vlan1 overload

ip nat inside source static xxx.xxx.xxx.xxx (Private IP) xxx.xxx.xxx.xxx (Public, static IP from ISP)

!

access-list 100 permit ip any any

no cdp run

!

!

!

!

control-plane

!

!

line con 0

no modem enable

line aux 0

access-class 23 in

privilege level 15

login local

transport input telnet ssh

line vty 0 4

login

line vty 5 15

access-class 23 in

privilege level 15

login local

transport input telnet ssh

!

scheduler max-task-time 5000

!

webvpn context Default_context

ssl authenticate verify all

!

no inservice

!

end

durakovica Sun, 05/25/2008 - 23:26

This is status interfaces:

xxxx#sh ip int brief

Interface IP-Address OK? Method Status Protocol

FastEthernet0 unassigned YES unset up up

FastEthernet1 unassigned YES unset up down

FastEthernet2 unassigned YES unset up down

FastEthernet3 unassigned YES unset down down

BRI0 unassigned YES NVRAM administratively down down

BRI0:1 unassigned YES unset administratively down down

BRI0:2 unassigned YES unset administratively down down

ATM0 unassigned YES NVRAM up up

ATM0.1 xxx.xxx.xxx.xxx (Public ISP from ISP) YES NVRAM up up

Vlan1 xxx.xxx.xxx.xxx (Private IP) YES NVRAM up up

Loopback0 unassigned YES NVRAM up up

NVI0 unassigned NO unset up up

Paolo Bevilacqua Mon, 05/26/2008 - 01:25

As mentoned above:

First of all check "show isdn status" to see if the link goes up.

Then specify if your ISP is using PPPoE, bridged 1483 or what else.

Actions

This Discussion