Call transfer problem in CME with ISDN

Unanswered Question
May 25th, 2008

Dear all,

I am running CME 4.1 (124-11.XJ2) with E1 for outgoing calls. I can receive the call successfully to the IP Phone and then when i press transfer and type the another extension number then immediately the first 4 digits of my DDI number is displayed.

Ex: 64201234 (1234 is the extension A) i transfer the call from 1234 to 5678. Once i press 5678 then immediately the display show 6420 instead of dialing to the 5678.

I did configure the transfter-system full-consult and transfer-pattern .T in the telephony service.

When i tried blind transfer then it works fine.

Can someone suggest what went wrong?? is there any debug commands to debug and see this call transfer issue??

Pls advice..

Thanks

Manoj

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
rob.huffman Mon, 05/26/2008 - 05:05

Hi Manoj,

It sounds like if the Blind Transfer works and Transfer System Full-Consult doesn't, the ephones would need to be setup with a Dual Line config;

A dual-line ephone-dn has one virtual voice port and two channels to handle two independent calls. This capacity allows call waiting, call transfer, and conference functions within a single ephone-dn. Dual-line mode is supported on all phone types, but is not appropriate for voice-mail numbers, intercoms, or ephone-dns used for message-waiting indicators, paging, loopback, or hunt groups. Overlays of single-line hunt groups onto dual-line buttons are supported.

Ephone-dns are created in single-line mode if the dual-line keyword is not used. Changing an ephone-dn from dual-line mode to single-line mode (and vice versa) requires that you delete the ephone-dn and then recreate it.

Examples

The following example enters ephone-dn configuration mode to create the ephone-dn 5576:

Router(config)# ephone-dn 1

Router(config-ephone-dn)# number 5576

Router(config-ephone-dn)# exit

The following example creates an ephone-dn with the number 1001 in dual-line mode. The no huntstop command allows calls to continue to hunt to other ephone-dns if this one is busy or does not answer. The huntstop channel command disables call hunting to the second channel of this ephone-dn if the first channel is busy or does not answer.

Router(config)# ephone-dn 10 dual-line

Router(config-ephone-dn)# number 1001

Router(config-ephone-dn)# no huntstop

Router(config-ephone-dn)# huntstop channel

Router(config-ephone-dn)# exit

From this good CME doc;

http://www.cisco.com/en/US/products/sw/voicesw/ps4625/products_command_reference_chapter09186a0080611350.html

Hope this helps!

Rob

netstar-sg-service Mon, 05/26/2008 - 06:50

Hi Rob,

Thanks for your reply. Currently my config is in Dual-line.

When i put the first call on hold and when i press new call then im getting a new tone.After i press the extension number it shows the first 4 digits of the did number.Actually it is not dialing the extension which i want instead it dials the first 4 digit of the DDI number.

I did check my dial-peer whether it clashes with the extension number and there is no clash.

Is there anyway i can debug the call transfer? is there any command? Pls let me know. If you want i can provide the CCME config.

Thanks

Manoj

rob.huffman Mon, 05/26/2008 - 08:43

Hi Manoj,

I know this doesn't answer your question but I'm curious about this line;

"When i put the first call on hold and when i press new call"

This process is not used when doing any kind of Transfer (Blind or Consult) both of these methods are intitiated by Pressing the Transfer Softkey.

Let us know,

Rob

netstar-sg-service Mon, 05/26/2008 - 23:42

Hi Rob,

Thanks for your continous support. What i meant is when i press Transfer i got a new tone after i press the remote extension number i got the 4 digit DDI number.

Kindly help.

Thanks

Manoj

Michael Owuor Sun, 06/01/2008 - 19:22

Manoj,

You sais that when you attempt to perform the transfer, the system dials the first 4 digit of the DDI number: What happens after this? Does is just sit and wait? Do you get reorder or some other tone? How long do you wait before concluding the transfer attempt failed?

If you can provide the current configuration and output of 'debug voip ccapi inout' as well as describe the steps taken while reproducing the output, that may help.

Regards,

Michael.

netstar-sg-service Tue, 06/03/2008 - 00:42

Hi Michael,

Suddenly it is started working fine without making any changes. I dont know is this a bug or some other problem. Let me monitor anyway.

Thanks for ur support

Manoj

Michael Owuor Tue, 06/03/2008 - 04:59

Thanks for the update, Manoj. Glad its working for you now. Good idea to monitor it for a while. Hopefully the problem goes away for good.

Have a good day!

Michael.

Actions

This Discussion