FXS with a fax connected

Unanswered Question
May 26th, 2008
User Badges:

Hi all,


I have a FAX connected on a FXS port in a UC520.

The FAX works for some time and for some reason it stops receiving calls, for now the workaround is to make a call from the fax to other phone and this seems to "unblock" the port.


Regards,


Rui

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.5 (2 ratings)
Loading.
paolo bevilacqua Mon, 05/26/2008 - 04:58
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Are you using IDSN lines ? And which exact IOS are you using ?

rcordeiro Mon, 05/26/2008 - 06:19
User Badges:

Hi,


There's a E1 connected to the UC520, the call comes in from the E1 and should always go to the FAX if it ends in 99.

Right now I don't have access to the machine and don't know the IOS, but this is a new machine installed 15 days ago, so it should be a recent version.

I check that later.


Thanks,


Rui

paolo bevilacqua Mon, 05/26/2008 - 06:26
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Some problem can be caused by missing "network-clock-participate" and "network-clock-select" for the E1 interface.


Then you need to check with "debug isdn q931" "debug vpm signal" and "term mon" why the FXS interface does not get disconnected.

rcordeiro Mon, 05/26/2008 - 06:58
User Badges:

Thanks for your help but I think it's not a problem of not getting disconnect. The call is disconnected correctly but if we receive a fax at 17:00 and there is no more calls until 9:00 AM if someone tries to send a fax from the outside it rings but the call never reaches the FAX machine, it rings because it's analog and then it disconnects for timeout.


I don't know if I'm making myself understood...


Regards,


Rui

paolo bevilacqua Mon, 05/26/2008 - 07:09
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Do "show dialplan pattern number XXX" where XXX is the fax number. You might have overlapping entries.

rcordeiro Mon, 05/26/2008 - 07:22
User Badges:

I only have one fax number.


The strange thing is it works if you make a call from the fax to another extension after the extension disconnect the call you can make the call from outside to the fax number.

It seems if the FXS port doesn't get calls for some time the port becomes down to incoming calls but it work just fine for outgoing calls.


Regards,


Rui

paolo bevilacqua Mon, 05/26/2008 - 07:26
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Sometime by mistake you end up having multiple DPs for a same number. The command I suggested before check for that.

Else you have to take debug isdn q931 and debug vpm signal as i suggested before.

rcordeiro Mon, 05/26/2008 - 08:04
User Badges:

Tomorrow morning (I'm in southern europe) I'll be there to check the debugs and the IOS version. I already have the latest version with me to change it, if necessary.


I'll give some more feedback tomorrow.


Thanks for your help.


Regards,


Rui

rcordeiro Tue, 05/27/2008 - 01:55
User Badges:

Hi,


Doing a "debug voice application stcapp port 0/0/0" (the fax) gives this:


May 27 09:49:02.451: 0/0/0: ==> Received event:STCAPP_DC_EV_DEVICE_CALL_STATE_RINGIN

May 27 09:49:02.451: 0/0/0: Call State:IDLE

May 27 09:49:02.451: 0/0/0: stcapp_cs_ringin_eh

May 27 09:49:02.451: 0/0/0: call_ref=7151, line=1

May 27 09:49:02.451: 0/0/0: stcapp_get_ccb_ptr

May 27 09:49:02.451: 0/0/0: stcapp_get_ccb

May 27 09:49:02.451: 0/0/0: dcb->lcb[line_inst - 1].num_ccbs=0

May 27 09:49:02.451: 0/0/0: Acquired CCB 0x85684B7C for device id:5

May 27 09:49:02.451: 0/0/0: num_ccbs++, num_ccbs=1

May 27 09:49:02.451: 0/0/0: New State = RINGIN

May 27 09:49:02.451: 0/0/0: ==> Received event:STCAPP_DC_EV_DEVICE_CALL_INFO

May 27 09:49:02.451: 0/0/0: Call State:RINGIN

May 27 09:49:02.451: 0/0/0: stcapp_call_info_eh

May 27 09:49:02.451: 0/0/0: call_ref=7151

May 27 09:49:02.451: 0/0/0: stcapp_get_ccb_ptr

May 27 09:49:02.451: 0/0/0: stcapp_set_up_voice_leg

May 27 09:49:02.451: 0/0/0: stcapp_get_ccb_ptr

May 27 09:49:02.451: 0/0/0: Disc pending... can't setup call yet

May 27 09:49:02.451: 0/0/0: No state change

May 27 09:49:02.455: 0/0/0: ==> Received event:STCAPP_DC_EV_DEVICE_DISPLAY_PROMPT_STATUS

May 27 09:49:02.459: 0/0/0: Device State:IS

May 27 09:49:02.459: 0/0/0: stcapp_display_prompt_status_eh

May 27 09:49:02.459: 0/0/0: lineNumber: 1

May 27 09:49:02.459: 0/0/0: call reference: 7151

May 27 09:49:02.459: 0/0/0: promptStatus: 'From 919964854'

May 27 09:49:02.459: 0/0/0: No state change

May 27 09:49:02.459: 0/0/0: ==> Received event:STCAPP_DC_EV_DEVICE_SET_RINGER

May 27 09:49:02.459: 0/0/0: Call State:RINGIN

May 27 09:49:02.459: 0/0/0: stcapp_set_ringer_eh

May 27 09:49:02.459: 0/0/0: Call reference is 7151

May 27 09:49:02.459: 0/0/0: stcapp_get_ccb_ptr

May 27 09:49:02.459: 0/0/0: saving ring mode=3 because disconnect is pending

May 27 09:49:02.459: 0/0/0: No state change

May 27 09:49:02.463: 0/0/0: ==> Received event:STCAPP_DC_EV_DEVICE_CALL_INFO

May 27 09:49:02.463: 0/0/0: Call State:RINGIN

May 27 09:49:02.463: 0/0/0: stcapp_call_info_eh

May 27 09:49:02.463: 0/0/0: call_ref=7151

May 27 09:49:02.463: 0/0/0: stcapp_get_ccb_ptr

May 27 09:49:02.463: 0/0/0: stcapp_set_up_voice_leg

May 27 09:49:02.463: 0/0/0: stcapp_get_ccb_ptr

May 27 09:49:02.463: 0/0/0: Disc pending... can't setup call yet

May 27 09:49:02.463: 0/0/0: No state change

May 27 09:49:49.707: 0/0/0: stcapp_get_dcb_and_lcb

May 27 09:49:49.707: 0/0/0: stcapp_screen_api_event

May 27 09:49:49.707: 0/0/0: event:STCAPP_DC_EV_DEVICE_CALL_STATE_ONHOOK received.

May 27 09:49:49.707: 0/0/0: ==> Received event:STCAPP_DC_EV_DEVICE_CALL_STATE_ONHOOK

May 27 09:49:49.707: 0/0/0: Call State:RINGIN

May 27 09:49:49.707: 0/0/0: stcapp_cs_onhook_ringin_eh

May 27 09:49:49.707: 0/0/0: Call reference is 7151

May 27 09:49:49.707: 0/0/0: stcapp_get_ccb_ptr

May 27 09:49:49.707: 0/0/0: stcapp_cs_onhook_ringin_eh:ERROR:ccCallFeature api failed

May 27 09:49:49.707: 0/0/0: stcapp_free_ccb

May 27 09:49:49.707: 0/0/0: ccb->dcb/ccb->lcb=0x8730BDD0/0x842FB200

May 27 09:49:49.707: 0/0/0: Freed CCB 0x85684B7C

May 27 09:49:49.707: 0/0/0: Reset the overlay mode of this phone!

May 27 09:49:49.707: 0/0/0: Reset the setup_pending of this phone!

May 27 09:49:49.707: 0/0/0: !!!! dcb->lcb->num_ccbs-- !!!!!

May 27 09:49:49.707: 0/0/0: num_ccbs=0

May 27 09:49:49.707: 0/0/0: New State = IDLE

May 27 09:49:49.711: 0/0/0: ==> Received event:STCAPP_DC_EV_DEVICE_CALL_INFO

May 27 09:49:49.711: 0/0/0: Call State:IDLE

May 27 09:49:49.711: 0/0/0: Uninteresting event

May 27 09:49:49.711: 0/0/0: ==> Received event:STCAPP_DC_EV_DEVICE_SET_RINGER

May 27 09:49:49.711: 0/0/0: Call State:IDLE

May 27 09:49:49.711: 0/0/0: Uninteresting event

May 27 09:49:49.711: 0/0/0: ==> Received event:STCAPP_DC_EV_DEVICE_STOP_TONE


It rings on the port but it does not change the port state...


Regards,


Rui

paolo bevilacqua Tue, 05/27/2008 - 02:05
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Fax might have problems, try with regular phone.

rcordeiro Tue, 05/27/2008 - 02:13
User Badges:

But the problem is I don't have a normal phone.

But if I make a call from the fax to any number it will start to receive calls...

Strange behaviour.


Any ideas of what I can try?


Regards,


Rui

paolo bevilacqua Tue, 05/27/2008 - 04:28
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

What I'm suggesting, is that you test with a normal phone to verify that it is ringing on each call and you can answer and talk normally, even if you don't place outgoing calls before receiving.


The trace shows that UC500 is ringing the FXS port but if the device doesn't answer there isn't anything UC500 can do about that.




rcordeiro Wed, 05/28/2008 - 03:11
User Badges:

Hi,


For now I just used a workaround to detect when the fax doesn't answer.

It forwards the call to a IP phone if the fax doesn't answer in 30 seconds (it normally answers the calls in 5 to 10 seconds).


I also did some changes as seen in some posts (changed the type to ATA and voice service pots with some commands).


Many thanks for your help.


Rui

etmarcof Thu, 09/04/2008 - 10:26
User Badges:

Hi Rui,


I have a similar problem.

Did you solve your problem?

What commands you use in your workaround?


Thks

Best Regards

MC


rcordeiro Fri, 09/05/2008 - 03:28
User Badges:

Hi,


Like I said in my last post I just used that workaround.

My configs, regarding the fax port are:

voice-port 0/0/0

ring frequency 50

disconnect-ack

compand-type a-law

cptone PT

timeouts call-disconnect 10

timeouts ringing infinity

dial-peer voice 1 pots

service stcapp

fax rate disable

port 0/0/0



Hope you solve your problem. If you manage to get a different solution post it.


Regards,


Rui

aciscolook Tue, 09/30/2008 - 15:27
User Badges:

I thought this stuff is supposed to be plug and play?


I having intermittent issues with the fax on fxs...wish I knew more about the stcapp configurations going on in the background.

Actions

This Discussion