VTPv2 Transparent Mode - Not forwarding VTP packets in different Domain

Unanswered Question

Hi All,


I'm doing some testing in the Lab and have 3 x 3750's daisy chained together running VTP, with 802.1q trunks hardcoded.


SW1 <--> SW2 <--> SW3


SW1 and SW3 are in VTPv1 domain A and are both in 'Server Mode'. However, SW2 is in VTPv2 domain B and in Transparent mode.


According to the Cisco Doc VTP Version 2 (SW2) supports only one domain, and it forwards VTP messages in transparent mode without inspecting the version and domain name.


However, I am not seeing this happen. When I increment the revision number on SW1, I am not seeing the VTP updates propagate to SW3, and vice-versa.


Has anyone experienced this behavior? Any suggestions?


Thanks in advanced.


Mario.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mahmoodmkl Mon, 05/26/2008 - 20:53
User Badges:
  • Gold, 750 points or more

Hi


Unfortunately this not going to happen,u need to have the transparent switch in the same domain then it will forward the VTP messages.


Thanks

Mahmood

bvsnarayana03 Mon, 05/26/2008 - 22:02
User Badges:
  • Silver, 250 points or more

Yes it does support but only in VTP v2. Check the version of VTP you are running.


Check "VTP version2 mode" in "sh vtp status".

Hi bvsnarayana03,


Thanks for the information.


However, I still have the issue. SW2 has VTPv2 mode enabled as per 'show vtp status'. When I change the VTP domain on SW2 to A (same as SW1 and SW3), and then increase the revision number on SW1, I immediately see VTP messages propagate to SW3. I am not seeing this behavior though when SW2 is in a different domain.


As for the link you referred me too... very interesting... Unless this issue is hardware/software depended? I tried the same setup with 3560's and still get the same result.


When I get access to the lab next week, I will span the trunk port from SW2 --> SW3 and see if VTP messages are being passed on. I'll let you know how that goes.


Thanks for your help.


Regards,


Mario.

Actions

This Discussion