Floating Static on 3750

Unanswered Question
May 27th, 2008
User Badges:

I have a 3750 with a static route and a floating static route. When the port connected to the next hop of the static is down my floating route is not inserted into the routeing table. Is there a trigger I'm missing?

Thanks,

Andy

router eigrp 100

network 10.31.103.0 0.0.0.255

network 192.168.100.0

network 192.168.103.0

network 192.168.110.0 0.0.0.3

network 192.168.110.4 0.0.0.3

no auto-summary

variance 2

redistribute static

!

ip default-gateway 192.168.103.6

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.103.6

ip route 172.16.189.0 255.255.255.0 192.168.103.6

ip route 192.168.60.0 255.255.255.0 192.168.103.6

ip route 192.168.101.96 255.255.255.224 192.168.103.6

ip route 206.220.236.0 255.255.255.0 192.168.100.34

ip route 206.220.236.0 255.255.255.0 192.168.110.6 190

ip route 206.220.237.0 255.255.255.0 192.168.100.34

ip route 206.220.237.0 255.255.255.0 192.168.110.6 190

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Burts Tue, 05/27/2008 - 07:26
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Andy


Looking at what you have posted I see 2 floating static routes which both involve the same primary and floating interfaces:

ip route 206.220.236.0 255.255.255.0 192.168.100.34

ip route 206.220.236.0 255.255.255.0 192.168.110.6 190

ip route 206.220.237.0 255.255.255.0 192.168.100.34

ip route 206.220.237.0 255.255.255.0 192.168.110.6 190


My first question would be to verify that the floating static is valid, especially to verify that 192.168.110.6 is a valid next hop address (is there an entry in the routing table that shows how to get there?).


My next question is: in describing the problem you say:

"When the port connected to the next hop of the static is down..."

but I wonder if the port is really down. It is a common experience with routing over Ethernet interfaces that you can lose connectivity and the neighbor on that interface is not reachable but the interface is still up. The trigger for the floating static route would be for the primary interface to go protocol down. If you think that it does go down then please post the output of show ip route and the output of show ip interface brief.


If the issue does turn out to be that the Ethernet interface is not going protocol down Cisco has introduced a feature which addresses this. It is frequently referred to as Reliable Static Routing Using Object Tracking. This link has some information which would get you started with this:

http://www.cisco.com/en/US/docs/ios/12_3/12_3x/12_3xe/feature/guide/dbackupx.html


HTH


Rick

thotsaphon Tue, 05/27/2008 - 07:34
User Badges:
  • Gold, 750 points or more

Hi Andy,

Could you explain a bit more about your question? R1(Float-static to R2)<---->R2

What is the media between R1 and R2? Lan?


You meant that the R1 interface is down

- In this case the static route will not be installed into the routing table because the outgoing interface was down!


You meant that the R2 interface(Next-Hop) is down

- The static route should be installed as long as the R1 interface is still up(Should be lan media between them)



HTH

Thot

averheaghe Tue, 05/27/2008 - 08:57
User Badges:

Here is the show ip route and the status of the interface.

Gateway of last resort is 192.168.103.6 to network 0.0.0.0


S 206.220.236.0/24 [1/0] via 192.168.100.34

S 206.220.237.0/24 [1/0] via 192.168.100.34

S 192.168.60.0/24 [1/0] via 192.168.103.6

192.168.110.0/30 is subnetted, 2 subnets

C 192.168.110.4 is directly connected, GigabitEthernet1/0/24

C 192.168.110.0 is directly connected, GigabitEthernet1/0/23

204.180.114.0/30 is subnetted, 1 subnets

D EX 204.180.114.196

[170/2179072] via 192.168.110.6, 1d05h, GigabitEthernet1/0/24

[170/2181376] via 192.168.110.2, 1d05h, GigabitEthernet1/0/23

204.181.190.0/32 is subnetted, 1 subnets

D EX 204.181.190.186

[170/2179072] via 192.168.110.6, 1d05h, GigabitEthernet1/0/24



GigabitEthernet1/0/12 is down, line protocol is down (notconnect)

Hardware is Gigabit Ethernet, address is 001c.582a.f08c (bia 001c.582a.f08c)

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Auto-duplex, Auto-speed, media type is 10/100/1000BaseTX

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output 00:01:01, output hang never

Last clearing of "show interface" counters 22w5d

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

2042779 packets input, 709627144 bytes, 0 no buffer

Received 14810 broadcasts (0 multicasts)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 0 multicast, 0 pause input

0 input packets with dribble condition detected

26251806 packets output, 2503570326 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out


In my case we are assuming the next hop device is down (R2)


Richard Burts Tue, 05/27/2008 - 09:21
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Andy


Thanks for the additional information. But I am a bit puzzled by what I see in it. I see the primary static routes:

S 206.220.236.0/24 [1/0] via 192.168.100.34

S 206.220.237.0/24 [1/0] via 192.168.100.34

but I do not see anything that shows the next hop of 192.168.100.34. I am not sure whether to assume that you posted a somewhat imcomplete output of show ip route or that something quite unusual is going on.


I do not have enough context about interface GigabitEthernet1/0/12 to recognize the significance of it being down. Perhaps if you give us some more information about the topology and the environment we might understand it better and find better answers.


HTH


Rick

averheaghe Tue, 05/27/2008 - 10:02
User Badges:

Sorry Rick, the routing table does include a route to the next hop of 192.168.100.34.

I was able to get the Relaible Static Route to work on our 2800, but not on our 3750- I need to dig a little deeper on it.

This seems to be the way to go if I can get it to work on the 3750



Richard Burts Tue, 05/27/2008 - 10:25
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Andy


Thanks for clarifying this. As long as the 192.168.100.34 is still in the routing table then the floating static will not be inserted into the routing table. This seems to substantiate my theory that the static route is not removed when you lose connectivity to the neighbor. Object tracking would seem to be the best alternative. I hope you get it working. Please keep us updated with the status of this.


HTH


Rick

Actions

This Discussion