cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3267
Views
11
Helpful
7
Replies

PPPoE on 831. Help!

holocrono
Level 1
Level 1

Hi all.

I have a DSL bridge connected to the WAN port of a Cisco 831. For whatever reason, the 831 does not negotiate PPPoE. When I connect a simple Linksys router to the bridge, it works fine.

debug pppoe events on the 831 shows the following repeating loop:

Mar 31 : Sending PADI: Interface = Ethernet1

Mar 31 : padi timer expired

Mar 31 : Sending PADI: Interface = Ethernet1

Please check this out and let me know if I missed some configuration.

---------------------------------

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Cisco831

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

!

no aaa new-model

no ip dhcp use vrf connected

ip dhcp excluded-address 10.10.10.1

!

ip dhcp pool sdm-pool

import all

network 10.10.10.0 255.255.255.248

default-router 10.10.10.1

lease 0 2

!

!

ip cef

ip domain name yourdomain.com

vpdn enable

!

vpdn-group 1

request-dialin

protocol l2tp

domain global

!

!

username xxxxxxxx privilege 15 secret xxxxxxxx

!

!

!

!

bba-group pppoe global

virtual-template 1

!

!

interface Ethernet0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-Ethernet 10/100$

ip address 10.10.10.1 255.255.255.248

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1412

!

interface Ethernet1

description $ETH-WAN$

no ip address

ip mtu 1492

ip nat outside

ip virtual-reassembly

duplex auto

pppoe enable group global

pppoe-client dial-pool-number 1

!

interface Ethernet2

no ip address

shutdown

!

interface FastEthernet1

duplex auto

speed auto

!

interface FastEthernet2

duplex auto

speed auto

!

interface FastEthernet3

duplex auto

speed auto

!

interface FastEthernet4

duplex auto

speed auto

!

interface Dialer0

ip address negotiated

ip mtu 1452

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname xxxxxxxx

ppp chap password xxxxxxxx

ppp pap sent-username xxxxxxxx password xxxxxxxx

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip nat inside source list 1 interface Dialer0 overload

!

access-list 1 permit 10.10.10.0 0.0.0.7

dialer-list 1 protocol ip permit

!

line con 0

login local

no modem enable

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet ssh

!

scheduler max-task-time 5000

end

1 Accepted Solution

Accepted Solutions

Hi,

Any luck determining the cause ? I have found in the past that after adding SSH access to a PPPoE config the unit fails to pass the PAP/CHAP authentication on the Dialer interface. I have yet to determine the breakdown

Regards,

Merlin

View solution in original post

7 Replies 7

holocrono
Level 1
Level 1

Question: Do I *have* to explicitly specify a MAC address on that interface?

The sh pppoe sessions is showing a MAC of all 0's.

If a PPPoE session has not been established, then the MAc address will show as all zeroes.

PPP negotiation only starts when there is a PPPoE session, so by the sounds of it the dialer won't have negotiated an IP address at this stage.

Are you still getting PADI timer expired debug messages? PADI is the first step of the discovery process -

1. PPPoE Active Discovery Initiation (PADI) packet

2. PPPoE Active Discovery Offer (PADO) packet

3. PPPoE Active Discovery Request (PADR) packet

4. PPPoE Active Discovery Session-confirmation (PADS) packet

5. PPPoE Active Discovery Terminate (PADT) packet

So if step one fails your PADI frames are not getting to the ISP or the ISP is not responding to this particular router.

Do you get anything helpful from any of the other PPPoE debugs?

#debug pppoe ?

data PPPoE data packets

elog PPPoE elogs

errors PPPoE protocol errors

events PPPoE protocol events

packets PPPoE control packets

There is a Cisco PPPoE troubleshooting page here:

http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a008071a7c2.shtml

However, after glancing at it, it seems to deal more with using an ATM interface as opposed to a fastethernet interface for the WAN connection.

bamboo
Level 1
Level 1

Did the dialer get a IP address?

also you miss the default route

add

ip route 0.0.0.0 0.0.0.0 dialer0

Hi,

Any luck determining the cause ? I have found in the past that after adding SSH access to a PPPoE config the unit fails to pass the PAP/CHAP authentication on the Dialer interface. I have yet to determine the breakdown

Regards,

Merlin

holocrono
Level 1
Level 1

Sorry for the delay in testing these suggestions. I've been fairly busy ;)

Anyways, I removed the SSH from the vty, just to eliminate that possible issue.

I also added ip route 0.0.0.0 0.0.0.0 dialer0.

The dialer0 interface never receives an IP address.

I've also turned on the debug for the dialer evens in addition to the pppoe events. This is the debug output that I'm getting now:

*Mar 31 01:33:23.271: PPPoE 6130: I PADT R:0090.1a40.c9b5 L:0016.c73e.352b Et1

*Mar 31 01:33:23.271: PPPoE : Shutting down client session

*Mar 31 01:33:23.271: [0]PPPoE 6130: O PADT R:0090.1a40.c9b5 L:0016.c73e.352b Et1

*Mar 31 01:33:23.271: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di0

*Mar 31 01:33:23.275: Vi2 DDR: disconnecting call

*Mar 31 01:33:23.275: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down

*Mar 31 01:33:24.255: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to down

*Mar 31 01:33:31.507: Di0 DDR: Cannot place call, no dialer string set

*Mar 31 01:33:34.991: Di0 DDR: Cannot place call, no dialer string set

*Mar 31 01:33:38.991: Di0 DDR: Cannot place call, no dialer string set

*Mar 31 01:33:43.395: Sending PADI: Interface = Ethernet1

*Mar 31 01:33:43.411: PPPoE 0: I PADO R:0090.1a40.c9b5 L:0016.c73e.352b Et1

*Mar 31 01:33:45.475: PPPOE: we've got our pado and the pado timer went off

*Mar 31 01:33:45.475: OUT PADR from PPPoE Session

*Mar 31 01:33:45.487: PPPoE 6152: I PADS R:0090.1a40.c9b5 L:0016.c73e.352b Et1

*Mar 31 01:33:45.491: IN PADS from PPPoE Session

*Mar 31 01:33:45.495: %DIALER-6-BIND: Interface Vi2 bound to profile Di0

*Mar 31 01:33:45.495: PPPoE: Virtual Access interface obtained.

*Mar 31 01:33:45.495: PPPoE : encap string prepared

*Mar 31 01:33:45.495: [0]PPPoE 6152: data path set to Virtual Acess

*Mar 31 01:33:45.499: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up

*Mar 31 01:33:45.499: Vi2 DDR: Dialer statechange to up

*Mar 31 01:33:49.015: Vi2 DDR: dialer protocol up

*Mar 31 01:33:49.971: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to up

To my unexperienced eye, it looks like I'm getting PADI and PADO functioning. I'm not sure where the Vi2 interface comes into the picture, I never configured it... Anybody got a suggestion?

PPPoE is OK. Now undeb that and take debug ppp auth, debug ppp neg.

holocrono
Level 1
Level 1

Thanks for all the help everyone.

After viewing the ppp auth debug I realized that my IP address is not assigned via DHCP but rather it should have been set to ppp negotiated.

Problem solved! Thanks again.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Innovations in Cisco Full Stack Observability - A new webinar from Cisco