diable stp on individual ports catos

Unanswered Question
May 28th, 2008

I tried to enable etherchannel on a catalyst 4506 with catos using


http://www.cisco.com/en/US/tech/tk389/tk213/technologies_configuration_example09186a008014edfa.shtml


but the NIC cards require that STP be disabled and I am unable to find any information about disabling individual port. I'm using ports 5/21 and 5/22


also when I tried

set vlan 1 5/21-22

it didn't create the vlan; it showed me an output like


2/1-48

3/1-48

4/1-48

5/1-48


I'm trying to team the nics, so I need to setup etherchannel; does anyone has any ideas what I have to do?


thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Wed, 05/28/2008 - 14:23

Cedric


By default all ports are in vlan 1 so you don't need to set them into vlan 1. The reason you get that output is the switch telling you that all ports are in vlan 1.


I'm not sure you can disable STP on a per port basis. You can use portfast to make the port go straight into forwarding mode but if you want to disable it i seem to remember you can only do it by vlan. You absolutely don't want to disable STP on vlan 1 so you could create a new vlan just for the server and disable STP there but i think portfast may be what you are looking for.


Jon

michael.leblanc Wed, 05/28/2008 - 18:51

On an IOS based switch (e.g.: 2950T), STP is disabled on an access port when the " spanning-tree portfast" command is issued in interface-config mode.


I verified this with Wireshark the other day.


I presume the same result would be achieved on a CatOS device.



cedric.spence Thu, 05/29/2008 - 04:11

I went ahead and configured the switch with

set vlan 2 5/21-22


set spantree portfast 5/21-22 enable


and know the nics will not communicate with the switch


also I when I tried

set port channel all distribution mac source

and I got a message stating "Feature not supported"


I change the ports back to the default vlan of 1 and disabled portfast and know the server is communicating the switch.



any ideas what I'm missing


Thanks






glen.grant Thu, 05/29/2008 - 04:47

I don't believe STP is shutoff when you use portfast . It just eliminates a couple of the spanning tree transition states and goes directly to forwarding , STP still is running on the port.

cedric.spence Thu, 05/29/2008 - 04:59

I think that is the case as well because the intel nic card have a tool and it states that stp is still enabled. I guess I have to figure out how to add the ports to a separate VLAN but still enable then to communicate with the rest of the network ports. Then I believe I can disable STP via the VLAN.


when I use "set vlan 2 5/21-22"

I get a message "vlan 2 not active"

rafaelgarcia Thu, 05/29/2008 - 05:30

Hi,

In order for you to disable STP on a per-port basis you should use the BPDU filtering command on each port.


switch(config-if)#spanning-tree bpdufilter


When you use portfast on a port STP is not disable completely, it can still listen to BPDUs if another device is connected to that port. What porfast does is that do not allow STP to send any TCN(topology notification change) BPDUs to the Root Bridge when the host connected at that port (end user PC) is turned off or on.


Let me know if it helps.

cedric.spence Thu, 05/29/2008 - 05:36

OK so I figure out how to setup the vlan in catos using


set vlan 2 5/21-22 state active


but I get the following message


VTP advertisements transmitting temporarily stopped,

and will resume after the command finishes.

Cannot add/modify VLANs on a VTP server without a domain name.


it looks like I have to use the following command


set vtp domain


will this affect my default vlan 1 in anyway.

I don't want to cause more issue setting this up.



jason.henderson Thu, 05/29/2008 - 05:46

You can enable bpdufilter on a per-port basis - see link below for explanation of the command.


http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.1E/native/configuration/guide/stp_enha.html#wp1033403


The command in catos to configure would be -


set spantree portfast bpdu-filter mod/port [enable | disable | default]


But you need to watch out for L2 loops if you've got it enabled.


Hope this helps,

Jason.


cedric.spence Thu, 05/29/2008 - 06:23

OK

I used


set spantree portfast bpdu-filter mod/port [enable | disable | default]


solved the issue with STP


I'm using qcheck a tool to check throughput and I'm getting a max on 600Mbps checking from a 1gig client pc with the server that has two 1gig nics teamed.


what can be causing low throughput like that. When I test the other server I get around 1gig throughput



cedric.spence Thu, 05/29/2008 - 07:19

OK here is the current setup I have on the switch side


#module 5 : 48-port 10/100/1000 Ethernet

set trunk 5/21 off dot1q 1-1005,1025-4094

set trunk 5/22 off dot1q 1-1005,1025-4094

set spantree portfast 5/21-22 disable

set spantree bpdu-filter 5/21-22 disable

set port channel 5/21-22 mode on


Let me know if you would like more information

Actions

This Discussion