Unanswered Question
Jun 1st, 2008

Pls help me id why this link is not coming up at all between our two offices. I have attached here the configs of both sites. It's displaying up,up with spoofing in brackets on both ends? What does this mean? I have no clue in ISDN.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
lamav Sun, 06/01/2008 - 06:24

You're not binding the physical interface to the dialers. How is the physical interface supposed to know that it's supposed to be working in conjunction with the dialers?

You must configure the physical interface to participate in a dialer pool. Configure

dialer pool-member 1

under the physical interface.



pcameron Sun, 06/01/2008 - 15:46

You need to add the following commands under the BRI interfaces on both sides to bind the dial interface to the physical BRI ports -

dialer pool-member 1

encapsulation ppp

ppp authentication chap

You will also need to add username and passwords on both sides, similar to this :

username SiteA_1841 password 0 cisco123

and for the other site -

username SiteB_1841 password 0 cisco123

Refer here for more details -

bericaleb Sun, 06/01/2008 - 16:34


Where do I add the username SiteA_1841 password 0 cisco 123? Do I add on the SiteA router or the SiteB router?

Wilson Samuel Mon, 06/02/2008 - 05:51


Please find the points below, which may be helpful for your query:

1. CHAP needs a shared password and unique usernames

2. Usernames are generally hostnames

3. One should give the username of the opposite ends ie you may add SiteA_1841 at the SiteB router and vice versa.

If it doesnt work, you may try reversing the order (uff.. its been a while I have workd on ISDN-BRI)


Kind Regards,

Wilson Samuel

Pravin Phadte Mon, 06/02/2008 - 08:12

It means you need to try the below config.

for site A

confifg t

username SiteA_1841 password 0 cisco123

interface BRI0/1/0

dialer pool-member 1

encapsulation ppp

ppp authentication chap

for site B

config t

username SiteB_1841 password 0 cisco123

interface BRI0/1/0

dialer pool-member 1

encapsulation ppp

ppp authentication chap

If this does not work keep ready show isdn status and debug isdn q931 and 921 output ready for both the routers.

bericaleb Mon, 06/02/2008 - 15:15


I've done all these configs specified above. I tested last night but it doesn't seem to do anything. I did a shut on the Primary Serial link and was hoping to see something on the ISDN link to pickup. Nothing seem to happen.

Anyways, I will do a show isdn status and a debug q931 and 921 and forward the output.

Thanks for you help so far.

bericaleb Tue, 06/03/2008 - 00:24

I turned on the debugs you requested, but I there was no message logged.

the show isdn status is attached.

Please identify what sort of configs I should have on the dialer 1 interfaces

the show int of these interfaces (bri, dialer ) are showing up and up with spoofing in brackets.

what am I still missing? pls help me.

Pravin Phadte Tue, 06/03/2008 - 03:33

Hi bericaleb,

I have still not gone through the configs perfectly. Depending on the show isdn status you have attached for the site A i notice a error in layer 2.

Layer 2 Status:

TEI = 255, Ces = 1, SAPI = 0, State = ESTABLISH_AWAITING_TEI

State = ESTABLISH_AWAITING_TEI is not what should be there.

Do you get the same error on the other side of the router ?

let me explain about the error.

TEI is terminal end point identifier, it is a number given to the router by

the switch at the exchange. 255 means that the exchange has not sent this

number to the router and hence layer 2's state is ESTABLISH_AWAITING_TEI -

ie it is awaiting the reception of a TEI from the switch.

Once the TEI is recieved the TEI value will change and the state will become



You can confirm whether the router is receiving a TEI from the switch by

doing the following:

debug isdn q921

term mon

Correct output will look like this:

*Sep 13 15:48:26: ISDN BR0/0: TX -> RRp sapi = 0 tei = 64 nr = 0

*Sep 13 15:48:26: ISDN BR0/0: RX <- RRp sapi = 0 tei = 64 nr = 0

TX is the router sending a message to the ISDN switch requesting a TEI, the

RX is the ISDN switch replying with a TEI.

If the ISDN line is not working properly you will not get the RX's, only the

TX's. If you don't see anything close your ISDN interface and open it again

(NB: this is often enough to bring the layer 2 up as it restarts the

conversation with the switch). If shut / no shuting the interface doesn't

work, try calling the ISDN number from a standard voice phone - sometimes

the lines "go to sleep" and this can be enough to wake them up. If this

does not resolve it, get back to your service provider.

clear interface BRI0/1/0 can be used.

the below link would expain a bit more on the error.

Please let me know if this helps.

bericaleb Tue, 06/03/2008 - 23:24

Thanks for the extremley helpful info provided above. I've rated this with a 5.

I called the BRI numbers and boths numbers on both end gave me an engaged tone. I inputed debug but I dont seem to get any out from these debugs on the console.

I have attached the show isdn status for both sites.

Pravin Phadte Wed, 06/04/2008 - 01:18


The site B does not have any problems as per the show isdn status.

The config which has been pasted for site A has a command.

no logging monitor

Please change this to.

config t

logging monitor

logging console

Logging console since you are trying the debug from the console as u said above.

I feel that this should get the outputs for isdn.

1] Shut the pri serial link.

2] show dialer map

3] Ping the dialer-map ip.

4] debug isdn q921

Need this outputs to comment more on this.

5] debug isdn q931

Still these i would suggest you to check with the telco provider for the site A on this.

Let us know.



bericaleb Fri, 06/06/2008 - 18:02


1. shut

the serial interface

2. show dialer map = result is no output display

3. ping the dialer-map ip = result is timed out.

4. debug isdn q921 & 931 = no output.


This Discussion