SRST under Voicemail not working using T1 PRI

Unanswered Question
Jun 2nd, 2008

Currently we are running CallManager 4.1(3)sr3 along with Unity 4.04.

We currently are using MGCP to control all of our gateways from a

centralized cluster and utilize SRST at remote sites for failover. I

was wondering if anyone has been successful, while in SRST mode, of

redirecting an inbound call after a set amount of rings to their

voicemail server, and have the subscribers message play rather than the

main Unity greeting. We are using ISDN PRI at our remote sites. I know

that there were some commands that you could configure to send digits to

the Unity server, but from what I understand those were only supported

in a analog configuration.

Below is a excerpt of my call-manager fallback config:

call-manager-fallback

voicemail 91517xxxxxxx

call-forward busy 91517xxxxxxx

call-forward noan 9517xxxxxxx timeout 12

Any help would be greatly appreciated.

John

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Michael Owuor Mon, 06/02/2008 - 10:21

Hello John,

Your call-forward noan is set to 9517xxxxxxx. Is that correct, or should it be 91517xxxxxxx like the voicemail setting as well as the call-forward busy?

Debug isdn q91 may be useful to help pin-point why your tests are failing.

Regards,

Michael.

Chris Deren Mon, 06/02/2008 - 11:58

You need to ensure that RDNIS is suppored on your carrier, then you need to ensure that GW at the head end site is configured to inspect RDNIS by checking the "Redirecting Number IE Delivery - Inbound" field. If you are not using 10 digit dial plan, you need to configure your subscribers with a matching 10 digit alternate extension as well.

Your debug isdn q931 on both sides will indicate if RDNIS is sent and received.

HTH,

Chris

John Tan Wed, 06/04/2008 - 13:19

Is there any workaround if RDNIS is not working on the PRI? What are some of the workarounds that I have if RDNIS is not a option? Any suggestion would be appreciated.

thanks

john

danny.howard Thu, 06/05/2008 - 13:23

Try putting this command under the PRI interface.

!

interface Serial1/0:23

isdn outgoing ie redirecting-number

Actions

This Discussion