ASA rdp plugin through a proxy?

Unanswered Question
Jun 3rd, 2008

Yesterday I found that when I'm behind a web proxy I can't start rdp sessions with the plugin. A packet capture on my client workstation showed that the SSL/RDP connection was trying to connect direct. All other parts of the webvpn session were working fine via the proxy. This was on IE7.

Has anyone successfully used the rdp plugin through a web proxy?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)

Why is this still a problem?

RDP plugin - java or the active x features does not work through proxy!

Running plugin: rdp-plugin.090915.jar with Cisco ASA 5505 with version 8.2(1).

Question, in java control panel you can configure the proxy settings just as you do in IE / Firefox, but this still doesn't work! Is it required to have Proxy socks support to get this working through a proxy server?

I prefered not to use Anyconnect or Smart tunnels as that required software install. RDP - Java works fine (as long as you are not behind a proxy server).



ffischer Wed, 12/15/2010 - 09:09


using RDP plugin dated 15. Sep 2009.

I can only confirm that connecting to RDP through a proxy is still not working here...

Neither the Java nor the Active-X

Java console shows connection attempts with PROXY=direct.

Is there an enhancement request pending ?

Any other news or workarounds ?



This Discussion