T1 Point to point issue

Unanswered Question
Jun 3rd, 2008

Hello,

I have an issue with a T1. We ordered a verizon T1 to connect one office to our corporate office. On one side we have a 2811 and an 1841 on the other.

The issue I am having is that even after doing a simple config of the IP addresses for each router, I am not able to ping the serial interfaces, they show as down, and I have warning lights on my wic. The LP light is yellow on both.

Verizon did have to come in and replace a a T1 card in the smartjack.

Any ideas what could be doing this? I cannot even ping the interface form fa0/0 on the routers. This is my first turn at version 12.4 of the IOS. I had used 12.2 the last time I had to configure T1 links, and at that time it was simply assigning an ip address to the interface, and issuing a no shut to get basic connectivity.

do both interfaces have to be able to communicate to bring either interface up?

Sorry, I just really never ran into any issues on first configs of a T1.

Here are the configs. Mind you it, it is not configured very well or secure at the moment. I just wanted to get the serial links up.

I've tried with and without a subinterface also. Currently it is setup as a subinterface

NYHQ-R0001#show run

Building configuration...

Current configuration : 1499 bytes

!

! Last configuration change at 11:13:09 NewYork Tue Jun 3 2008

! NVRAM config last updated at 16:59:58 NewYork Mon Jun 2 2008

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname NYHQ-R0001

!

boot-start-marker

boot-end-marker

!

no logging buffered

enable secret xxx

enable password xxxxxxx

!

no aaa new-model

!

resource policy

!

clock timezone NewYork -5

clock summer-time NewYork date Apr 6 2003 2:00 Oct 26 2003 2:00

ip subnet-zero

!

!

ip cef

!

!

ip domain name xxxxxxxxxx

ip name-server 192.168.0.2

ip name-server 192.168.0.3

!

username admin privilege 15 view root secret xxx.

!

!

!

interface FastEthernet0/0

ip address 192.168.0.251 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0

description T1 circuit to MWF/LWD - Verizon - CID# xx.xxxx.xxxx

no ip address

no fair-queue

service-module t1 timeslots 1-24

!

interface Serial0/0/0.1

ip address 192.168.107.2 255.255.255.0

!

router rip

version 2

network 192.168.0.0

network 192.168.7.0

network 192.168.107.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.0.254

!

ip http server

!

snmp-server community xxxxxx RO

snmp-server host 192.168.0.191 xxxxxx

!

control-plane

!

banner login ^CAuthorized access only!^C

!

line con 0

line aux 0

line vty 0 4

password xxxxxxx

login

!

scheduler allocate 20000 1000

!

end

NYHQ-R0001#

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
fretburner Tue, 06/03/2008 - 07:42

I forgot to add that on both sides the serial interface is an integrated T1 CSU/DSU WIC

raeesshaikh Wed, 06/04/2008 - 07:22

We will require the Sh int output to help you.

Need to knw wether its protocol down or hard down.

Incase its getting hard down than u need to check your serial NIC card & the physical connectivity. If its protocol down than there can be a problem with the verizon network or on the other end of ur serial link.

Raees.

Richard Burts Tue, 06/03/2008 - 07:48

Glen

I doubt that your problem is due to running 12.4 and believe that there are other issues.

For one thing the serial interface by default runs HDLC protocol and HDLC does not support subinterfaces. I am surprised that the IOS even allowed you to configure the subinterface if the interface is HDLC. I suggest that you remove the subinterface and concentrate on getting the main interface to work.

From your description of the symptoms I wonder if there is a problem with the connection between the router and the smart jack. Can you check that connection?

It might be helpful if you would post the output of show interface serial0/0/0 and the output of show service-module for that interface.

HTH

Rick

Richard Burts Tue, 06/03/2008 - 07:50

Glen

I doubt that your problem is due to running 12.4 and believe that there are other issues.

For one thing the serial interface by default runs HDLC protocol and HDLC does not support subinterfaces. I am surprised that the IOS even allowed you to configure the subinterface if the interface is HDLC. I suggest that you remove the subinterface and concentrate on getting the main interface to work.

From your description of the symptoms I wonder if there is a problem with the connection between the router and the smart jack. Can you check that connection?

It might be helpful if you would post the output of show interface serial0/0/0 and the output of show service-module for that interface.

HTH

Rick

Pravin Phadte Tue, 06/03/2008 - 07:58

Hi,

I am not sure what this route is for ?

ip route 0.0.0.0 0.0.0.0 192.168.0.254

I may be wrong but i feel you need to change it.

and try without the sub interface.

config t

ip route 0.0.0.0 0.0.0.0 Serial0/0/0

interface Serial0/0/0

ip address 192.168.107.2 255.255.255.0

regards,

pravin

Richard Burts Tue, 06/03/2008 - 08:40

pravin

The ip route that you question is a default static route with a next hop of some device located on the fastethernet interface. Why do you believe that there is a problem with it?

You suggestion would point the default route out the serial interface which is a major change in the architecture of the network.

HTH

Rick

Pravin Phadte Tue, 06/03/2008 - 08:55

Hi Rburts,

Yes I agree to you Rburts and may be i may have not concluded properly the problem.

The reason why i said this was because i felt that he need to route the traffic out through the serial link.Default routes tell router where to go to if they don't have a specified route in their routing table.

In the routing table he will it will have the networks for serial and fasteth as connected and would be routed without any problem.

If you see the configs it also has RIP configured. This makes it more confusing what the config does. It would be better to give a suggestion if there was a network diagram and configs of both the routes.

Regards

pravin

fretburner Tue, 06/03/2008 - 09:28

Yes, that 192.168.0.254 is the router for all outside access and also has 5 other t-1 and frame relay connections to our other locations attached to it's serial interface.

Sorry if I didn't mention that earlier.

fretburner Tue, 06/03/2008 - 09:24

This is the output for show s0/0/0

Serial0/0/0 is down, line protocol is down

Hardware is GT96K with integrated T1 CSU/DSU

Description: T1 circuit to MWF/LWD - Verizon - CID# 32.HCGS.446179

Internet address is 192.168.107.2/24

MTU 1500 bytes, BW 1536 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC, loopback not set

Keepalive set (10 sec)

Last input 3d23h, output 3d23h, output hang never

Last clearing of "show interface" counters 20:31:44

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

0 packets output, 0 bytes, 0 underruns

0 output errors, 0 collisions, 2470 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

DCD=down DSR=up DTR=up RTS=up CTS=down

*****************************

and the output for show service module s0/0/0

NYHQ-R0001#show service-mod s0/0/0

Module type is T1/fractional

Hardware revision is 1.2, Software revision is 20071128,

Image checksum is 0x3E88B0, Protocol revision is 0.1

Receiver has no alarms.

Unit is currently in test mode:

remote loopback (remotely initiated) is in unknown state

Framing is ESF, Line Code is B8ZS, Current clock source is line,

Fraction has 24 timeslots (64 Kbits/sec each), Net bandwidth is 1536 Kbits/sec.

Last module self-test (done at startup): Passed

Last clearing of alarm counters 5d03h

loss of signal : 1, last occurred 5d03h

loss of frame : 3, last occurred 3d23h

AIS alarm : 2, last occurred 3d23h

Remote alarm : 24, last occurred 04:17:01

Module access errors : 0,

Total Data (last 96 15 minute intervals):

11135 Line Code Violations, 17 Path Code Violations

0 Slip Secs, 4 Fr Loss Secs, 4 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 2147483647 Severely Err Secs, 2147483647

Unavail Secs

Data in current interval (665 seconds elapsed):

0 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

******************

I also removed the subinterface, and assigned the IP address to s0/0/0

Thanks for your replies.

Pravin Phadte Tue, 06/03/2008 - 09:36

Serial0/0/0 is down, line protocol is down

DCD=down DSR=up DTR=up RTS=up CTS=down

the interface is down and protocol is down,

the modem status is DCD=down DSR=up DTR=up RTS=up CTS=down.

This router or its CSU/DSU is not communicating with the telco device. Look for trouble on the physical wiring to this router. In the real world, this is almost always a telephone company

Get the telco involved to do an end to end circuit test. Test till smartjack and then till the CSU.

If not you may need to change the card on the router.

reagrds,

Pravin

fretburner Wed, 06/04/2008 - 07:01

Thanks everyone. I called my telco up and placed a ticket.

I received a call back and they said they see no issues with the circuit, but miraculously the circuit bounced back up and I was able to ping the other site about 5 minutes after I received the call.

So everything is fine. Thanks again everyone!!

Pravin Phadte Wed, 06/04/2008 - 07:04

Hi,

thats good to know that the problem is been fixed.

The telo always say that they dont have any problem from them.

AT&T has always been the tuff to deal with lol.

Paolo Bevilacqua Mon, 06/09/2008 - 13:50

You have just witnessed a typical telco CS approach.

When possible, the ticket is immediately closed, as this improves their "SLA" benchmark, and in some cases involves a monetary compensation.

Following that, since in most cases they already know what's wrong, the problem is fixed so customers can't complain further.

cristian.d.generoso Thu, 08/21/2014 - 02:16

NYHQ-R0001#show service-mod s0/0/0

Module type is T1/fractional

Hardware revision is 1.2, Software revision is 20071128,

Image checksum is 0x3E88B0, Protocol revision is 0.1

Receiver has no alarms.

Unit is currently in test mode:

remote loopback (remotely initiated) is in unknown state <<<<<<<<<

 

The circuit was in loopback state that's why it's down.

Someone or something had initialized the loop.

Actions

This Discussion