CRC error

Unanswered Question
Jun 3rd, 2008

We are doing router refreshment project. We are replacing 1700 router with 1841 router. But the 1700 router having Ethernet port 1841 router having Fastethernrt port. We are facing some problem while replacing 1841 router. Fast Ethernet port having CRC error and collecting error ( half duplex and speed 10) this problem is not in 1700 router. Problem with only 1841 router

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
spremkumar Tue, 06/03/2008 - 08:48

Hi Thiru

Try changing both speed/duplex on the other end (most probably switch) where the router ethernet interface is getting terminated and check.

Else try to hardcode both speed/duplex to half/10 in your router which i suggest is not a best practice to do so.


gajanangavli Wed, 06/04/2008 - 03:39

configure the

speed 100

duplex full


int fa x/x

port for which u r getting the errors .Make sure that duplex and speed should be matched on both side.

Pravin Phadte Wed, 06/04/2008 - 04:47

Yes i feel changeing the speed will help.

If you need to get the right speed then i would suggest to check what speed the 1700 routers port is at and change to the same on the new router.

thiru.vel10 Thu, 06/05/2008 - 08:58

In 1700 router settings are half duplex and speed 10, I configured the same in 1842 router but I am getting CRC error. If I set full duplex means the line protocol is went down. So I am sure the duplex is half and then I tried speed 100, 10 & auto but the result is same. When I am connecting e0 int in 1700 router that time everything is fine settings is half duplex and speed is 10. I am facing this not only one router where ever I replacing 1842 router I am having same problem so I am suspecting some things problem in Fasethernet port.

patrickvanham Wed, 06/04/2008 - 05:15

CRC errors on a port could be an indication of a duplex mismatch, like collisions are. set both to auto on both ends and see what they autonegotiate. If the port doesn't come up try setting both ends to speed 10 but leave duplex auto.

bibek_deo Fri, 06/06/2008 - 06:50


The Fa ethernet port supports 100 mbps/full duplex.Jus try changing the config..




This Discussion