banwidth segregation and load balance

Unanswered Question
Jun 3rd, 2008

Dear simsing,


We having 1841 router of my customer place in that router

my customer wanted band width segregation my customer

having 2mb bandwidth he wanted 1 mb for voice and 1mb for data segregation he wanted and he having 2 leased lines one

is 2 mb link v.35 output link another one also 2mb v.35

output link so he want failover in this 2 links so plz help

me in this configurations .


Thanks & Regards

vasu

9246571397



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
spremkumar Wed, 06/04/2008 - 02:01

Hi


A sample config has been pasted below but you need to make sure that the so called data traffic has to be classified properly so that they dont starve for bandwidth.


In this example only voice and http traffic is being considered.


access-list 100 permit udp any any range 16384 32000

access-list 100 permit tcp any any eq 1720

access-list 101 permit tcp any any eq 80

!

class-map voip

match access-group 100

class-map data1

match access-group 101

!

policy-map llq-policy

class voip

priority percent 50

class data1

bandwidth 768

class class-default

fair-queue

!

interface Serial 0/0

service-policy output llq-policy

!

interface Serial5/1/0:0

service-policy output llq-policy

!


Also make sure that the bandwidth command under the interface is set to 2048 instead of the default 1544.


You can also make use of max-reserved-bandwidth command to reserve maximum bandwidth available and be used by Qos policies for your voice and data traffic.


for failover you can make use of floating static routes over the links so that when the primary link goes down the traffic will automatically get re routed via the secondary link..


regds



bericaleb Sun, 06/15/2008 - 17:13

Hi

what does the priority percent 50 mean?

And the bandwidth 768, is it the total bandwidth of the 2048?


Do I have to configure configs on both end of the link?


For the access-list above the data includes all data not specificall http, do I necessarily need to include the an access-list for data?



spremkumar Sun, 06/15/2008 - 20:25

Hi


As per your requirement of allocating equivalent share to both voice and data as a part of LLQ configuration which is very much required for Voice traffic we use priority percent which takes 50% of the available bandwidth on the interface.

Generally 75% of the bandwidth is used for the normal traffic like voice/data etc and other 25% is being considered for routing updates/keepalives etc.,.

But if you want to make use of the total bandwidth you can make use of the command max-reserved-bandwidth to avail the whole bandwidth.


you can use the below link for more info on the commands..


http://www.cisco.com/en/US/tech/tk543/tk757/technologies_tech_note09186a0080103eae.shtml


http://www.cisco.com/en/US/tech/tk39/tk48/technologies_tech_note09186a00800fe2c1.shtml


regds


Actions

This Discussion