Unable to backup image.bin in PIX

Unanswered Question
Jun 3rd, 2008


Im planning to delete the "downgrade.cfg and image.bin" in my router. Since in running out of flash mem so i can install asdm522 in my pix. Before deleting it, i just want to backup these files first. Im able to backup downgrade.cft but when im trying to save the image.bin in tftp server im always getting an error "%Error copying flash:/image.bin <Inappropriate file type or format> "

PIX#copy flash tftp

Source filename []? image.bin

Address name of remote host []?

Destination filename [image.bin]?

%Error copying flash:/image.bin <Inappropriate file type or format>

Is there a way to backup my previous PIX image before deleting it?



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
husycisco Wed, 06/04/2008 - 01:45

Hi Jong

I dont think that image exists as image.bin in your PIX. Type dir in priv exec mode and it will list you the files. Most probably, following syntax will work

copy flash:image tftp:\\tftpip\image.bin

Btw if your IOS is older than 7.x, you cant copy the image to a tftp. Only config is allowed to be copied


jong_r0602 Wed, 06/04/2008 - 17:26


I tried both procedure but it still not worked for me. My previous version was 6.3 then I upgraded it to ve7.0 then 7.2

But I've noticed that the pix704.bin was gone after 6.3-7.0 upgrade. And the only file that I have on my flash are:

HT1-PIXA# dir

Directory of flash:/

6 -rw- 56680 05:48:12 May 04 2008 downgrade.cfg

9 -rw- 5386296 05:49:13 May 04 2008 image.bin

12 -rw- 8312832 06:23:03 May 04 2008 pix722.bin

16128000 bytes total (2306560 bytes free)


What happen to pix704.bin image after the 6.3 to 7.0 upgrade?

Farrukh Haroon Mon, 06/09/2008 - 01:15

Try the following:

rename flash:image.bin flash:ABCD

And then try to copy the ABCD file.

Also make sure your TFTP Server is operational :)



jong_r0602 Mon, 06/16/2008 - 23:19

HT1-PIXA# copy flash:image63.bin tftp://


I tried to renamed it but still getting the same error. Please see the item below

Source filename [image63.bin]?

Address or name of remote host []?

Destination filename [image63.bin]?

%Error copying flash:/image63.bin (Inappropriate file type or format)



husycisco Mon, 06/16/2008 - 23:46

Wait a minute, are you using 6.3 ? Copying the image is NOT! supported in this version!

Farrukh Haroon Tue, 06/17/2008 - 02:13

The rename was meant to bypass that restriction, but personally I never tried it.

Did you try it?



jong_r0602 Wed, 06/18/2008 - 17:12


I was upgraded it from 6.3 to 7.2(2). I wanted to delete that image.bin file beczuse im runningout of space rightnow but i need to backup it first just in case theres a bug on 7.2(2) i can revert it back again to 6.3

I already renamed it from image.bin to image63.bin.

I appreciate all your help.



srue Wed, 06/18/2008 - 20:02

when you upgrade from 6.3 to 7.0 on the pix, the image is named image.bin for some reason - it renames it that as part of the upgrade process.

as others have said:

copy flash:/image.bin tftp

then follow the prompts.

jong_r0602 Mon, 07/07/2008 - 05:39

I tried but still no luck :(

Is says "invalid format"



Farrukh Haroon Mon, 07/07/2008 - 05:54

One question, why are really backing it up?

Every image is present on CCO, in case you need it?



jong_r0602 Thu, 07/17/2008 - 04:09

Yes, incase we need it. Actually we had a problem this week, our VPN connectivity becomes intermittent in both PIX. I dont know if there's a bug nn 7.2(2). ACL hit count does not incrementing also even if there's a traffic on it. I dont know what should i need to do now. Both PIX have the same symptoms. Appreciate your help



Farrukh Haroon Thu, 07/17/2008 - 04:47

Well you need to post more details about the issue. If possible debugs also.

Don't worry too much about the ACL hits. Why don't you upgrade to the least version in the 7.2(X) train?




This Discussion