a problem with RDP when WAEs was connected to the network

Unanswered Question
Jun 4th, 2008

The customer has a problem with RDP sessions on one Microsoft cluster server. The problem started when the WAEs (management and acceleration WAEs) are connected to a network (where a cluster is connected). Did anybody have the similar problem? The sessions are connected, but after some different times these sessions are frozen. This problem is only with this Microsoft cluster, the RDP on other servers are good. The WAAS is 4.0.17b14.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
edwardwaithaka Wed, 06/04/2008 - 09:58

Hi,

I have the same problem as I write. RDP seems to get slower when I connect the WAEs and the login timesout before the user can type the username and password.

I have ensured that "EPM Classification" is disbled.

Check and see if Term-services are well configured on the TS server side. Maybe some config is conflicting with WAAS TS optimization.

What happens when you set TS to passthrough?

Also try this for your case;

" HOW-TO: Configuring RDP and Terminal Services for Full WAAS Optimization

Microsoft RDP and Terminal Services are, by default, compressed and encrypted. As such, the default Cisco WAAS policy for these applications is to apply TCP optimizations only. RDP and Terminal Services can be configured to allow Cisco WAAS to provide full optimization (DRE, LZ, TFO) which is a 2X-10X improvement over native WAN and 2X-3X improvement over the compression provided by Microsoft.

Configuring Microsoft RDP and Terminal Services to support Cisco WAAS full optimization requires a change to the client and a change to the server.

On the client, disable compression by editing the .RDP file for the connection using Notepad or a similar text editor. Identify a line in the file that shows "compression:i:1". Modify this line to say "compression:i:0". This disables compression for the RDP/TS connection.

On the server, open the Terminal Services Configuration found under Start > Programs > Administrative Tools. From here, expand Terminal Services Configuration to Connections. Double-click the "RDP-Tcp" entry found in the workspace. Change the encryption level to "Low", which specifies that only login will be encrypted. Then, click "Ok" and close Terminal Services Configuration.

Then, modify the Cisco WAAS policy on the configured device group (or explicitly on each of the WAEs) called "MS-Terminal-Services". Set this policy to "Optimize Full". "

Anyone out there with a clue why RDP gets disconnected?

ROMAN TOMASEK Thu, 06/05/2008 - 00:33

Hi Edward,

thank you for your answer. I have already configured TS to passthrough. The behaviour is following - a client established RDP to TS, he communicates with TS, but after some time this connection is frozen:-(

Roman

dstolt Thu, 06/05/2008 - 06:58

Roman,

Just a thought, do you have any tunneling or VPN in the network that might be causing fragmentation?

Dan

ROMAN TOMASEK Thu, 06/05/2008 - 07:03

Hi,

I have no any tunneling or VPN. It is just clear communication from a client to a server.

Roman

Actions

This Discussion