does a MAXimum nr. of configurable DCHP Pools exist?

Answered Question
Jun 4th, 2008

Regarding a Catalyst 6500 with IOS version 12.2(18)SXF5, we have (seemingly) unexplicable difficulties in configuring a number of dhcp pools. It looks as if certain Interfaces dont get any answers/reactions to their dhcp discovers. Some interfaces/pools serve as expected - some dont. We have 34 Pools configured ...

Regards

Robert

I have this problem too.
0 votes
Correct Answer by Richard Burts about 8 years 6 months ago

Robert

The additional information is quite helpful. BBB does not work because all of the addresses in its pool have been excluded and it has no addresses that it can offer. BBB's pool is:

network 10.2.94.0 255.255.255.0

and it is entirely included within the excluded range of:

ip dhcp excluded-address 10.2.93.250 10.5.93.255

I do not know if it was really intended to have the excluded addresses go through 10.5.93.255 of whether it was a typo (typed a 5 instead of a 2). But 10.5.93.255 is what the router is excluding. Change the excluded range and BBB should start to work.

HTH

Rick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Richard Burts Wed, 06/04/2008 - 04:32

Robert

I am not aware of any limit on the number of DHCP pools that can be configured and suspect that there is some other issue causing your symptoms. Can you post the configuration of the pools (or at least one or two that do not work as expected) and also post the configuration of the interface on which the DHCP discovers would be received?

HTH

Rick

robertblasey Wed, 06/04/2008 - 05:22

the dhcp config:

AAA works, BBB doesn't (34 pools)

-----------------------------------------

ip dhcp excluded-address 10.2.93.250 10.5.93.255

ip dhcp excluded-address 10.2.94.250 10.2.94.255

ip dhcp pool AAA

network 10.2.92.0 255.255.254.0

default-router 10.2.93.254

domain-name DNS.local

dns-server 10.2.91.241 10.2.91.242

option 150 ip 10.2.91.1 10.2.91.2

ip dhcp pool BBB

network 10.2.94.0 255.255.255.0

default-router 10.2.94.254

domain-name DNS.local

dns-server 10.2.91.241 10.2.91.242

option 150 ip 10.2.91.1 10.2.91.2

interface Vlan920

description AAA

ip address 10.2.93.251 255.255.254.0

no ip redirects

no ip proxy-arp

standby ip 10.2.93.254

standby priority 200

standby preempt

!

interface Vlan921

description BBB

ip address 10.2.94.251 255.255.255.0

no ip redirects

no ip proxy-arp

standby ip 10.2.94.254

standby priority 200

standby preempt

------------------------------------------

we disabled HSRP - no change.

The device receives DHCPDISCOVERS on all vlan interfaces, but doesn't answer specific pools/vlans

Thanks for your time

Robert

Correct Answer
Richard Burts Wed, 06/04/2008 - 09:49

Robert

The additional information is quite helpful. BBB does not work because all of the addresses in its pool have been excluded and it has no addresses that it can offer. BBB's pool is:

network 10.2.94.0 255.255.255.0

and it is entirely included within the excluded range of:

ip dhcp excluded-address 10.2.93.250 10.5.93.255

I do not know if it was really intended to have the excluded addresses go through 10.5.93.255 of whether it was a typo (typed a 5 instead of a 2). But 10.5.93.255 is what the router is excluding. Change the excluded range and BBB should start to work.

HTH

Rick

robertblasey Wed, 06/04/2008 - 11:34

Hi Rick,

thanks a bunch - 4 Network Pro's looked over this config nobody saw the typo. Incl. one CCIE and alltogether 20 years Cisco experience ...

Thanks again for your time Rick!

Regards

Robert

Richard Burts Wed, 06/04/2008 - 12:02

Robert

I am glad that I was able to help. Sometimes we just see what we expect to see, especially if we are looking at something that is familiar to us (like your device config is to you) and miss a typo like this. Sometimes it is a real advantage to have a fresh pair of eyes.

Thank you for using the rating system to indicate that your problem was resolved (and thanks for the rating). It makes the forum more useful when people can read about a problem and can know that there was a response that did resolve the problem.

The forum is an excellent place to learn about Cisco networking. I encourage you to continue your participation in the forum.

HTH

Rick

Sushil Kumar Katre Thu, 06/05/2008 - 09:34

Hi Guys,

This is the power of rating. I have been following this specific post since the day this was created and today when I saw the RED tick I immediately opened it to see the resolution.

If used sensibly rating system is just great.

-> Sushil

Actions

This Discussion