Multiple t1's to 2 locations

Unanswered Question

I am working with a 3845 with 3 dual T1 WICS and 2 2851's with 1 dual T1 and a single T1 WIC. Having trouble getting them to communicate across simulated T1 connections. I have made the test cables for loopbacks and have all WICS connected (3 to each 2851 ) I cannot get any communication acrossed the routers, ie, ping. Previous routers have serial lines to establish point-to-point routes but do not see serial interfaces on the newer configuration IOS 12.4 (17b). My test cables are configured by creating jumper patch cables with 1-4, 2-5, 4-1, 5-2. All WICS are lit green on the CD lights. Once communications are established, how are the T1 lines bonded? There will be 3 T1 lines bonded to each 2851 from the 3845.

3845 sho run

version 12.4 no service pad service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption service sequence-numbers ! hostname cisco3845 ! boot-start-marker boot-end-marker ! card type t1 0 0 card type t1 0 1 card type t1 0 2 security authentication failure rate 3 log

security passwords min-length 6

logging buffered 51200 debugging

logging buffered 51200 debugging logging console critical enable secret xxx ! no aaa new-model clock timezone PCTime -6 clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00

network-clock-participate wic 0

network-clock-participate wic 1

network-clock-participate wic 2

no ip source-route ip

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Sushil Kumar Katre Wed, 06/04/2008 - 09:54

Hi Bill,

I don't see any serial interfaces in the running config [may be because of formatting].

Can you upload the show run and show diag output in a txt file.

+ show ver

-> Sushil

Richard Burts Wed, 06/04/2008 - 10:10

Bill

It is not clear in your post what kind of cards these are. But I suspect that the issue is that the cards support both T1 and E1 and need to be identified to IOS what they are to do. Use the command card type t1 and see if it does not produce serial interfaces that you can configure.

If that does not solve your issue then it would help if you would post the output of show diag and the complete running-config.

HTH

Rick

Richard Burts Wed, 06/04/2008 - 17:56

Bill

Maybe I have some good news and perhaps some not so good news. I found some interesting things in this link:

http://www.cisco.com/en/US/products/hw/modules/ps2617/products_configuration_example09186a008052c920.shtml

The good news is that there is a command in controller t1 config mode for:

channel-group 1 timeslots 1-23

and the channel-group command that assigns certain channels is the command that creates the serial interface:

interface Serial0/0:1

ip address x.x.x.x m.m.m.m

The not so good news is that according to this link:

Cisco IOS Image -- To run these features on T1/E1 interfaces, you must install an IP Plus or IP Voice image (minimum) of Cisco IOS Release 12.3(14)T or a later release.

and you are running the IP BASE feature set. So it may be that you will need to upgrade the IOS image to a different feature set (not necessarily a different version) to be able to use these interfaces.

I would give the channel-group command a shot. If it works that is good. And if it does not produce the serial interfaces then you need a different image.

HTH

Rick

Richard Burts Fri, 06/06/2008 - 07:42

Bill

If the router is covered by a maintenance contract then the IOS should be a downloadable issue. If the router is not covered by maintenance then it probably is a purchase issue.

HTH

Rick

Richard Burts Fri, 06/06/2008 - 09:25

Bill

It may depend on the terms specified by who ever sold the routers to you. I would be optimistic that most new routers are covered by a warranty that should cover it. But you probably should check with who ever sold the routers to you.

HTH

Rick

Rick,

I am still waiting to hear from my sources regarding the IOS upgrade, as to if it is a purchase or downloadable. I was attempting the command to create the serial interface. Looking at my options, it appears the serial is not there. Am I in the correct place?

cisco3845(config-if)#?

Interface configuration commands:

access-expression Build a bridge boolean access expression

arp Set arp type (arpa, probe, snap) or timeout

backup Modify backup parameters

bandwidth Set bandwidth informational parameter

bgp-policy Apply policy propagated by bgp community string

carrier-delay Specify delay for interface transitions

cdp CDP interface subcommands

dampening Enable event dampening

default Set a command to its defaults

delay Specify interface throughput delay

description Interface specific description

diffserv diffserv (Provisioning)

dot1q dot1q interface configuration commands

exit Exit from interface configuration mode

flow-sampler Attach flow sampler to the interface

help Description of the interactive help system

hold-queue Set hold queue depth

ip Interface Internet Protocol config commands

keepalive Enable keepalive

llc2 LLC2 Interface Subcommands

load-interval Specify interval for load calculation for an

cisco3845(config-if)#

Richard Burts Tue, 06/10/2008 - 08:51

Bill

This output indicates that you are in interface config mode (cisco3845(config-if)#). I believe that you want to be in controller t1 mode to enter the channel-group command which would create the serial interface.

HTH

Rick

Richard Burts Tue, 06/10/2008 - 12:58

Bill

I am glad that you managed to get the serial interfaces configured. Is this still on the IP Base image?

I have looked at the configs and while there are some things that I would question (especially the network statements under router rip) I do not see config problems that would explain not being able to ping the main router ethernet from a remote. The main router does have static routes configured for each remote ethernet with a correct next hop address. And each remote has a valid default route configured which should get to the main.

I wonder if some interfaces are not working as expected. Could you post the output of these commands from the main router and from at least one of the remote routers:

show ip route

show ip interface brief

show cdp neighbor detail

HTH

Rick

Rick,

I ran the commands to one file. The last command received an error about % CDP is not enabled. The RIP was just a test that did not get removed. The remote routers can ping/telnet into the main router Gigabit Eth address but cannot telnet/ping the remotes Gigabit Eth addresses from the main site router. This is still the IP Base image. I have a case open and have received an email from Luis Aguero.

Richard Burts Tue, 06/10/2008 - 13:36

Bill

The additional information is quite helpful and shows exactly what the issue is. from the remote router:

Interface IP-Address OK? Method Status Protocol

GigabitEthernet0/0 192.168.10.1 YES NVRAM up down

If the remote ethernet interface is protocol down then it can not receive or respond to the ping. I suspect the interface is down because nothing is connected to it. The simple solution would be to connect something to the ethernet interface. If there is some reason for not connecting something to the interface then as a test you could configure "no keepalive" under the remote ethernet interface. This will bring the interface protocol up.

HTH

Rick

Richard Burts Tue, 06/10/2008 - 14:23

Bill

I am not sure that I understand what you mean when you say 3 T1s bonded to a site. Right now you have 3 T1s connected to each site and each T1 has its own IP address and operates independently. When many people talk about bonded T1s they are talking about putting the T1s into ppp multilink in which the 3 T1s act together and the multilink provides a single logical interface for the serial connections. If that is the kind of thing that you had in mind then you need to configure ppp multilink on the routers and put each t1 into the multilink.

HTH

Rick

Richard Burts Tue, 06/10/2008 - 14:47

Bill

It would look something like this:

!

interface Multilink1

ip address 192.168.2.1 255.255.255.0

no keepalive

no cdp enable

ppp multilink

ppp multilink fragment disable

ppp multilink group 1

!

interface Serial0/0/0:1

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

!

interface Serial0/0/1:1

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

!

interface Serial0/1/0:1

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

!

HTH

Rick

Richard Burts Wed, 06/11/2008 - 07:42

Bill

Here are some comments as I look through the configs:

- you should update the dates specified in the clock summertime command:

clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00

and I wonder if you really want it from first week of April to last week of October - but then I am not sure where you are and what daylight savings situation you have.

- you have some static routes configured as permanent:

ip route 0.0.0.0 0.0.0.0 192.168.0.192 permanent

ip route 192.168.10.0 255.255.255.0 192.168.2.2 permanent

I am not sure why they are permanent. I am not sure what the situation for the static default is and perhaps there is reason to have that one as permanent. But I would suggest that the static routes going over the multilinks should probably not be permanent. If the link goes down and can not transport traffic do you want to keep it in the routing table anyway?

- I would suggest that you change the banner exec which describes SDM user IDs (which you have already changed)

- on remote2 you have

ip domain name yourdomain.com

you cleaned it up on main and remote1, so why is it still here?

It looks to me like the T1s and the multilink are ok and my comments here do not represent any serious issues but are things I would address if I were you.

HTH

Rick

Rick,

I have cleaned up all the items listed above but wanted to ensure I was using the correct command for the clock summertime command. The routers will be installed in the Central Time Zone (St Louis,MO area). I used the following command

clock summer-time recurring CST 2 Sun Mar 02:00 1 Sun Nov 02:00 60

Is this correct? Thanks again for all your help. It has been greatly appreciated.

Bill

Richard Burts Wed, 06/11/2008 - 11:10

Bill

It is mostly right. To define daylight savings I would think that you would want CDT instead of CST (and I think that you would want CST in the command clock timezone rather than what is there now).

Also depending on the version of code that you are running it may be that all you need is

clock summer-time recurring CST

specifying the date and time for the switch is an option if you are in a place where the date for change is different from the default. Your original post talked about running 12.4(17b) is that still the version? I believe that it would implement the new dates for the daylight savings change. You can use the command show clock detail to check and see when the router thinks it will make the change and determine whether you need to specify the date or not.

HTH

Rick

Richard Burts Wed, 06/25/2008 - 15:26

Bill

I have looked through the configs that you posted (focusing mainly on the serial and multilink confiuration) and I do not see any particular issues.

Perhaps the output of show ppp multilink, of show interface (for the serial interfaces), and of show controller t1 would show something.

HTH

Rick

Sushil Kumar Katre Wed, 06/04/2008 - 21:31

Hi Bill/Rick,

I don't seeany PVDM in the show diag output and DSPs would be required for the VWIC cards to work.

-> Sushil

Paolo Bevilacqua Tue, 06/10/2008 - 13:10

No, DSPs are not required when the VWIC are configured with channel-group.

Indeed today the "proper" card for data connectivity is the HWIC-xCE1T1-PRI or the HWIC-8CE1T1-PRI, but the VWIC works fine also.

Actions

This Discussion