PRI Turnup ... International Not working

Unanswered Question
Jun 4th, 2008

AT&T circuit in NYC ... getting this when dialing International. Local and LD are fine.

Jun 4 19:18:13.688: ISDN Se0/3/0:23 Q931: RX <- PROGRESS pd = 8 callref = 0x8001

Cause i = 0x82FF - Interworking error; unspecified

Progress Ind i = 0x8281 - Call not end-to-end ISDN, may have in-band info

Any ideas?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
eellarbee Wed, 06/04/2008 - 11:33

my guess is you need to specify a numbering plan and a plan type.

If this is an MGCP gateway, you can change those under the PRI gateway in the callmanager. If it's a CME or H.323 gateway, you can do an outgoing voice-translation profile to designate ISDN and National.

eellarbee Wed, 06/04/2008 - 11:44

What system are you using and what type of gateway? I can get you a snippet or lead you in the right direction

Brian Carscadden Wed, 06/04/2008 - 11:50

Callmanager 5.1(3), MGCP 3825 w/ 12.4(19)

ISDN is NI2, two full PRIs (no NFAS)

Config is basic MGCP

t-alkhalidi Wed, 06/04/2008 - 11:51

well im facing the same problem , but with service number we use here in my country. we use 181 as directory service. route pattern 9.1xx discard digit predot. i can call 111 , 199 etc .. excpet the 181. i got error msg from the PSTN that the number not valid. and its routed to FXO port not ISDN. any idea?

eellarbee Wed, 06/04/2008 - 12:05

You can't control the Information Element on an FXO port - it doesn't contain ISDN information. What message do you get when the call fails?

Are you running MGCP gateways or H.323?

eellarbee Wed, 06/04/2008 - 11:48

taken from:

Change Outbound Calls with a Plan and Type of Unknown to ISDN and National

voice translation-rule 1

rule 1 // // type unknown national plan unknown isdn

!--- Matches any number string with a plan and type of

!--- unknown. Also changes the type to national and the plan to isdn.


voice translation-profile isdn_map

translate called 1

!--- Invokes voice translation rule 1 in order to translate the called number.


dial-peer voice 1 pots

translation-profile outgoing isdn_map

!--- Invokes voice translation profile “isdn_map” for outgoing calls.

kearly01#test voice translation-rule 1 5551234 type unknown plan unknown

Matched with rule 1

Original number: 5551234 Translated number: 5551234

Original number type: unknown Translated number type: national

Original number plan: unknown Translated number plan: isdn

eellarbee Wed, 06/04/2008 - 11:54

ah, okies, that previous post is h.323, that won't work.

in your mgcp gateway, there should be a setting for outbound calls. I'm not 100% on 5.x or 6.x, but in 4.x it defaulted to callmanager under plan type and numbering plan. You can set those to ISDN plan type and National numbering plan, reset the gateway and try it out.

Carriers are usually real picky about information elements on a PRI for international calls, it needs the plan type and numbering plan.

Brian Carscadden Wed, 06/04/2008 - 12:06

Yes, it's largely the same. I've tried a few combinations, but I'm largely guessing. I opened a TAC case and am awaiting contact.

Brian Carscadden Thu, 06/05/2008 - 06:03

TAC says based on the debug info the issue appears to be on the provider's side. Nothing to change with the config...


This Discussion