IOS upgrade

Answered Question
Jun 4th, 2008

I need to upgrade the IOS on my 4506, sup 4. It is currently running 12.2.18-EW3 (DF). I'd like to get a lot newer IOS on there. But i'm stuck on deciding which one to upgrade. 12.2.44-SG (ED)is the newest one i can find. What is the difference between the EW and SG?

I have this problem too.
0 votes
Correct Answer by Edison Ortiz about 8 years 6 months ago

argh,

try this one:

delete bootflash:cat4500-ipbase-mz.122-40.SG.bin

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Edison Ortiz Wed, 06/04/2008 - 12:39

SG supporst NSF, WCCP and CoPP. I recommend going with it as it's the new line of code for the 4500 Switches.

12.2(44)SG or 12.2.(40)SG are solid choices.

HTH,

__

Edison.

cowetacoit Wed, 06/04/2008 - 12:42

The IOS i'm running now is very old, DF! So i won't have any problems upgrading to such a new IOS? There is about 20 IOS releases between the current and the newest. That bothers me. I'm just a cautious person.....

glen.grant Wed, 06/04/2008 - 15:47

In the earlier days you did have to worry about new releases but these days code is a lot more stable generally right out of the box so its not as big of a risk anymore. We used to stick to strictly GD code but we don't do that anymore either. I'm not sure they still even do GD code anymore for anything other than routers anyway , maybe one of the cisco guys could comment on that . I know I never see GD code for any of the switches since catos went away .

cowetacoit Wed, 06/04/2008 - 17:05

For some reason i tried loading that new IOS 5 different times and it wouldn't work.

first

copy tftp flash

ip add

source cat4500-ipbasek9-mz.122-44.SG.bin

dest cat4500-ipbasek9-mz.122-44.SG.bin

conf t

boot system flash cat4500-ipbasek9-mz.122-44.SG.bin

then i did a reload. But it didn't take the new IOS. I currently have cat4000-i9s-mz.122-18.EW3.bin on my 4506. The only difference i see is the old image file has "4000" and the new has "4500". Do i need to load a earlier image before i can load the newest? When i go to the IOS page for the 4506 sup 4, i apparently i have the oldest IOS on the page.

any suggestions would be helpful.

Admin_4506#sh ver

Cisco Internetwork Operating System Software

IOS (tm) Catalyst 4000 L3 Switch Software (cat4000-I9S-M), Version 12.2(18)EW3, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2005 by cisco Systems, Inc.

Compiled Mon 07-Feb-05 19:21 by hqluong

Image text-base: 0x00000000, data-base: 0x010BFA78

ROM: 12.2(20r)EW1

Dagobah Revision 95, Swamp Revision 29

Admin_4506 uptime is 12 minutes

System returned to ROM by reload

System restarted at 00:55:35 UTC Thu Jun 5 2008

System image file is "bootflash:"

cisco WS-C4506 (MPC8245) processor (revision 7) with 524288K bytes of memory.

Processor board ID FOX0929063J

Last reset from Reload

30 Virtual Ethernet/IEEE 802.3 interface(s)

144 FastEthernet/IEEE 802.3 interface(s)

44 Gigabit Ethernet/IEEE 802.3 interface(s)

403K bytes of non-volatile configuration memory.

Configuration register is 0x2101

Jon Marshall Wed, 06/04/2008 - 17:33

Try setting your configuration register to 0x2102. With 0x2101 the switch will load the first image it finds in bootflash and will ignore your boot system variables.

Jon

cowetacoit Wed, 06/04/2008 - 17:50

humm....good idea. Of course i have to wait till tomorrow night to do it. Don't you hate having to do major maintenance after hours!!!!! Any other suggestions?

Jon Marshall Wed, 06/04/2008 - 18:18

Not really. You are going to have reload the switch again anyway. You know that you can set the configuration register from config mode ie.

4500(config)# config-register 0x2102

Jon

cowetacoit Thu, 06/05/2008 - 17:14

Alright, i set my Config-Reg to ox2102, loaded the NEWEST 4506 IOS and it booted to ROMMON. I was running cat4000-i9s-mz.122-18.EW3.bin and upgraded it to cat4500-ipbasek9-mz.122-44.SG.bin. I knew this wouldn't work for some reason. The rommon error said it has to boot with the correct file name, the old said CAT4000 and the new said CAT4500. So now i have 4 images on my switch. How can i safely delete the 3 that i don't need (i tried loading the 2 before the newest) and does anyone have any suggestions on what IOS to load?

Edison Ortiz Fri, 06/06/2008 - 05:21

The rommon error said it has to boot with the correct file name

It means the file name wasn't typed correctly or the location of the file is incorrect.

It happens frequently when you have to type such a long file name.

What I usually do is do a dir in the filesystem and copy and paste the output on the boot system command.

Can you post the dir output along with the boot system command you have in the router config?

As for deleting the images, the command erase followed by the image name should do it.

cowetacoit Fri, 06/06/2008 - 05:24

Sure, Admin_4506#dir

Directory of bootflash:/

1 -rwx 10322612 Aug 25 2005 18:21:27 +00:00 cat4000-i9s-mz.122-18.EW3.bin

2 -rwx 14787732 Jun 5 2008 00:27:41 +00:00 flash

3 -rwx 14787732 Jun 5 2008 00:35:03 +00:00 cat4500-ipbasek9-mz.122-44.SG.bin

4 -rwx 13406880 Jun 5 2008 00:52:42 +00:00 cat4500-ipbase-mz.122-40.SG.bin

61341696 bytes total (8036228 bytes free)

boot system flash cat4500-ipbasek9-mz.122-44.SG

Also i just tried to erase the last 3 in the dir and it wouldn't let me using the command "erase *filename*

cowetacoit Fri, 06/06/2008 - 05:35

erase bootflash:cat4500-ipbase-mz.122-40.SG.bin

This didn't work.

Admin_4506#erase ?

/all Erase all files(in NVRAM)

cat4000_flash: Filesystem to be erased

nvram: Filesystem to be erased

startup-config Erase contents of configuration memory

Correct Answer
Edison Ortiz Fri, 06/06/2008 - 05:37

argh,

try this one:

delete bootflash:cat4500-ipbase-mz.122-40.SG.bin

cowetacoit Fri, 06/06/2008 - 05:40

I actually just tried it.

Admin_4506#delete ?

/force Force delete

/recursive Recursive delete

bootflash: File to be deleted

cat4000_flash: File to be deleted

nvram: File to be deleted

slot0: File to be deleted

Admin_4506#delete bootflash:?

bootflash:cat4000-i9s-mz.122-18.EW3.bin bootflash:cat4500-ipbase-mz.122-40.SG.bin bootflash:cat4500-ipbasek9-mz.122-44.SG.bin

bootflash:flash

ok, so as far as the upgrade....

boot system flash bootflash:cat4500-ipbasek9-mz.122-44.SG.bin

Thanks! I'll try it again tonight.

Edison Ortiz Fri, 06/06/2008 - 05:48

Were you able to delete it?

You can verify by typing dir once again.

How about the boot system command?

Did you modify it per my suggestion?

Noticed, you had the missing location where the file was stored and the ".bin" in the filename was also missing.

Let us know how it goes.

HTH,

__

Edison.

cowetacoit Fri, 06/06/2008 - 06:01

Yes i deleted all but the oldest and the newest.

Directory of bootflash:/

1 -rwx 10322612 Aug 25 2005 18:21:27 +00:00 cat4000-i9s-mz.122-18.EW3.bin

3 -rwx 14787732 Jun 5 2008 00:35:03 +00:00 cat4500-ipbasek9-mz.122-44.SG.bin

61341696 bytes total (8036228 bytes free)

Yes, the boot system flash "filename" you suggested works.

I did delete the file name "flash" as well.

Thanks for your help. I'll try the upgrade when i can have downtime again.

Actions

This Discussion