Publisher/Subscriber sync

Unanswered Question
Jun 4th, 2008

Hi all. I am having an issue getting my publisher and subscriber syncing up. I have had them up at one point, because I saw some route patterns I put in on both of them. But I came in today to work on them, I rebooted the publisher and now I cant seem to get them both to sync up. The Cisco Dirsync is running on the publisher, just not sure what else to look for. Any ideas?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jaime Valencia Wed, 06/04/2008 - 15:41

Dirsync is for the directory, not for CUCM DB.

use admin: utils dbreplication repair all to do so or do the following:

SUBSCRIBERS

admin: utils dbreplication stop

PUBLISHER

admin: utils dbreplication stop

PUBLISHER

admin: utils dbreplication reset all

HTH

javalenc

if this helps, please rate

jjoseph01 Wed, 06/04/2008 - 19:35

Ok, sorry for the delay on this all. My goal here is if the Publisher dies (CUCM 6.1), then the Subscriber takes over without any issue. Well, when I took down the Publisher today (because I changed the default gateway on it), then the Subscriber didnt have the config I had initially put in for route patterns, etc. I had added two phones in on the Pub, but one wouldnt register because it was pointed to the Subscriber as the primary. To troubleshoot, I looked at the Subscriber to see why, and neither phone was there in the phones listing. The first one registered to the Publisher without issue. So, after the Publisher had rebooted and the gateway was correct, I had rebooted the Subscriber and then all was good. But, if the Publisher fails, I want the Sub to take over without issue, and not have to reboot it after the Publisher comes back up. Is there a way that this happens automatically?

jjoseph01 Thu, 06/05/2008 - 11:00

All, I think I got this figured out. I put the sub as the first server, the pub second. I pull the network cable for the sub out, and phones register to pub. Put sub network cable back in and it re-registers to sub. I think this is how it should work. Thanks all.

Actions

This Discussion