Switch port

Unanswered Question
Jun 5th, 2008

Hii...

We have an issue where one of the switch ports(trunk port) was in err-disable state,with indications of loop-back error detected on that.All stuff failed until i made the port portfast enabled and reset the port.this has made it come up.

I am aware that portfast is not to be enabled on trunk, but it was a trial.

Pls suggest how to get this fixed.

Thanks in advance!!!!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 2.5 (2 ratings)
Loading.
a.hajhamad Thu, 06/05/2008 - 11:00

Hi,

STP portFast should be enabled only at access ports only (not trunk), since this command will bypass the listening & learning state and make the port in 2-3 seconds. i.e from blocking to forwarding state immediately.

I recommend not using portfast at trunk port, since when the port in portfast state it will be shift to blocked err-disable when it receive BPDU (mesage from another switch).

And always use this command with spanning-tree portfast:

spanning-tree portfast bpdu-guard

This command will enable PortFast with BPDU guard. This disable the switch port if a BPDU is ever received. preventing any possibility of a loop.

I hope to be helpful!

please rate when done

Thanks

foxbatreco Thu, 06/05/2008 - 13:41

Thanks for the reply..BPDU guard as i know is basically used on access ports to prevent it fr m receiving BPDU eliminating loop factors.

The case here is err-disable port with loopback-error.As i know, dis indicates the keepalive generated is comin back to the same source port.

a.hajhamad Thu, 06/05/2008 - 14:28

BPDU guard is used to prevent loops in case the port is configured with PortFast feature, it will disable the port in case it receives BPDU.

You should not enable PortFast with trunks only it is applied for access port.

Could you please with your switch config and also the Layer2 topolog?

Thanks

rsohi Thu, 06/05/2008 - 14:28

Don't know if this helps: use the no keepalive command? Although this does not get rid of the loop.

%ETHCNTR-3-LOOP_BACK_DETECTED : Keepalive packet loop-back detected on [chars]

Problem

The switch reports this error message, and the port is forced to linkdown:

%ETHCNTR-3-LOOP_BACK_DETECTED : Keepalive packet loop-back detected on [chars]

This example shows the console output that is displayed when this problem occurs:

Oct 2 10:40:13: %ETHCNTR-3-LOOP_BACK_DETECTED: Keepalive packet loop-back detected on

GigabitEthernet0/1

Oct 2 10:40:13: %PM-4-ERR_DISABLE: loopback error detected on Gi0/1, putting Gi0/1 in

err-disable stateDescription

The problem occurs because the keepalive packet is looped back to the port that sent the keepalive. Keepalives are sent on the Catalyst switches in order to prevent loops in the network. Keepalives are enabled by default on all interfaces. You see this problem on the device that detects and breaks the loop, but not on the device that causes the loop.

Workaround

Issue the 'no keepalive' interface command in order to disable keepalives. A disablement of the keepalive prevents errdisablement of the interface, but it does not remove the loop.

rsohi Tue, 06/10/2008 - 16:05

Would it possible to see your topology and/or the config for the trunks?

foxbatreco Wed, 06/11/2008 - 08:29

Roshi..actually i cant provide the configs due to restrictions.

but rest assured i hav done the checks u guys said and the other basic ones..trunks.and all.

I am just supposing how to check on spanning tree issues if any out there which could be causing this.

dgroscost Wed, 06/11/2008 - 15:56

Check your cabling between the two devices and if using modules (SFP, etc.) on the trunk port, verify they aren't damaged.

foxbatreco Mon, 06/23/2008 - 19:26

Guys,

This issue appears to be resolved now..as its not loggin any error messages and the port is stable without goin to err-diasble state again for more than 10 days now.

Tried doin all stuff as suggested by you all, bt still didnt show up anything.

Finally i removed the portfast enable and reset the interface again.After this the port has been fine with no issues for past 10 days.

Thanks to all for the help/views!!!

Actions

This Discussion