MPLS - GRE tunnel routing problem

Unanswered Question
Jun 6th, 2008
User Badges:

Hi,


The problem we have is that the GRE tunnel becomes the primary route when both ciruits are up. EIGRP sees it as a better route over our MPLS circuit.

At the moment we have passived the tunnel interface, but this then doesn't give us the automatic failover we require.


Is there a way that I can make EIGRP see the MPLS circuit as the primary one?


Your help will be much appreciated.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Check your bandwdith and delay settings in your GRE tunnels.


Make your MPLS tunnel the best route from both sides, something like:=


MPLS tunnel

Bandwdith 10240 = 10mbs or whatever the circuit speed is.

delay 500000



Backup tunnel

Bandwidth 10240 = = 10mbs or whatever the circuit speed is.

delay 1000000


With the above - EIGRP will choose the MPLS as it has a lower delay = better route.


These settings must be used at both ends - otherwise you will have asymetric routing, the traffic will go over the MPLS and return on the backup.


HTH.

standardbankcco Fri, 06/06/2008 - 02:53
User Badges:

We have tried this, without any effect.


I believe it is do with getting the route internally over the tunnel, but externally accross the MPLS link.


sh ip route 10.220.1.1

Routing entry for 10.220.1.0/24

Known via "bgp 65011", distance 20, metric 0

Tag 2006, type external

Redistributing via eigrp 100

Advertised by eigrp 100 metric 64 20000 255 1 1500 route-map IST_MPLS_Networks_in

Last update from 146.200.22.53 04:23:52 ago

Routing Descriptor Blocks:

* 146.200.22.53, from 146.200.22.53, 04:23:52 ago

Route metric is 0, traffic share count is 1

AS Hops 2

Route tag 2006



Actions

This Discussion