ACS upgrade from 4.0.x to 4.1.x "Appliance upgrade in progress"

Answered Question
Jun 6th, 2008
User Badges:

Hello friends,


We are in the process of upgrading ACS 4.0 to 4.1 in a SE appliance 1113.


We followed very carefuly the steps, and upgraded de Appliance management ACS 4.1. The second upgrade (Software for appliance 4.1) keeps showing "Appliance upgrade in progress..." (near 2 hours by now). I know that it can stick even finishing, but it seems it has not finished because we can not log in with the GUI Administrator account like we did when upgrading the management software (previous step).


Is this normal? what can be missing?, I attach the console text output below (IP adds obscured).


Note the management upgrade went fine.


Thanks.



---

Cisco Secure ACS: 4.1.1.23

ACS 4.0.1.49-CSAdmin-CSCsd96293_CSCse26719 Fix: (Patch: 4.0.1.49 Tue 01/09/2007

7:50:00.17)

Appliance Management Software: 4.1.1.23

Appliance Base Image: 4.0.1.2

CSA build 4.0.1.543.2: (Patch: 4_0_1_543)


Appliance upgrade in progress...


Session Timeout: 10

Last Reboot Time: Fri Jun 06 11:46:40 2008


Current Date & Time: 6/6/2008 13:17:40

Time Zone: (GMT-05:00) Bogota, Lima, Quito

NTP Server(s): 131.107.1.10


CPU Load Free Disk Free Physical Memory

0.00% 16.9 GB 765 MB


Appliance IP Configuration

DHCP Enabled. . . . . . . . . . .: No

IP Address. . . . . . . . . . . .: 172.16.x.y

Subnet Mask . . . . . . . . . . .: 255.255.255.0

Default Gateway . . . . . . . . .: 172.6.x2.y2

DNS Servers . . . . . . . . . . .: 172.16.x3.y3

CSAdmin running

CSAuth running

CSDbSync running

CSLog running

CSMon running

CSRadius running

CSTacacs running


CSAgent stopped


Appliance upgrade in progress...

---


Correct Answer by Jagdeep Gambhir about 8 years 9 months ago

Do not worry, the upgrade is over. After issuing that command, please reload the acs appliance.


It will surely come up with new software.



Regards,

~JG

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Jagdeep Gambhir Fri, 06/06/2008 - 10:33
User Badges:
  • Red, 2250 points or more

Form console issue command,


download x.x.x.x


where x is any IP (fake or real)


That will fix it.



Regards,

~JG


Do rate helpful posts

martinv2008 Fri, 06/06/2008 - 13:37
User Badges:

Thanks Jagdeep, but the upgrade has not finished.


The documentation mentions (please read it carefully):

"IF YOU COMPLETE THE UPGRADE and the ACS console displays the message Appliance upgrade in progress, this indicates that the upgrade PROGRESS is hanging.

If this condition occurs, start an ACS console session and enter the command download [hostAddress], where hostAddress can be any IP address. This action releases the ACS console from the upgrade process."


What worries me is that it has not finished.

As I said in my post, we can not log in :( (the GUI gets blocked during the upgrade).


I appreciate the help. Many Thanks.

Correct Answer
Jagdeep Gambhir Fri, 06/06/2008 - 14:31
User Badges:
  • Red, 2250 points or more

Do not worry, the upgrade is over. After issuing that command, please reload the acs appliance.


It will surely come up with new software.



Regards,

~JG

martinv2008 Fri, 06/06/2008 - 15:23
User Badges:

The recommended reload is restarting every service?


or is it enough with:


> restart CSAdmin


thanks

stephenwa Fri, 06/06/2008 - 14:43
User Badges:

I encountered the same exact issue when upgrading our SE 1112 from 4.0.1 (42) to 4.1.1.23. I ulitmately had to create a recovery disk and re-image the SE. After that I had to perform a restore from the backup I took before I started. You will also need to install patch 5 to the SE as well as to any Remote Agents, if applicable.


Good luck.

martinv2008 Fri, 06/06/2008 - 15:01
User Badges:

Thanks a lot guys,


Jagdeep, thanks, I'll try it.

stephenwa, thanks, that's the version we are upgrading. Let's hope no re-imaging will be needed.


Many thanks.

stephenwa Fri, 06/06/2008 - 15:03
User Badges:

Don't forget the patch, you'll need it if you are doing any AAA command accounting.

martinv2008 Fri, 06/06/2008 - 15:51
User Badges:

where did you get that patch?


I'm still in the 2nd upgrade.

Then the Ms.Hotfixes step will come. With a re-image after all the upgrades according to the doc.

stephenwa Fri, 06/06/2008 - 16:51
User Badges:

I got it on CCO, under SW Dowloads/Security.


Look for 4.1.1.23.5 and 4.1.1.23.5-RA (remote agent).. Don't forget to get the readme files also.


If you can't find them, open a TAC case and ask the Engineer to publish them.


Basically you have to install 4.1.1.23 and then apply the patch on over it.


Regards,

Actions

This Discussion