Console Cable for 1600/2621/3640 Routers

Unanswered Question
Jun 7th, 2008


I've got three routers I need to reset and configure - a 1601, 2621 and a 3640. I'm using a Cisco console cable (RJ45-DB9), and one other cable that I made myself and verfied as working on a Catalyst 4006.

When I plug into any of the routers I get the full boot output as usual - however, I cannot send any data to the routers. No breaks, no input, nothing.

My HyperTerminal, PuTTY and minicom settings are 9600 8N1 with hardware flow control. Am I doing something wrong or are the cables to blame?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Richard Burts Sat, 06/07/2008 - 18:42


I am not sure that we have enough information to be able to really answer your question yet. Has the console cable worked before? (on these routers or on any other router?) Your post indicates that the cable that you made has worked before - right?

I doubt that it is a cable issue. Especially given that output is carried over the cable and it seems that the problem is with input on the cable. While there might be a problem just with input I think it not likely.

Given the description of the problem I would guess that the console may have been configured with no exec. Configuring no exec will prevent an exec process from starting on the console and that is the process that accepts your input and sends your output. The messages that you are getting are system log messages and are not related to exec.

I have a couple of suggestions for how you might solve this:

- try access through the aux port. Depending on how the routers were configured you might be able to get access through the aux port. If you can get access through the aux then see if you can get into privilege mode. If you can get into privilege mode then go into config t and enter:

line con 0



and then see if the console works.

- if the aux does not work then try connecting to the network interfaces of the router, assign an address in the subnet of the router interface to which you connect, and see if you can telnet. If you can telnet then go through config t and configure exec on the console.

- if neither aux or telnet work then you should try the password recovery procedure. Boot the router, as it boots hit the break key to get into rommon, change the config register to 0x2142, and cycle the router. If my theory is correct then the console should start to work. At that point just set the config register to 0x2102 and the router is reset.

[edit] in reading the original post again I see that you have configured your terminal emulators with hardware flow contol. You should change this to no flow control. The console port of the Cisco router does not provide flow control.



srue Sat, 06/07/2008 - 19:39

is it possible that someone changed the console line speed?

try changing your terminal settings from 9600 to all the other possibilities.

a little more than half way down that page, there are instructions to change the console speed from rommon. maybe someone did this?

on second that, i'm not even sure you get output if you change that speed, so that may or may not be the issue.

danclough Sat, 06/07/2008 - 20:18

I tried changing the baud rates, but stepping down to 4800 or up to 19200 resulted in no output, so I decided not to try any other speeds.

danclough Sat, 06/07/2008 - 20:12


I've followed your advice regarding disabling Hardware Flow Control. Unfortunately it did not change my circumstances. Also, trying to enter RomMon by sending a break through Hyperterminal and PuTTY was unsuccessful.

To answer your first question, the cable that I made functions flawlessly on a Catalyst 4000 switch with a Supervisor II module. The official Cisco console cable I have did not appear to work with the Catalyst, which is odd. Both cables exhibit the same symptoms on my routers, so I'm positive it must be an emulation issue. What should I set the emulation to? It's currently ANSI.

I have no means of connecting to the Aux port. I'm fairly sure that these routers' configs were cleared before I received them. I haven't been able to log in or see any configuration details so I'm flying blind.

Thanks for your suggestions. Got anything else in mind?

Richard Burts Sun, 06/08/2008 - 12:59


I do not have much experience with the 1601 and the documentation I looked at for it looks like it does not have an aux port. So I guess no aux access for the 1601.

the 2621 and the 3640 do have an aux port and it can be accessed by the same cable that you use for the console.



danclough Sun, 06/08/2008 - 13:27


I connected to the aux port using the console cable and it doesn't seem to be working. Does the aux port function like the console port? I ask because it doesn't output anything. I tried placing a null modem adapter on the line but it didn't work, either.

I'm pretty sure that the configs were cleared, as the 3640 asks me if I want to enter the initial system configuration once the booting is done.

Richard Burts Sun, 06/08/2008 - 14:53


Especially for the purpose of this conversation the main difference in operation of the console and the aux is that while the console is active during the boot process and will accept input before the router becomes fully active, the aux port does not start to work (accept input) until the router has completed the boot process and is fully active.

If the router asked if you want to enter the initial system configuration then the aux will not work on that router.

It is most unfortunate that the routers will not accept a break during the boot process. There is one trick that I would suggest that you might try to get the router into rommon so that you can change the config register. Power off the router, then set the speed of your terminal emulator to 1200, start the emulator, power up the router, while the router is booting hold down the space bar. When the router has completed booting, change the speed of your emulator to 9600 and start another session to the console. Sometimes when operating at very low speed, sending spaces to the console will look like the break character.




This Discussion