AP1240 problem

Unanswered Question
Jun 8th, 2008

hi..

Do you have any idea why the radio will disable after i configure the AP1240 as workgroup bridge?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
kamarul83 Mon, 06/09/2008 - 17:56

First of all, thanks for your reply.

After I configured the AP1240, the software status still disabled and the hardware still down.

FYI, I have two of AP1240 and one 1300 Series Outdoor. For the AP1240, i configured as WGB and 1300 as Access Point.

Before this, all device working properly until last month. The AP1240 doesnt work but the 1300 Outdoor still working properly.

Did you have any idea what happen to my AP1240?

kamarul83 Mon, 06/09/2008 - 22:23

First of all, thanks for your reply.

After I configured the AP1240, the software status still disabled and the hardware still down.

FYI, I have two of AP1240 and one 1300 Series Outdoor. For the AP1240, i configured as WGB and 1300 as Access Point.

Before this, all device working properly until last month. The AP1240 doesnt work but the 1300 Outdoor still working properly.

Did you have any idea what happen to my AP1240?

kamarul83 Tue, 06/10/2008 - 00:39

Below is the configuration that i copy for config.txt

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ap

!

enable secret 5 $1$Gl9g$EL6iBO/Yfu.fskfJiY1rI.

!

ip subnet-zero

ip domain name m

!

!

no aaa new-model

!

dot11 ssid Myport

authentication open

!

power inline negotiation prestandard source

!

crypto pki trustpoint TP-self-signed-1842759256

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1842759256

revocation-check none

rsakeypair TP-self-signed-1842759256

!

!

crypto ca certificate chain TP-self-signed-1842759256

certificate self-signed 01 nvram:IOS-Self-Sig#3601.cer

username Cisco password 7 032752180500

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

ssid Myport

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role workgroup-bridge

infrastructure-client

bridge-group 1

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

shutdown

speed basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

bridge-group 1

bridge-group 1 spanning-disabled

hold-queue 160 in

!

interface BVI1

ip address 192.168.1.134 255.255.255.0

no ip route-cache

!

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

!

!

control-plane

!

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

login local

!

end

kamarul83 Tue, 06/10/2008 - 01:11

I'm sorry. I'm not really understand. Could you please explain it to me?

kamarul83 Tue, 06/10/2008 - 01:30

I've already select enable for the radio but the radio still =disable/down.

Below is the config;-

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ap

!

enable secret 5 $1$Gl9g$EL6iBO/Yfu.fskfJiY1rI.

!

ip subnet-zero

ip domain name m

!

!

no aaa new-model

!

dot11 ssid Myport

authentication open

!

power inline negotiation prestandard source

!

crypto pki trustpoint TP-self-signed-1842759256

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1842759256

revocation-check none

rsakeypair TP-self-signed-1842759256

!

!

crypto ca certificate chain TP-self-signed-1842759256

certificate self-signed 01 nvram:IOS-Self-Sig#3601.cer

username Cisco password 7 032752180500

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

ssid Myport

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role workgroup-bridge

infrastructure-client

bridge-group 1

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

shutdown

speed basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

bridge-group 1

bridge-group 1 spanning-disabled

hold-queue 160 in

!

interface BVI1

ip address 192.168.1.134 255.255.255.0

no ip route-cache

!

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

!

!

control-plane

!

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

login local

!

end

kamarul83 Tue, 06/10/2008 - 01:41

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ap

!

enable secret xxx

!

ip subnet-zero

ip domain name m

!

!

no aaa new-model

!

dot11 ssid client

authentication open

!

power inline negotiation prestandard source

!

crypto pki trustpoint TP-self-signed-1842759256

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1842759256

revocation-check none

rsakeypair TP-self-signed-1842759256

!

!

crypto ca certificate chain TP-self-signed-1842759256

certificate self-signed 01 nvram:IOS-Self-Sig#3601.cer

username Cisco password xxx

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

ssid client

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role workgroup-bridge

infrastructure-client

bridge-group 1

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

shutdown

speed basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

bridge-group 1

bridge-group 1 spanning-disabled

hold-queue 160 in

!

interface BVI1

ip address 192.168.1.134 255.255.255.0

no ip route-cache

!

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

!

!

control-plane

!

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

login local

!

end

kamarul83 Tue, 06/10/2008 - 02:01

oh. i'm sorry. i thought you want me to change the SSID. Do you mean the Client Authentication Setting?

kamarul83 Tue, 06/10/2008 - 02:14

FYI, for the primary AP (1300 series outdoor)still on the site.

below is current 1240AP:-

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ap

!

enable secret xxx.

!

ip subnet-zero

ip domain name m

!

!

no aaa new-model

!

dot11 ssid client

authentication open

!

power inline negotiation prestandard source

!

crypto pki trustpoint TP-self-signed-1842759256

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1842759256

revocation-check none

rsakeypair TP-self-signed-1842759256

!

!

crypto ca certificate chain TP-self-signed-1842759256

certificate self-signed 01 nvram:IOS-Self-Sig#3601.cer

username Cisco password 7 032752180500

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

ssid client

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role workgroup-bridge

infrastructure-client

bridge-group 1

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

shutdown

speed basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

bridge-group 1

bridge-group 1 spanning-disabled

hold-queue 160 in

!

interface BVI1

ip address 192.168.1.134 255.255.255.0

no ip route-cache

!

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

!

!

control-plane

!

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

login local

!

end

OK - so I have been in my lab and found the following that would create the same situation that you are seeing:-

1) The radio interface on the root AP is down - then the workgroup ap radio interface would not come up.

2)The radio interface on the root AP as an ssid - then the workgroup ap radio interface has a different ssid in the radio interface, then it would not come up.

3) The radio interface on the root AP has encryption enabled - then the workgroup ap radio without the same encryption on the interface would not come up.

4) The radio interface on the root AP has encryption enabled, with a pre-shared key - then the workgroup ap radio with the same encryption but no pre-shared key on the interface would not come up.

5) The workgoup bridge AP is not close enough to the current root AP.

The above is all I could test in my lunch hour.

HTH.

kamarul83 Wed, 06/11/2008 - 01:16

Thanks.

I will let you know if i have a AP1300 Series configuration.

Also keep you update if there have a improvement of AP1240.

tonyspcrepairs Sat, 06/14/2008 - 12:59

andrew I wanted to say thanks for posting this link. I've been wrestling for hours with my AP1242AG access point and could not get it to work as a bridge but the link you gave cleared it all up.

Cheers, Tony

Actions

This Discussion