B-ACD with FXO problem

Unanswered Question
Jun 9th, 2008

Hello guys,

I've tried to use B-ACD with FXO port and it seems working differently than with PRI. When I call in I can't hear welcome prompt and also script doesn't respond to any keypresses. After some time I hear the message "You've entered an invalid option, please try again. For sales press...". And after that I can press options to dial by extension or to reach the queue. With PRI port at the same router it works fine.

Does anybody have ideas why this happens?



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
ashok_boin Mon, 06/09/2008 - 02:51

Hi Yuri,

I have not seen any specific reference for Welcome script in Parameters section so it is trying to use default "en_bacd_welcome.au" file. So, either this file is corrupted or not available.

If you are trying to put your customized Welcome script, then record your own file & refer explicitly with "param welcome-prompt _bacd_welcome.au" command under "service aa" command.

And try to restart the audio file with

"Router# audio-prompt load flash:en_bacd_welcome.au

Reload of flash:en_bacd_welcome.au successful


Hope the following link helps...


privateer Mon, 06/09/2008 - 03:15

Thank you for reply Kumar.

B-ACD works fine when call comes through PRI on the same router. So I think corrupted prompt is not the case here. Also I think without param welcome-prompt command the default on is used. Anyway I tried both of your suggestions and it didn't helped.

Paolo Bevilacqua Mon, 06/09/2008 - 03:34

Can you collect output of "debug voice application script" and "debug voice application media status" with "term mon" and send them here.

privateer Mon, 06/09/2008 - 23:00

Hi Paolo,

Here are the debugs. Fist one is successul where I used dial by extension option to dial internal number 1001. Second one is unsuccessul. I tried to choose menu options 1, 2 and 3 and script didn't respond. Then I waited for some time and heared the message "You've entered an invalid option...". After that I successfuly dialed internal number 1001 using menu option 1.

Paolo Bevilacqua Tue, 06/10/2008 - 02:25


the debug doesn't reveal anything strange.

I don't know what to suggest, which exact IOS are you using ?

privateer Tue, 06/10/2008 - 02:32

I've tried the following versions:



Results are the same.

Anyway thank you.

ashok_boin Mon, 06/16/2008 - 21:20


The only difference I could able to observe in the debugs comparing both files is...

"*Jun 10 06:49:50.981: //-1//TCL :EE463877CC000:/tcl_PutsObjCmd: TCL AA: -- max-extension-length is set to default value of 5 --

*Jun 10 06:49:50.981: //-1//TCL :EE463877CC000:/tcl_PutsObjCmd: TCL AA: -- Mandatory parameter second-greeting-time does not exist --

*Jun 10 06:49:50.981: //-1//TCL :EE463877CC000:/tcl_PutsObjCmd: TCL AA: -- Setting default to 60

*Jun 10 06:49:50.985: //-1//TCL :EE463877CC000:/tcl_PutsObjCmd: TCL AA: -- Valid mandatory parameter call-retry-timer = 5 --

*Jun 10 06:49:50.989: //-1//TCL :EE463877CC000:/tcl_PutsObjCmd: TCL AA: -- Valid mandatory parameter max-time-call-retry = 600 --

*Jun 10 06:49:50.989: //-1//TCL :EE463877CC000:/tcl_PutsObjCmd: TCL AA: -- Valid mandatory parameter max-time-vm-retry = 2 --

*Jun 10 06:49:50.993: //-1//TCL :EE463877CC000:/tcl_PutsObjCmd: TCL AA: -- Valid Mandatory parameter number-of-hunt-grps = 2 --"

which are not reflecting in "unsuccessful.txt". I am not sure whether these timers are mandatory.


privateer Tue, 06/17/2008 - 04:42

Thank you guys.

Now I am troubleshooting it with Cisco TAC. I'll post results here.


This Discussion