DHCP over L3 MPLS VPN

Unanswered Question
Jun 9th, 2008

how to configure a L3 MPLS VPN over which DHCP should get accessed. I have created L3 MPLS VPN between 2 locations. In locaton "A" DHCP server is located and at Location "B" DHCP client is located. As per the requirement client host should get the ip address from the DHCP server.

I configured the PE router which is at client side as DHCP Relay agent but no result. the main problem is i don't know the trouble shooting commands using which i can come to know where the problem is exactly.

I don't have proper material also for the entire configuration and trouble shooting....

if any body have the configuration plz provide me....

Regards,

RAj

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.7 (3 ratings)
Loading.
DishnetWireless... Mon, 06/09/2008 - 23:16

Hi Niranjan,

Thanks for your document, but this document shows only how to configure can you plz provide any document which shows how to trouble shoot..

Just for testing sake i connected both DHCP Server and the client to the same PE router.

i kept both server and client in the same vrf and configured the helper address in the interface facing towards client.

when i enaled debug in PE as well as DHCP server,what i noticed is client is sending the DHCP request but from the debug information of DHCP server there is no hit of DHCP request.

plz find below mentioend debug info of PE router..

Jun 7 07:49:06.915: DHCPD: table id 66 = vrf Dhcp_HYD

*Jun 7 07:49:06.915: DHCPD: Selected subnet=1.1.1.0

*Jun 7 07:49:06.915: DHCPD: Server-id-override=1.1.1.1

*Jun 7 07:49:06.915: DHCPD: giaddr changed to 192.168.3.2

*Jun 7 07:49:07.759: DHCPD: Sending notification of DISCOVER:

*Jun 7 07:49:07.759: DHCPD: htype 1 chaddr 0011.5c32.7ec0

*Jun 7 07:49:07.759: DHCPD: remote id 020a0000c0a80201f7000000

*Jun 7 07:49:07.759: DHCPD: circuit id ffffffff

configuration :

dhcp relay information option vpn

ip vrf Dhcp_HYD

rd 10201:307

route-target export 10201:307

route-target import 10201:307

interface GigabitEthernet1/29

description ### DHCP SERVER PORT ###

ip vrf forwarding Dhcp_HYD

ip address 192.168.3.2 255.255.255.0

interface FastEthernet2/1

description ### TESTING ###

ip vrf forwarding Dhcp_HYD

ip address 1.1.1.1 255.255.255.252

ip helper-address 192.168.3.1

DHCP SERVER IP ADDRESS : 192.168.3.1

n.nandrekar Tue, 06/10/2008 - 00:02

hi!

Under int fa2/1, can you try the command as,

# ip helper-address vrf Dhcp_HYD 192.168.3.1

I think that without the vrf option the helper address might be looked up in the global table. Not very sure. The config doc provides with this detail.

I am sorry but i dont have an troubleshooting doc for this specific feature. I guess you will have to apply regular DHCP / mplsvpn toroubleshooting skills to find the problem.

Verify through counters / span of whether the request is forwarded to the server thru gi1/29, and what are the addresses set in that.

Regards,

Niranjan

kjarri Tue, 06/10/2008 - 03:12

Hi,

The 'vrf VRF-A' after the ip helper-address disappears if its the same VRF as the interface is.

But the command syntax is correct. it should be

!

interface Ethernet1

ip vrf forwarding VRF-A

ip address 1.2.3.4 255.255.255.0

ip helper-address 192.1.1.2

!

for example..

DishnetWireless... Tue, 06/10/2008 - 22:00

Hi Niranjan,

As kjarri said, The 'vrf after the ip helper-address disappears if its the same VRF as the interface is.

Regards,

RAj

n.nandrekar Tue, 06/10/2008 - 22:24

Ok. So were you able to troubleshoot as per my earlier post to see at which point it is failing. Whether the request is sent to the server, whether the server is responding and if the response is getting dropped, the ip addresses in the request response... if they are as expected?

Regards, Niranjan

DishnetWireless... Wed, 06/11/2008 - 06:16

Hi Niranjan,

DHCP Server is not receiving Discover messages

there is no debug information generated in DHCP server as it is not even receivn the hit of DHCP request....

http://www.cisco.com/en/US/docs/ios/12_2t/12_2t8/feature/guide/ftdhmpls.html

more over i noticed from cisco document ( link is mentioned above) that 7606 Router platform will not support DHCP relay agent over MPLS VPN.. pls put ur comments on this..

Regards,

RAjesh.M

n.nandrekar Thu, 06/12/2008 - 08:56

hi Raj!

DHCP Relay Agent - MPLS vpn support is not present in the 7600 / 6500 series. You wont be able to use this feature on these devices if you are planning to do so.

The link you mentioned doesnot show these devices under supported platforms and I also checked in the feature navigator.

Regards,

Niranjan

Actions

This Discussion