Rob Huffman Mon, 06/09/2008 - 04:24
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Dave,


Hope things are going well with you! You can only use BARS with the exact same CCM Version (including SR's), so this won't work :(


This will have to be done in multiple stages to be supported. Stage 1 will be building CCM 4.0(x) on the new Hardware with a BARS Restore (no BARS issues) then upgrading to CCM 4.3(1).If you don't want to go that way you could do the upgrade to 4.3(1) on the existing servers and then do a 4.3(1) rebuild/restore on the new boxes with the proper BARS (4.3(1)) Backup. Either way would work just fine :)


Here is a nice Step by Step Guide;


Upgrading Cisco CallManager Release 4.3(1)


Replacing Servers During the Upgrade


http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/upgrade/4_3_1/replace.html


Hope this helps!

Rob

Rob Huffman Mon, 06/09/2008 - 08:52
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Dave,


I'm not sure exactly what they mean by that reference in Table 5 ?? But I do know that a BARS Restore checks to make sure that CCM versions match including SR's. If there is a version mismatch the restore will fail for sure. Here is one such reference;


***Note: If the backed-up version of Cisco Unified CallManager does not match the version that is current running in the cluster, you cannot perform a BARS restore. In this situation, you must reinstall Cisco Unified CallManager on every server in the cluster and proceed to reconfigure the system manually.***


http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/bars/4_0_12/restore1.html


Hope this helps!

Rob

Jaime Valencia Mon, 06/09/2008 - 09:13
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

yes you can, at certain point during the CUCM 4.3(1) install you will be prompted whether it will be a new install or an upgrade, if you select upgrade it will ask for the backup file to restore the data.


similar process to a 5.x or 6.x process since it requires a new install because there is no upgrade to 2003.1.1


HTH


javalenc


if this helps, please rate

Rob Huffman Mon, 06/09/2008 - 09:34
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Dave/Jaime,


Dave, I did not realise this had ever changed ( I'm a fool) but this does work more like a 5.x or 6.x upgrade using the BARS .tar file WOW!!. Jaime, this is really quite the cool method (+5 points for this excellent info;


Dave here is the section of the install that refers to this;


Step 10 In the Server type window, choose the Publisher radio button and click Next.


Step 11 In the Install type window, choose the Upgrade from 3.3, 4.0, 4.1, and 4.2 release radio button, enter the path to the Cisco Unified CallManager backup file in the Backup Archive File field, and click Next.


The system validates the archive file.



http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/upgrade/4_3_1/upgrfrom.html#wp1039540


You learn something new every day :)


Rob

Jaime Valencia Mon, 06/09/2008 - 09:49
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

indeed Rob =) we had quite a hard time when 4.3(1) was released because the guides were not consistent on which upgrade method should be used. initially the old process of migrate same version to new HW and upgrade was mentioned, but other guides mentioned "no upgrade to 2003.1.1" so we were like: mmm, ok, 2003.1.1 only supports 4.3(1) and new installs... but i need to install an older version... so... mmm how am i supposed to do this???? i cannot install an older OS because i cannot upgrade!!!


then later the guides were updated to show that the upgrade process was to take the backup file and during the install you would be prompted for it to migrate the data.


personally i haven't worked with this version more than 10 minutes and since the upgrade process is quite similar to linux versions i usually recommend everyone to go to a 5.x or even better a 6.x if i need to do the same stuff for the install or upgrade with 4.3 than with later versions.


javalenc

Actions

This Discussion