QOS & ATM on 7206vxr

Unanswered Question
Jun 9th, 2008

I have setup "ip nbar protocol discovery" on the input interfaces, I have set up Class-map's and I have created the Policy-maps but when I apply them to the WAN (ATM sub-interface) I get the message "GTS : Not supported on this interface"

How do I get the WAN interface to shape traffic ?

The interface hardware is PA-A3, the config for the sub-interface is

interface ATM3/0.36 point-to-point

description PVC ->inverness-gw

bandwidth 39000

ip address 10.254.10.2 255.255.255.252

ip ospf cost 100

atm pvc 36 0 36 aal5snap 39000 35000 inarp oam 10

end

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Mon, 06/09/2008 - 08:21

Beside nbar (that often is unable to classify properly) can you clarify what is that you want to shape and how you tried to do so ?

Also recommend you use the newer command "pvc 0/3" and "vbr" under it to configure an ATM PVC. You don't need inarp for a p-t-p link.

tomredmond Tue, 06/10/2008 - 00:16

I created the class-maps and policy-maps given below, I them applied them to the interface with the command "service-policy output QoS-Policy-2" . I am trying to create a general prioritisation scheme on the network as we have a mixed bag of traffic types, fairly high utilisation and our VC and telephone traffic is suffering.

class-map match-any Transactional-1

match protocol finger

match protocol notes

match protocol novadigm

match protocol pcanywhere

match protocol secure-telnet

match protocol sqlnet

match protocol sqlserver

match protocol ssh

match protocol telnet

match protocol xwindows

match protocol citrix

class-map match-any Signaling-1

match protocol h323

match protocol rtcp

match protocol sip

class-map match-any Routing-1

match protocol bgp

match protocol egp

match protocol eigrp

match protocol ospf

match protocol rip

match protocol rsvp

class-map match-any Voice&Video-1

match protocol rtp audio

match protocol h323

match protocol rtp video

class-map match-any Management-1

match protocol dhcp

match protocol dns

match protocol imap

match protocol kerberos

match protocol ldap

match protocol secure-imap

match protocol secure-ldap

match protocol snmp

match protocol socks

match protocol syslog

class-map match-any voice

match protocol rtp

!

!

policy-map QoS-Policy-1

class Voice&Video-1

set dscp ef

priority percent 33

class Signaling-1

set dscp cs3

bandwidth percent 5

class Routing-1

set dscp cs6

bandwidth percent 5

class Management-1

set dscp cs2

bandwidth percent 5

class Transactional-1

set dscp af21

bandwidth percent 5

class class-default

fair-queue

random-detect

policy-map QoS-Policy2

class class-default

shape average percent 100

service-policy QoS-Policy-1

Paolo Bevilacqua Tue, 06/10/2008 - 02:47

Hi, beside that your policy map appears to be an overkill, you should configure the pvc as suggested above. After that you will be able to attach a policy map to it.

Joseph W. Doherty Tue, 06/10/2008 - 04:58

I'll confirm both Paolo's posts. Have used service policies within ATM PVC as he describes.

What may not be clear, with what Paolo is suggesting, you also get an implicit shaper, although I believe its FIFO, but that's where the policy comes in.

I also agree with Paolo your policy might me a bit of "overkill", looks like something Enterprise AutoQoS would generate.

If some real-time traffic is the issue, drop it into a LLQ and everything else WFQ.

E.g. (pseudo config)

class-match match-all real-time

match (your real-time traffic - could be nbar protocol, could be dscp, could be acl)

policy-map cbwfq

class real-time

priority percent 30

class class-default

fair-queue

atm #/# point-to-point

ip address ...

pvc #/#

vbr-nrt (pvc's pcr/scr/burst)

service-policy output cbwfq

PS:

BTW: you don't need NBAR protocol-discovery to use NBAR to match; protocol-discovery is used to gather NBAR analysis traffic stats

Actions

This Discussion