Convert config from Hybrid to Native wiht CatOS tool

Unanswered Question
Jun 9th, 2008

Testing the waters to convert my 6513 hybrid config to a Native config. Cisco has a Catos-to-IOS converter. I ran it and can't see how this thing is going to work.

Below is what It translated just one port to native OS. This is a switchport on vlan24.

interface GigabitEthernet11/33

dot1x timeout quiet-period 60

dot1x timeout tx-period 30

dot1x timeout supp-timeout 30

dot1x timeout server-timeout 30

dot1x max-req 2

dot1x reauth-period 3600

switchport

no l2protocol-tunnel

no ip rgmp

channel-protocol pagp

no mls qos statistics-export

switchport

switchport trunk native vlan 24

switchport voice vlan none

power inline auto max 15400

no mls qos trust extend

mls qos trust extend cos 0

no shutdown

speed auto

no snmp trap link-status

description dmoore

storm-control broadcast level 0

flowcontrol send desired

flowcontrol receive off

no udld port

no udld port aggressive

switchport trunk allowed vlan remove 1006-1023

no switchport port-security

switchport port-security maximum 1

switchport port-security violation shutdown

dot1x port-control force-authorized

no dot1x host-mode multi-host

spanning-tree portfast

spanning-tree mst 0 port-priority 32

spanning-tree mst 0 cost 20000

spanning-tree cost 4

spanning-tree port-priority 32

spanning-tree vlan 1,5-6,15-16,19-20,24,100,251 port-priority 0

spanning-tree vlan 1,5-6,15-16,19-20,24,100,251 cost 3

spanning-tree guard none

mls qos cos 0

no mls qos trust cos

no mls qos vlan-based

no switchport mode dot1q-tunnel

no l2protocol-tunnel cdp

no l2protocol-tunnel stp

no l2protocol-tunnel vtp

ip arp inspection limit rate 0

no ip arp inspection trust

no link debounce

switchport block unicast

mdix auto

=============

This port is not a trunk. Why doesn't it put the commands of

switchport mode access

switchport access vlan 24

The above would put the port on Vlan24.

Also my config for native is about 1.3megs and about 50,000 lines.

What am I missing here? is there something I can do in CatOS to better prep my NativeOS config and keep out clutter?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
hadbou Fri, 06/13/2008 - 05:54

The need for configuration management, as well as network migration systems, mandates differentiated configuration applications in order to handle complex network transitions. The Cisco EDI CatOS to IOS Configuration Conversion Tool enables you to translate Cisco Catalyst Operating System (CatOS) configurations to equivalent supported Cisco IOS® configurations.

Refer the following url for more information on "How to Convert a Catalyst 6500/6000 Supervisor Engine from Hybrid Mode (CatOS) to Native Mode (IOS) Using a Conversion Utility":

http://www.cisco.com/en/US/products/hw/switches/ps708/products_tech_note09186a008070f124.shtml

dmooreami Fri, 06/13/2008 - 06:16

Thanks for the link, but no way do I trust a utility to convert over Sups from hybrid to native. Plus, I am going from a Sup2 to a sup32. Sup32 modules are in totally different slots, etc.

But maybe I can salvage some of this to at least convert the CATOS to native OS without having to get my actual switch involved.

dmooreami Fri, 06/13/2008 - 06:22

Plus, I think just automates the conversion of the OS to IOS from catOS, it doesn't convert my CATOS config to a native IOS config.

Actions

This Discussion