Network Topology Telnet close window campus manager 4.0.0

Unanswered Question
Jun 9th, 2008

When I right click on a device in Network Topology and select Telnet, I get a message box "the web page you are viewing is trying to close the window" With Ok and Cancel buttons. I can't figure out how to allow Ciscoworks to close the window with out the dialog box... HELP :)

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Joe Clarke Mon, 06/09/2008 - 13:09

This is really Campus Manager 4.0.0, LMS 2.5? If so, that is very old. You need to upgrade to LMS 2.6. That said, this really sounds like Campus 5.0, and this bug was been fixed if you upgrade to LMS 3.0.1 and CM 5.0.3.

jbarger Mon, 06/09/2008 - 13:12

Sorry I confused things by putting the CM version and not the LMS verison.

Here are the versions I am running...

1. LMS 3.0.1 28 Apr 2008

1. CiscoWorks Common Services 3.1.1 01 May 2008, 11:39:22 MDT

2. Campus Manager 5.0.3 01 May 2008, 16:57:29 MDT

3. CiscoView 6.1.7 01 May 2008, 11:39:30 MDT

4. CiscoWorks Assistant 1.0.1 01 May 2008, 11:39:30 MDT

5. Device Fault Manager 3.0.3 09 Jun 2008, 13:45:42 MDT

6. Internetwork Performance Monitor 4.0.1 01 May 2008, 11:39:36 MDT

7. Integration Utility 1.7.1 01 May 2008, 11:39:39 MDT

8. LMS Portal 1.0.1 01 May 2008, 11:39:40 MDT

9. Resource Manager Essentials 4.1.1 01 May 2008, 11:39:42 MDT

The CM version I copied from the home page of CM... silly how much is wrong here :)

Joe Clarke Mon, 06/09/2008 - 13:35

Okay, so you have the bug fix. You now need to make sure your browser is properly configured to handle telnet: URIs. One Windows, it is typically desirable to have the browser launch telnet.exe.

jbarger Mon, 06/09/2008 - 13:56

I have checked the telnet default setting in the registry. Telent works just fine from a URL.

I didn't mention that telnet works. I should have. The new browser window appears with Opening telnet to and the dialog box on top of it... With my telnet appliaction sometimes in the background or in the forground not focused... and an orange blinking bar from IE trying to steal focus with the dialog box. YUCK!!!!

The problem seems to be that the browser is annoyed that some other program/script is trying to close the window. When searching the web for "the web page you are viewing is trying to close the window" it seems lots of scripts suffer from this noise.

I have tried to figure out if there is a security setting that would let Ciscoworks be trusted by IE and have not.

I have other reasons that I want to stay on IE for but god I wish I didn't... And thank you for your help BTW!

Joe Clarke Mon, 06/09/2008 - 14:49

What I've done with IE is to make the LMS server a trusted site, then set my trusted site security level to low. However, this doesn't work for this page due to what I feel is an IE 7 bug. The page isn't detected as a trusted site until you refresh it. that is, if you answer No to the prompt, then refresh the page, the window will close without asking you. I couldn't find a way to fix this, but Microsoft might be able to help you out.

jbarger Tue, 06/10/2008 - 07:29

Well it could be easily fixed in the code that cisco wrote... Where is the right click menu generated :). I have looked for it before and didn't find it.

I would modify the code myself. I would rather use ssh but hate that cworks asks for a username. SecureCRT can store username and pass so I would modify SSH and fix telnet also. No I would not ask cisco to support it. I'd just make backups of the files and document how I made the change so I could upgrade and re-apply my changes. Anyhow what a bother. Ciscoworks is much better than it was but still I would rather have configurable network topology instead of a floating toolbar dashboard...

Once again thanks for your help.

Joe Clarke Tue, 06/10/2008 - 07:40

Unfortunately, this is not possible. This solution is Microsoft-only, and this page is auto-generated, so turning into a VBScript application just isn't going to happen. What would be nicer for this particular problem is for IE to allow trusted sites to close their own windows using Javascript.

As for the SSH issue, again we had to consider portability when designing it. Some SSH clients, most notably OpenSSH and commercial SSH for UNIX require the username be passed on the command line. Since there were Windows clients like PuTTY which also supported that syntax, we went with the prompting approach.

This could be fixed by adding another property which when true would disable the prompting.

jbarger Tue, 06/10/2008 - 08:11

Wow I am surprised that java can't close windows like VB script can by setting the openwindow to something other than null...

The addition of an option to disable SSH prompting would be cool and a default SSH user would also for the putty folks. I am just trying to reduce the number of clicks making changes to 200 boxes takes. Not that I make that many changes but sometimes !!! I know that is a job for config mngmt but how do you do no proxy arp to all routed interfaces in config mngmt?

While I am at it, add Ping and Tracert to the right click menu in topology! :)

I tried telnet with Firefox it doesn't prompt but it doesn't close the window either. We use Sharpoint so getting off IE is not possible.

It has been very nice to have someone to chat with about this that knows so much about the product.

Thanks again Jclarke have a great day.


This Discussion