DSL Configuration on SBC Global / ATT PPPoE need help

Answered Question

I am trying to get PPPoE DSL setup on a 2811 with SBC Global Internet and I am having some issues. I followed a configuration that was posted and everything worked and came up with full L3 connectivity to the internet until I did a reload on the router.


Upon Reload I get the following message about every second:


000066: *Jun 6 16:02:05.791 CDT: %DIALER-6-BIND: Interface Vi1 bound to profile Di1

000067: *Jun 6 16:02:05.795 CDT: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

000068: *Jun 6 16:02:09.679 CDT: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di1

000069: *Jun 6 16:02:09.683 CDT: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down


I must be missing something very simple, and ATT/SBC reps are trying to play the 'we dont support that router' game. Any help much appreciated, and points awarded.


Current Config (the relevant parts):

2811-2#sh run

Building configuration...


Current configuration : 9313 bytes

!


version 12.4

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service sequence-numbers

!

hostname 2811-2

!

boot-start-marker

boot-end-marker

!

security authentication failure rate 10 log

security passwords min-length 6

logging buffered 4096 debugging

!

no aaa new-model

!

resource policy

!

clock timezone CST -6

clock summer-time CDT recurring

no ip source-route

no ip gratuitous-arps

!

!

ip cef

no ip dhcp use vrf connected

!

no ip bootp server

!

ip ssh time-out 60

ip ssh authentication-retries 2

!

login block-for 10 attempts 4 within 3

vpdn enable

!

vpdn-group ppoe

request-dialin

protocol l2tp ! The guide I had put "pppoe" here which was not an option. I tried both l2tp & l2

!

!

!

!

!

!

!

crypto pki trustpoint TP-self-signed-

!

!

!

!

!

interface FastEthernet0/0

description Link to the LAN 192.168.1.0/24

ip address 192.168.1.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

no ip mroute-cache

duplex auto

speed auto

no mop enabled

glbp 50 ip 192.168.1.3

glbp 50 timers 5 18

glbp 50 priority 10

glbp 50 preempt delay minimum 30

glbp 50 load-balancing host-dependent

glbp 50 authentication md5 key-string 7 xxxxx

!

interface FastEthernet0/1

Shutdown

--More-- no mop enabled

!

interface ATM0/0/0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

no ip mroute-cache

no atm ilmi-keepalive

bundle-enable

dsl operating-mode auto

hold-queue 224 in

!

interface ATM0/0/0.1 point-to-point

no ip redirects

no ip unreachables

no ip proxy-arp

no snmp trap link-status

pvc 0/35

pppoe-client dial-pool-number 1

!

!

!

interface Dialer1

mtu 1492

ip address x.x.x.201 255.255.255.248 !yes this is the static block.

no ip redirects

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication pap chap callin

ppp chap hostname [email protected]

ppp chap password 7 xxxxxx

ppp pap sent-username xxxx.net password 7 xxxxx

!

router eigrp 10

passive-interface ATM0/0/0

network 192.168.1.0

no auto-summary

!

ip route 0.0.0.0 0.0.0.0 x.x.x.206 !ISP Router

!

!

no ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source list 10 interface Dialer1 overload

!

!

no cdp run

!

!

!

!

!

!

control-plane

!

!

!

!

!

!

!

!

line con 0

exec-timeout 60 0

logging synchronous

login local

transport output telnet

line aux 0

transport output telnet

line vty 0 4

login local

length 0

transport input telnet ssh

line vty 5 15

privilege level 15

login local

transport input telnet ssh

!

access-list 10 permit 192.168.1.0 0.0.0.255

!

dialer-list 1 protocol ip permit

!

scheduler allocate 20000 1000

sntp server 129.6.15.28

!

end



Correct Answer by paolo bevilacqua about 8 years 10 months ago

Hi, please send output of "show dsl interface", "debug ppp negotiation" "debug ppp autentication" with "term mon"

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.

See previous message for full description & config.


-------------- Dialer Int when no dsl:

2811-2#sh int dialer 1

Dialer1 is up, line protocol is up (spoofing)

Hardware is Unknown

Internet address is x.x.x.201/29

MTU 1492 bytes, BW 56 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP, loopback not set

Keepalive set (10 sec)

Last input never, output never, output hang never

Last clearing of "show interface" counters 01:13:42

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/0/16 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 42 kilobits/sec

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

1012 packets input, 83773 bytes

1113 packets output, 96320 bytes

Correct Answer
paolo bevilacqua Mon, 06/09/2008 - 13:10
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, please send output of "show dsl interface", "debug ppp negotiation" "debug ppp autentication" with "term mon"

paolo bevilacqua Tue, 06/10/2008 - 10:55
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Good. Also note:



vpdn enable

!

vpdn-group ppoe

request-dialin

protocol l2tp ! The guide I had put "pppoe" here which was not an option. I tried both l2tp & l2



None of the above is needed, whatever the guide says.



interface ATM0/0/0

bundle-enable


That doesn't do anything



dsl operating-mode auto


that is better set to itu


hold-queue 224 in

Really no need to increase input queue


interface Dialer1

dialer-group 1


PPPoE doesn't need dialer-group. Connection is always open.


router eigrp 10

passive-interface ATM0/0/0

That interface is not IP-enable, no need to make it passive.



ip route 0.0.0.0 0.0.0.0 x.x.x.206 !ISP Router


Alternative to that, use "ppp ipcp default router" under dialer


Thanks for the appreciation and good luck!

Thanks again!

I took all of your suggestions except for dsl operating-mode and default route since I have a static block to work with.


I am sure that I will come up with a few more questions, but it is great to have so many professionals that are willing to help out! I'll make sure to scan the forms a bit to return the favor.

paolo bevilacqua Tue, 06/10/2008 - 12:17
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

No worries, in networking (almost) everything has an explanation.


"dsl operating-mode" doesn't have perceptible differences except the router never attempts the legacy ANSI ADSL modulation that is not used anymore.


"ppp ipcp default route" installs the default route via PPPoE once established, no difference if you have a block or not. Really a matter of "being clean" more than anything else.


On the matter of having a static block, most likely you will use the additional addresses to route them (with NAT or without) to inside devices. Certainly you don't want them be routed back toward the PPP link, like your configuration does currently.


Actions

This Discussion