CCM 6.1.2.1000-13 Component Version mismatch

Unanswered Question
Jun 9th, 2008
User Badges:

Hello,


My customer has a cluster with 2 servers running CCM 6.1.2.1000-13 and when I look in the System Report/Unified CM Cluster Overview report, I have a bunch of components that are not the same version on both servers. I don't know how that happened because I am the one that installed all the patchs and upgrades and Locals and the servers have always been rebooted after the upgrades/patchs.


What brought me to look at that report is that my customer is complaining of is he is not able to make changes to a device and have the changes saved.


Please let me know if anyone had this problem before.


Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jaime Valencia Tue, 06/10/2008 - 09:53
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

which components show up as not in sync?


HTH


javalenc


if this helps, please rate

Tommer Catlin Tue, 06/10/2008 - 13:07
User Badges:
  • Green, 3000 points or more

Are you showing and DBreplication errors in the RTMT event logs?

egravel Wed, 06/11/2008 - 05:28
User Badges:

Yes there is replication errors in RTMT.


I did a "utils dbreplication repair all".

But I still have the components that are mismatch between the servers and I think I will continu to have those replication errors until I fix the component version mismatch.

Tommer Catlin Wed, 06/11/2008 - 08:11
User Badges:
  • Green, 3000 points or more

Sounds like you will need a TAC case to resolve the DB errors. I did some dbreplication tips such as stopping the replication on the each of the subs, then running the repair. I know TAC has a few other commands that may fix it.


If its bad, you may have to re-install the subscriber.


Was this a new install?

egravel Wed, 06/11/2008 - 09:17
User Badges:

The servers were initially installed with 6.0(1) and then upgraded to 6.1(2).


I did today a switch version on both servers to go back to version 6.0(1) and all the components are the same with CCM version 6.0(1). Re-did a switch version to go back to version 6.1(2) and the components are still not the same version. So I guess there is something that went wrong during the upgrade on the subscriber and I did not notice it.


I will probably try to reinstall the upgrade or re-install the server from scratch.

Tommer Catlin Wed, 06/11/2008 - 09:35
User Badges:
  • Green, 3000 points or more

yeah, the re-install of any subscriber is usually pretty painless. I have learned in the past dbreplications problems that take me more that 3 hours to fix are not worth my time when I can reinstall the subscriber is less than 2 hours.


good luck!

matt22coll Mon, 09/01/2008 - 07:16
User Badges:

Did you ever fix this problem. I have got the same issue and did the same upgrade path. I have noticed that all the components are all one out. For example sysvinit should be 4.3.0(110EL) ( The current version of the one below) and not 2.85(4.4) (the current version of the one above). Then this sequence keep going down the list.



The version of StorMan on is 2.85(4.4) and not 3.10(00)



The version of SysVinit on is 4.3.0(110.EL) and not 2.85(4.4)


The version of XFree86-libs-data on is 2.2.3(1) and not 4.3.0(110.EL)


egravel Tue, 09/02/2008 - 04:53
User Badges:

No i did not fix the problem, since it is a cosmetic bug (CSCsl61950). I had to open a TAC case to get the bug.

In the bug it says it is fixed in 6.1(2)1000-13, but i have that version running and i still have the problem.

matt22coll Tue, 09/02/2008 - 05:46
User Badges:

Same here, Some one has just told me that even thought it states it has been fixed in 6.1(2)1000-13 this sometimes on only means if you install this from new and dosent include upgrades

egravel Tue, 09/02/2008 - 06:05
User Badges:

There is a command that you can do in CLI on the publisher server and that will show that everything is in sync between all the servers. But i forgot what the command is :(


shabali52 Tue, 09/02/2008 - 06:13
User Badges:

> show tech version


This command displays the version of the installed components.


gmalli Tue, 09/16/2008 - 05:09
User Badges:

what is the first component out of sync ?


In my case, it was the IDP which was not installed on the subscriber.


After installing, everything is in sync now


shabali52 Tue, 09/02/2008 - 05:59
User Badges:

This is a known issue, Try the following:


1) Pick one of the components that it says is out of sync

2) Then on the Pub CLI: show packages active

3) Same on Sub

4) Compare the two


You will find they are the same!


And bug CSCsl71686 D => CSCsl61950


Its fixed in version 7.0

DanatShekhe Sat, 10/11/2008 - 21:26
User Badges:

I've same bug. After I got second server, its comes with ver. 6.1.2.1000-13, publisher was ver 6.0.1. I'm updated publisher to 6.1.2.1000-13 version, which was downloaded from cisco.com. After that I have components version mismatch. I have a question, why this bug fixed only in 7.0? I haven't access to this updates...


Can Clean install for publisher fix this bug?

Actions

This Discussion